Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   [FIXED] new bug for Central European (http://forum.bsplayer.com/bug-reports-codecs/11882-fixed-new-bug-central-european.html)

progh 3rd December 2010 12:01 AM

[FIXED] new bug for Central European
 
I can't save the subtitles to "Central European" script, it goes to "Western" after I restart bsplayer.




v2.57.1049 pro.

Edit by BSPeter: The (rather persistant) bug for "right-to-left" languages is reported to be repaired in version 2.58.1058 ("changes.txt")

black_ps 3rd December 2010 06:53 PM

new bug for Central European
 
Install for example bsplayer_pro257.1049 go to subtitles and set script to Central European, close bsplayer start it again,it will reset to Western , or install bsplayer_pro257.1048 and set Central European,then install 1049 and it will reset Central European to Western,using Windows 7 Ultimate x86 , i see the same problem as progh's

adicoto 3rd December 2010 09:33 PM

No such behaviour here. Central european since the begining. Had 1048 in CE, installed 1049, CE still active. 7x86 Ultimate

black_ps 3rd December 2010 09:55 PM

Quote:

Originally Posted by progh (Beitrag 43347)
I can't save the subtitles to "Central European" script, it goes to "Western" after I restart bsplayer.




v2.57.1049 pro.

Temporarily fix is to disable Use new subtitle parser/renderer and it will work. For this bug to confirm you need to have it ( [X] Use new subtitle parser/rendere ) in Subtitles enable so you will not be able to set Central European. Forget to tell you,not only Central Europe , any other that is not Western ( the default one ) will reset.

black_ps 3rd December 2010 10:23 PM

Quote:

Originally Posted by adicoto (Beitrag 43359)
No such behaviour here. Central european since the begining. Had 1048 in CE, installed 1049, CE still active. 7x86 Ultimate

Do you have [X] Use new subtitle parser/rendere enable?

adicoto 4th December 2010 06:11 AM

1 Attachment(s)
As attached.
I rather believe there is a problem with writing permisions on BS.Player's folder or on the xml file.

Code:


<SubFont type="font">238;Comic Sans MS;30;0;FFFFFF</SubFont>


progh 4th December 2010 12:07 PM

Quote:

Originally Posted by black_ps (Beitrag 43360)
Temporarily fix is to disable Use new subtitle parser/renderer and it will work. For this bug to confirm you need to have it ( [X] Use new subtitle parser/rendere ) in Subtitles enable so you will not be able to set Central European. Forget to tell you,not only Central Europe , any other that is not Western ( the default one ) will reset.

It's working...


Thank you.

black_ps 4th December 2010 04:51 PM

Quote:

Originally Posted by adicoto (Beitrag 43374)
As attached.
I rather believe there is a problem with writing permisions on BS.Player's folder or on the xml file.

Code:


<SubFont type="font">238;Comic Sans MS;30;0;FFFFFF</SubFont>


It has nothing to do with any permissions on folder as this text is there but if you enable Use new subtitle parser/rendere it will select itself Western ,and can't be changed,you change it,close bsplayer and then when you start it it's Western again.

BSPeter 4th December 2010 04:59 PM

As appears from adicoto's attached picture, he doesn't have "Use new parser/renderer" selected.
So it is unclear if he tested that.
:wink:

black_ps 4th December 2010 05:02 PM

Quote:

Originally Posted by BSPeter (Beitrag 43390)
As appears from adicoto's attached picture, he doesn't have "Use new parser/renderer" selected.
So it is unclear if he tested that.
:wink:

Yes i have seen,i can only confirm it with new subtitle reanderer

adicoto 4th December 2010 07:36 PM

1 Attachment(s)
Set to new engine, closed BS.Player. Opened again. Picture attached.

adicoto 4th December 2010 07:53 PM

Is it posible that this post:

http://forum.bsplayer.com/bug-report...-reversed.html

can add an info on this post. If the hebrew subtitles were displayed on western script (like in this post - where this setting is not remebered) it's posible that this effect occurs. If I recall correctly, hebrew use rigth to left writing and the western script just reversed the words. So, if the same bug (reset to western script) occurs in the above mentioned post, it's posible to have the reported effect.
On the other hand, as I've reported, no such effect in here, using new engine, central european stay selected. Played a movie with no problems. I still believe that there is a writing permisions bug and not an engine bug.

BSPeter 4th December 2010 08:32 PM

Yes, that's why I asked him to mention what script was selected. Unfortunately he didn't reply to that!
:wink:

black_ps 4th December 2010 09:00 PM

Quote:

Originally Posted by adicoto (Beitrag 43394)
Set to new engine, closed BS.Player. Opened again. Picture attached.

Anyway i have seen a lot of people completing about this problem,it's a bug for sure. I did try in Romanian and the same problem,very strange,maybe it's something to do with programs installed or something i don't know,for my is not working to select Central European only if i select the new subtitle engine,if i`m not selecting it i got no problem,so what permissions are we talking about?

adicoto 4th December 2010 09:19 PM

Don't really know yet where to go with the presumtions. But I have also installed PRO version on a friend's computer and does not have this issue (7x64 ultimate). Both computers are installed by me, with romanian regional settings as default, UAC disabled from the very begining and user + program files folders unset as read-only.

Azorel 5th December 2010 02:07 PM

EDIT by adicoto: bug also reported here:

http://forum.bsplayer.com/answered-s...html#post43412

just copied the concerning posts

Well it is possible that if we download from X that goes where we want but from Y goes into cache, now I know and I keep an eye on both place.

Staying on the subtitle issue, why every time when I get a sub. file the settings what I made in BSPlayer keep changing like to a "standard" settings?

I'm speaking about the sub. font size (I always set to font size 36) and script (I always chose "Central European" but it always jump back to "Western" at each new subtitle)? This was not happening in the previous BSPlayer version, when I set to size X and script Y that was implemented to ALL sub. files.
Any idea about this issue? Or this is normal?

Thank you all in advance and sorry to bother everybody with this nonsense!

Cheers

adicoto 5th December 2010 08:53 PM

Draga Azorel, din pacate inca nu am gasit solutii.
There is a workaround by un-checking use new subtitle engine in subtitle options

http://forum.bsplayer.com/bug-report...html#post43407

Mytusin 5th December 2010 09:53 PM

Problem with version 2.57 - Subs properties!
 
Hello, i'm from Romania and I downloaded the new version of BSplayer today 05.12.2010, it works ok but after BSplayer restart it didn't remeber my settings regarding subtitle, I mean.. Subtitles --> Primary --> Subtitles properties --> Font --> an here at "scripts" it doesn't remember my setting (Central european)...every time i start bsplayer return to the default settings.
What can I do?
Thanks

BSPeter 5th December 2010 10:01 PM

This concerns a bug. As a temporary solution please deselect "Use new subtitle parser/renderer" under
(rightclick >) Options > Preferences > Subtitles [Subtitle properties]
:wink:
(Note I merged your post and my reply thereto to the existing thread about this issue)

Mytusin 5th December 2010 10:23 PM

It works :)
 
Thank you very much for your quick response...i did what you told me and it works.
Thanks again!

BSPeter 6th December 2010 12:29 AM

Glad I was able to help you.
I will be even more happy if the bug is repaired soon.
:wink:

Ico-man 6th December 2010 09:35 AM

The problem appears only with new subtitle renderer in some cases of subtitle/OS language settings. We will fix this, in the mean time, the solution is to un-check Use new subtitle renderer.

New subtitle renderer will not be selected by default, until this is resolved. New version will be released today with old renderer being used as default.

black_ps 8th December 2010 03:11 PM

Not fixed in 1050

BSPeter 10th December 2010 06:35 PM

And in 1051? (I cannot test this myself).
:wink:

black_ps 10th December 2010 07:00 PM

Quote:

Originally Posted by BSPeter (Beitrag 43500)
And in 1051? (I cannot test this myself).
:wink:

Just tested,not working,this is a disaster.. Windows 7 Ultimate x86 Service Pack 1 all updates, UAC ( User Account Control Enabled )

Plavi269 13th December 2010 10:01 AM

Quote:

Originally Posted by BSPeter (Beitrag 43415)
This concerns a bug. As a temporary solution please deselect "Use new subtitle parser/renderer" under
(rightclick >) Options > Preferences > Subtitles [Subtitle properties]
:wink:
(Note I merged your post and my reply thereto to the existing thread about this issue)

Yes, you're right. But... When I deselect that I have a problem with subtitle in full screen mode. Last subtitle line stays on screen until the new one appears. On window screen mode everything is OK, but in full screen it's a problem.

Use new subtitle parser/renderer & above mentioned problem are connected!

BSPeter 13th December 2010 11:47 AM

@Plavi269:
You're using 1051 build?
If Vista or Win7: EVR renderer as Rendering mode?
( rightclick > Options > Preferences > Video > [Video rendering] )
Enabled drawing subtitles under image with EVR renderer?
( rightclick > Options > Preferences > Subtitles [Subtitle properties] )
:wink:

Plavi269 13th December 2010 03:44 PM

Quote:

Originally Posted by BSPeter (Beitrag 43551)
@Plavi269:
You're using 1051 build?
If Vista or Win7: EVR renderer as Rendering mode?
( rightclick > Options > Preferences > Video > [Video rendering] )
Enabled drawing subtitles under image with EVR renderer?
( rightclick > Options > Preferences > Subtitles [Subtitle properties] )
:wink:

Build 1048 - WIN7 - EVR renderer - drawing subtitles is enabled

When I disable drawing subtitles it solves a problem, but then another one appears... Secondary subtitle is automatic ON!

BSPeter 13th December 2010 03:57 PM

Forced second sub indeed was another bug.
Please update.
:wink:


All times are GMT +1. The time now is 01:55 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20