Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Subtitles

Subtitles Post question about BS.Player and subtitles (srt sub ssa mkv) here

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 1 Week Ago
Junior Member
BS.Player Newbie
 
Join Date: Jan 2021
Location: France
Age: 39
Posts: 6
Rep Power: 0
unlimited is on a distinguished road
Post Default Subtitles language is always "french" [in .mkv files]

Hello to BS-Player staff/forum!

I used BS-Player many years (10 maybe ) and i love it!
I have v2.76 free (build 1090) on win 10 Pro (in french OS default language).

I have recently learned to select automatically the default audio language for a movie/anime (often in .mkv) and it is working great as far as i know. (i watch a ton of anime always in Japanese Audio & Eng Subtitles, and movies/series always in VO Eng & Eng ST... even if i'm french.)

But i have a "bug/problem" with the auto/default subtitles language. My windows is in French, and so BS-player always auto-select the french subtitles (even if i specify "eng" in the option in subtitles; or a "track number" to select... which is not very useful to me because the order of the ST are not always the same in my many files to watch) in multi-sub .mkv files (that are current nowadays); Even if i switch to english for the menus of BS-Player, "french ST" are always taken first. The ST are .ass here, but i think .srt will do the same.

I tried many options in the ST section of BS-Player (launching BS-P in admin-mode too), but nothing works. I tried with external (exported from the .mkv file) files and then it shows than BS-Player always take the first in alphabetic order to play. (so there is no "auto selection" here if ST are in the same repertory as .ass, but i don't know if this feature is supposed to exist here )

I searched many hours in the forum & on google many times (and found some guy with the same problem in 2010), but never found an answer.

Even if there is a known bug here, if i just could modify/create a file in BS-player (.ini etc...), or trick it to take "Eng" instead for default selection of ST (which is clearly working for French i can see, but i simply can't select the language i want here)... or a plugin to select that, i will take it!

Thanks in advance!
Reply With Quote
  #2 (permalink)  
Old 1 Week Ago
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 53
Posts: 5,207
Rep Power: 29
adicoto is on a distinguished road
Default

Try to delete first all languages selected in subtitles options and after add just English
Reply With Quote
  #3 (permalink)  
Old 1 Week Ago
Junior Member
BS.Player Newbie
 
Join Date: Jan 2021
Location: France
Age: 39
Posts: 6
Rep Power: 0
unlimited is on a distinguished road
Lightbulb

Quote:
Originally Posted by adicoto View Post
Try to delete first all languages selected in subtitles options and after add just English
I am fairly good with computer by the way. Thank for the support!

I already tried that, but just in case i did it again (closing BS-Player for the option to be registered each time). Doesn't work. But so, it tells me that this feature is seemingly working with everyone now... :) (it is just me so... )

Test2: reinstallation of BS-Player in another fresh repertory and selecting "English" as default installation language. (i always use "save settings in home folder" to be portable). The skin is different so i can't make a mistake, i load my .mkv file (with multiple ST, and the English one is also marked "default" to play first BTW) and here the French ST is selected/playing as always... :( .
Tried another file too with less/different ST ([eng] & [fre] are clearly specified in each ST file), same! Always French ST no matter what i do!

So i have a doubt/idea, and i go to see the subtitles options in the fresh version... and it is written in the line : "Fre,Eng"! I didn't specify it... and then when i touch the line to edit it... the "fre," disappear (like it is hidden now).
I think i am on the problem here... If the FR text is really buggy/hidden, i can't modify it and whatever i type (or if i leave it blank) the "hidden 'fre' could be here first always"...
I will try some clever things to trick it... (i have one shot at this only before it disappears) and report here! All ideas are welcome!
Reply With Quote
  #4 (permalink)  
Old 1 Week Ago
Junior Member
BS.Player Newbie
 
Join Date: Jan 2021
Location: France
Age: 39
Posts: 6
Rep Power: 0
unlimited is on a distinguished road
Lightbulb

This is getting weirder...

I re-check files in the BS-P repertory and sorry i didn't see the "insfiles" one, with "BSplayer.xml" in it... I read/edit that with a text editor, and it seems i was right with the "disappearing act"... here in the file the line is like that:
<subDefaults type="string">1|fre,eng</subDefaults>

So i was glad i found this, i modified to "eng" only and saved... and when i try, BS-P continue to load the French ST even if it is not specified here!... (i tried to add eng then in the option too, but to no avail ).

I check my original BS-P, and in the .xml there is no mention of "fre" in the Subdefaults line... so the problem doesn't seem to come from here...

Will try some things today and report here!

Last edited by unlimited; 1 Week Ago at 05:36 PM.
Reply With Quote
  #5 (permalink)  
Old 1 Week Ago
Junior Member
BS.Player Newbie
 
Join Date: Jan 2021
Location: France
Age: 39
Posts: 6
Rep Power: 0
unlimited is on a distinguished road
Lightbulb

So when i uninstall my new/clean BS-P for testing, the codecs were removed too... when i tried to play my .mkv file it prompts me to install "Hali Splitter" if i remember correctly.

I installed all codecs again (see screenshot), and check if there was hidden options in LAV splitter (it is used when i play my .mkv file because i checked to see it in the taskbar when in use) and there were some (but blank) for the default audio & subtitles languages to take... so maybe i can modify here to resolve the issue.

OK i tried all options (and type "eng" or "eng,fre" as preferred language for ST), doesn't affect anything... (even the "no subtitles" one doesn't do anything, and the French ST are always loaded no matter what... they are the second ones after english, and not even marked as default in .mkv muxer options so i don't understand why it is chosen each time in different files).
Attached Images
File Type: jpg screenshot.51.jpg (137.7 KB, 2 views)

Last edited by unlimited; 1 Week Ago at 05:37 PM.
Reply With Quote
  #6 (permalink)  
Old 1 Week Ago
Junior Member
BS.Player Newbie
 
Join Date: Jan 2021
Location: France
Age: 39
Posts: 6
Rep Power: 0
unlimited is on a distinguished road
Exclamation

I realized today that the audio preferences don't work either... i watched another .mkv with jpn & eng audio stream and BS-P always select the one marked "default" in the mkv muxer and not the language preferences in the options of the prog... (my previous test was with jpn audios track all marked as default).

Maybe this will help troubleshooting the problem... (ST & Audio are not selected by the options of the prog... but by strange static rules )

Any idea to resolve this?
Reply With Quote
  #7 (permalink)  
Old 1 Week Ago
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 53
Posts: 5,207
Rep Power: 29
adicoto is on a distinguished road
Default

You can't change subtitle preferences by typing. Press the three dots button next to default language for subtitles and in the window that pops up, delete all languages and after that add just en. See the attached screenshot.
Also, try to switch to old subtitle engine (uncheck use the new engine)
Attached Images
File Type: jpg sub.jpg (101.0 KB, 2 views)
File Type: jpg sub1.jpg (71.0 KB, 2 views)
Reply With Quote
  #8 (permalink)  
Old 6 Days Ago
Junior Member
BS.Player Newbie
 
Join Date: Jan 2021
Location: France
Age: 39
Posts: 6
Rep Power: 0
unlimited is on a distinguished road
Exclamation

I already try deleting all language in the [...] windows; and set english language alone here etc... (and a bunch of variations) but just to be sure i retested and it don't work at all. (FR ST are always taken even without any language, no matter what)

I already tried "new or old" mode parser/renderer and a bunch of other options to make it work... nothing changes. (French ST always loaded in the list)

*

Could it be a windows registry key than i can access/delete to rewrite the content? (because it seems like a info that can't be overwritten by anything)

An other idea: Could a very simple plugin be created (or exist) to select at least one language for audio track, and one language for ST to be "invisibly & manually" (like with the mouse in the menu, but invisible) selected when opening a file? (it could search and select the first track/ST with the code of the language selected in its options so ; maybe could be done with simple internal line command options etc...)

It could be an easy & distributable fix for this problem (without trying for hours to see where the prog or windows is doing a wrong thing etc...) and i don't mind setting that here (instead of ST/Audio pref) if i know that doesn't work there for me!

*

(Very sad that doesn't work even if the options are there, because heavy users like me will want that quality option for their many files from everywhere to play with their prefs etc... it is a must-have for an advanced "pro" player)
Reply With Quote
Reply

Tags
default, french, language, mkv, subtitles

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bug with secondary UTF8 subtitles in MKV Ivanov Bug Reports And Codecs 4 20th February 2013 08:27 PM
crashes playing ogm or mkv files aok General Talk And Support 38 28th February 2006 10:58 PM
Default language fo subtitles MtK General Talk And Support 4 16th June 2005 04:00 PM
Default Subtitles in build 808. Ogm embedded subtitles Rober2D2 Bug Reports And Codecs 3 7th September 2004 07:26 PM
Testing subtitles, overlays and filters. Wormlord1442 Bug Reports And Codecs 0 5th February 2004 08:07 PM


All times are GMT +1. The time now is 04:02 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20