Official BS.Player forums

Official BS.Player forums (
-   BSPlayer for Android (
-   -   Transformer Infinity TF700 - Not playing from MicroSD (

psychoholica 17th August 2012 06:25 AM

Transformer Infinity TF700 - Not playing from MicroSD
Im not having any luck playing back videos on the new Asus TF700. I have a SanDisk 64 Gig card that began working with the Asus with the last firmware. Unfortunately, BSPlayer just says Error Playing File and moves on to the next one. Thumbnails generate and every once and a while you will see the first frame of video before it fails.

Any ideas?


Ico-man 20th August 2012 10:35 AM

As long as system can read the card, BSPlayer can do it also. Try to copy files to smaller card and test it there.

psychoholica 20th August 2012 07:30 PM

Hi, thanks for the reply. So I did a few tests.

Ran down to Frys and picked up a 8 GIG card and copied the same file to it, played back no problem! Yay!

I noticed that the 8 gig was formatted NTFS and my SanDisk Ultra 64 Gig was formatted exFAT. I thought for sure that was going to be the culprit.

I reformatted the 64 GIG to NTFS and copied my file back on it. Same thing. It begins to play then stops and goes back to the file browser. The copy speed from PC to MicroSD when formatted NTFS is 10x faster then exFAT though using a USB to MicroSD converter. Huh.

So, not sure why but the 8 gig el cheapo card works great, the fancy 64 Gig Ultra does not. Music and photos are fine on the 64 GIG just not video files.

Any thoughts?

adicoto 20th August 2012 08:51 PM

If you put the card into a computer, does the file play OK ? If so, it's still may be possible that the device doesn't correctly understand the card and looks for bytes in another place than they reallly are. So, BSPlayer loses connection with the file.

psychoholica 20th August 2012 10:48 PM

Well, I tried a few things today and think I have found the solution.

Apparently the .26 firmware update which "fixed" large sized MicroSD card support still needs some work on the Asus TF700.

I have the 64GB SanDisk Micro SDXC Ultra class 10 (mouthful) card which apparently as of yet is not fully compatible. I did try reading from my PC which worked fine, then i tried to copy the file from the card to the internal memory of the TF700. This failed. I then tried a few other means of moving it around, all failed. I formatted the card exFAT, NTFS, FAT32 and tried unsuccessfully FAT. All loaded the content fine but would not play in BSPlayer or move it to internal storage. Clearly this is an Asus issue.

I will say this, my write speed with FAT32 and exFAT was around 8Mbs, with NTFS it was just over 100! Im returning the card and ordered a new class 6 that is supposed to be more compatible based on some info I just read on this thread:

Micro SD Card List - Page 10 - xda-developers

Thanks for your help, hope this helps someone as well. I will be purchasing the full version shortly.

olorin2 24th September 2012 04:40 PM

Not sure if this is related at all, but I also own the TF700 and I can't even see my SD card files in BSPlayer. I posted about it here: (posted on the Galaxy Tab thread because it was the same issue I was having).

The SD card seems to be fine, because I can see its files in the file manager app. I have a 32gb SanDisk card (class 4), and unlike your card, movies seem to play okay once I can browse for them elsewhere. I just wonder if there is some compatibility issue with Asus that is causing various problems with sd cards.

Hope your new card works for you!

Ico-man 25th September 2012 08:43 AM

Do you have 2 SD cards present? We will check it.

Ahlitah 25th September 2012 04:42 PM

it works fine on my 64GB SD card in my TF700.

olorin2 25th September 2012 05:16 PM


Originally Posted by Ico-man (Beitrag 64054)
Do you have 2 SD cards present? We will check it.

Are you asking if I have 2 SD cards mounted in the tablet? No, just the one. I did take the one from the tablet and put it in my HTC Thunderbolt phone, and BSPlayer was able to see the SD card contents. When switching back to the tablet, I see nothing in those folders in BSPlayer. Really strange!

Psychoholica: Didn't mean to hijack your thread - just thought there may be some related incompatibilities with our TF700 tabs.

Bmedo 9th November 2012 01:37 PM

Transformer Infinity TF700 - Not playing from MicroSD
I have the same problem on TF700.
I can't see the contents of the micro SD(SDCARD1)CARD 32GB. It doesn't show the contents while browsing in BSplayer free.
It doesn't matter, whether i put it in micro SD slot or through adapter in SD port - both ways the same thing.

To see the movies from SD I run them from the Asus file manager.

BSPeter 10th November 2012 12:06 AM

On my (cheap) QW TB-1207 Android 4.0.3, it is a bit hard to find the external SD card too (in BSPlayer's browser mode).
When using FileManager you can directly (at the top bar) select either internal or external SD card (or USB or ... etc.).
However, BS.Player (in browser mode) will show you the internal SD-card with no fuss at all, but it takes a bit more to find the external SD-card.
First you (repeatedly) tap "Browse" till you get at the top (or root) of the tree.
Then, on my device, I have to tap on "mnt" (I assume this stands for "mount") and then select "extsd" ("sdcard" is also shown under "mnt", but that's the internal one).
What path further to follow - of course - depends on the structure you may have created yourself on your SD-card.
Maybe this is similar on other tablets, the owners of which have trouble to find their external SD-card using BSPlayer's browser?

All times are GMT +1. The time now is 08:29 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20