Official BS.Player forums

Official BS.Player forums (
-   Answered And Solved Questions (
-   -   [SOLVED] Bsplayer don't recognize the audio tracks (

kotzebu 5th July 2010 06:35 PM

[SOLVED] Bsplayer don't recognize the audio tracks

I have Bsplayer 2.53 and files with 2 audio tracks, when i open them the program displays a little windows showing "This file contains multiple audio tracks" but in audio option the selection of the streams appears in grey color (no option to select) and I only can listen one audio track.

I did reinstall ffddshow and i try it with 2 files and always the same problem.

How can i resolve it?

I will be very grateful to anyone who can help. Thanks


BSPeter 5th July 2010 09:55 PM

Unfortunately you fail to mention the type of the files you're talking about.
Also it may be usefull to know which codecs/filters are actually used by BS.Player for playback of such files.
To know this: (rightclick >) Options >Filters > Advanced.
This with a file loaded! Clicking on the small [+]-signs in front of the codecs/filters mentioned will reveal further info and access!
Given the message you quoted, I think you will find also DivX6.x there. If so, I'm afraid this really bloated codec will probably prevent more than one audio track to be used in any other player than DivX-player. (If instead you would e.g. use DivX5.2.1, you wouldn't have that problem and DivX5.2.1 isn't bloated either). If so: blacklist DivX6.x codec in BS.Player's Filter management. Then BS.Player will find another filter/codec to use for those files. (In this connection: when you installed BS.Player, did you allow BS.Player to download and internally (i.e. for use by BS.Player only and not interfering with your system's codecs/filters) install its preferred filters/codecs?)

Anyhow, maybe also try if using internal AVI splitter helps.
(rightclick >) Options > Preferences
Now keep [SHIFT]-key depressed while clicking on "Filter management".
Then check/select the box "Use internal AVI parser".

Two (already somewhat older) images where audio streams should be found:
As indicated in the image above use "Choose" if you want to select more than one stream at the same time; this will lead to another window:
P.S.: Concerning the DivX5.2.1 coded which I mentioned:

Originally Posted by BSPeter (Beitrag 18091)
.....First-time user? DivX-codec and AC3-Filter:
For users that are new to this, I would advise to start with a minimum installation (which is OK for playing most common avi's), i.e. the free DivX-5.2.1-codec, which - if you havn't already installed it - can be downloaded here. (Note: you only need the codec for playback, so you do NOT need to install the trial Pro-version and/or the DivX Player; also you do not need to "include Google", which are all included in this "bundle"; you can simply deselect these upon installation). [Special note to Win98 and WinMe users: make sure to not ever install DivX6 codec!]
After installation of DivX-codec please check settings on Tab "Quality", which can be reached directly through [Start] "Programs"/"DivX"/"DivX codec"/"Decoder configuration Utility". If "Support Generic Mpeg-4" is checked (selected) DivX-codec will e.g. also play XviD encoded movies.....

kotzebu 5th July 2010 10:55 PM

Problem resolved. I followed your instructions and it works correctly.

thank you verry much BSPeter.

BSPeter 5th July 2010 11:40 PM

Glad I was able to help you!

All times are GMT +1. The time now is 09:12 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20