Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/index.php)
-   Answered And Solved Questions (http://forum.bsplayer.com/forumdisplay.php?f=20)
-   -   Problem with .mkv and .mp4 (http://forum.bsplayer.com/showthread.php?t=12438)

FatSpanner 22nd October 2011 12:16 PM

Problem with .mkv and .mp4
 
Hi there, I've been using BSplayer for a good time and i have never used such a more awesome player. But when i reinstalled my computer and later installed BSplayer, i can't start a .mkv file (I'll get an error instant) and when i open a .mp4 file then it ask's if i have updated my codec even though i have installed the latest ones. But if i open a .avi file then it's zero problems! I tried to reinstall several times but with the same result

"BS.Player cannot play the media file.
You don't have necessary codec installed, file may damaged or not media file.

Click 'Find codec' to try to find codec."

The file is not damaged, cause I've been using VLC to open my files lately but i really want to use BSplayer! So please help me!

Thanks in advance
/Benjamin

adicoto 22nd October 2011 01:52 PM

Besides codecs, you also must install other filters such as splitters. One that can splitt MKV and MP4 files (like Haali media splitter) or individual splitters such as Gabest MP4 and Gabest NKV splitter.
So, when installed BSPlayer, did you allow it to install it's own filters (can be used only by BSplayer and don't mix with system ones) ?
If not, open codecmanager.exe from inside BSplayer's install folder and allow instalation for Haali and ffdshow (MPEG4 AVC support - usually requiered in MKV and MP4 files)

FatSpanner 22nd October 2011 02:49 PM

@adicoto

When i first installed BSplayer they did ask for the filters and i did install them, when i check at codecmanager.exe i had all the filters installed, i tried to uninstall Haali and reinstall it but with no result :/

black_ps 12th November 2011 12:45 AM

Quote:

Originally Posted by FatSpanner (Beitrag 46583)
@adicoto

When i first installed BSplayer they did ask for the filters and i did install them, when i check at codecmanager.exe i had all the filters installed, i tried to uninstall Haali and reinstall it but with no result :/



I have the same problem,i can't see MP4 , i got sound but no image.

BSPeter 12th November 2011 01:42 AM

Using this downloaded mp4 (1920x1080) playback is no problem with me!
(Under XP SP3, using i.a. Haali Media Splitter (Source), Gabest MPA Decoder filter and ffdshow Video Decoder; all "internally" installed by BS.Player's codecmanager for use by BS.Player only. So not using any special "BS.Player-external-filters" which I may have installed separately on my system.)
Could you also try/test?
(And post the filters used by BS.Player?
rightclick > Options > Filters > Advanced)
:wink:

black_ps 12th November 2011 01:50 AM

Quote:

Originally Posted by BSPeter (Beitrag 46788)
Using this downloaded mp4 (1920x1080) playback is no problem with me!
(Under XP SP3, using i.a. Haali Media Splitter (Source), Gabest MPA Decoder filter and ffdshow Video Decoder; all "internally" installed by BS.Player's codecmanager for use by BS.Player only. So not using any special "BS.Player-external-filters" which I may have installed separately on my system.)
Could you also try/test?
(And post the filters used by BS.Player?
rightclick > Options > Filters > Advanced)
:wink:


No the problem is bsplayer closes when i try to run that file,any other file working ok no problems. Windows 7 Professional X64, 4 GB ram,ati 5650 1GB. The problem i have is running file from computer not youtube,running file from youtube is working.

BSPeter 12th November 2011 12:03 PM

Maybe I wasn't clear enough, but I (also) ran that file without problems after having downloaded it to HD (I just mentioned it as a possible source for a reference file).
Am I to understand that BS.Player exits immediately when loading this file from HD? (MP4 is an associated extension of BS.Player?)
:wink:

black_ps 12th November 2011 12:05 PM

Quote:

Originally Posted by BSPeter (Beitrag 46794)
Maybe I wasn't clear enough, but I (also) ran that file without problems after having downloaded it to HD (I just mentioned it as a possible source for a reference file).
Am I to understand that BS.Player exits immediately when loading this file from HD? (MP4 is an associated extension of BS.Player?)
:wink:

Yes it closes after running the file,yes MP4 is an associated extension.

BSPeter 12th November 2011 12:14 PM

Quote:

Originally Posted by black_ps (Beitrag 46795)
Yes it closes after running the file....

Does BS.Player close after running (part of) the file or exit immediately when just trying to load this file from HD?
If you can load it without running, you can still report the filters/codecs used by BS.Player for this file.
If it exits, it does so without error report?
:wink:

black_ps 12th November 2011 11:33 PM

1 Attachment(s)
Quote:

Originally Posted by BSPeter (Beitrag 46797)
Does BS.Player close after running (part of) the file or exit immediately when just trying to load this file from HD?
If you can load it without running, you can still report the filters/codecs used by BS.Player for this file.
If it exits, it does so without error report?
:wink:

I have selected bsplayer to do nothing when finishes the file so now i can see what codecs are used,it exits without any error or something if i select close bsplayer on file finish of file.If i unselect close bsplayer on finish i got sound but no image.

BSPeter 13th November 2011 02:09 AM

When you installed BS.Player did you allow it to also "internally" instal its preferred codecs/filters? (Internally meaning for use by BS.Player only and not interfering with your system's codecs/filters).
What is shown under source?
:wink:
P.S.:
You probably installed some codec-pack?:eek:

black_ps 13th November 2011 02:18 AM

2 Attachment(s)
Quote:

Originally Posted by BSPeter (Beitrag 46805)
When you installed BS.Player did you allow it to also "internally" instal its preferred codecs/filters? (Internally meaning for use by BS.Player only and not interfering with your system's codecs/filters).
What is shown under source?
:wink:
P.S.:
You probably installed some codec-pack?:eek:

I only installed bsplayer internally codecs no codec-pack here.

adicoto 13th November 2011 06:50 AM

As the file is an MP4 should be using an AVC decoder (such as ffdshow if no other filter is installed - certainly not Window's 7 DVB built in decoder) and at least an AAC decoder (such as ffdshow + AC3 if they are installed)
When playing youtube's file, which filters are used ? The filters from the picture are used when playing the file you downloaded from youtube or another file ?
Can you post a link to that file...if is available ?

BSPeter 13th November 2011 12:08 PM

Link already posted (5th post in this very thread).
:wink:

adicoto 13th November 2011 01:43 PM

Asked for a link if...is another file ;)

BSPeter 13th November 2011 01:57 PM

Quote:

Originally Posted by adicoto (Beitrag 46811)
....The filters from the picture are used when playing the file you downloaded from youtube or another file ?
Can you post a link to that file...if is available ?

When reading I must have skipped the first sentence as quoted and focussed on the final "...if is available" part.
:embarassed:


All times are GMT +1. The time now is 02:36 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20