Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/index.php)
-   Bug Reports And Codecs (http://forum.bsplayer.com/forumdisplay.php?f=10)
-   -   Bug when playback subtitle in Chinese characters (http://forum.bsplayer.com/showthread.php?t=15)

mp3 13th June 2002 06:48 PM

Bug when playback subtitle in Chinese characters
 
When displaying Chinese subtitle, some single line become double line.

I play a divx movie with a .srt subtitle, which is in Chinese (Big5). For some lines, it broke into 2 lines and the second line cannot be seen. Just like this one:
http://logic.itsc.cuhk.edu.hk/~s9965...oad/bscap1.jpg

For this line it should be:
Code:

各種疾病很快就會成為過去
(These are chinese characters...the board would not display them properly and become some numbers...I'll put it here anyway)

I have checked the original file. And Vobsub can display it correctly as well. (Well....but sometimes Vobsub slow me down making sound and picture un-sync, that's why I use the built-in subtitle function of BSplayer)

I think it is becuase Chinese characters are double byte character.

Smarties 13th June 2002 07:43 PM

Just an idea...
 
I have never tried to use chinese subtitles so maybe I am
completely wrong.

But some ideas to try out could be...

* don't use overlayed subtitles. What happens then?
* try adjusting the subtitle position by moving it up

Hope this helps a bit...

Cheers, Smarties :P

mp3 14th June 2002 08:38 AM

No. They don't work.
Thank you anyway.


All times are GMT +1. The time now is 06:40 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20