Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/index.php)
-   Bug Reports And Codecs (http://forum.bsplayer.com/forumdisplay.php?f=10)
-   -   Wierd screenshots... (http://forum.bsplayer.com/showthread.php?t=1902)

silenttension 19th June 2003 05:35 AM

Wierd screenshots...
 
1 Attachment(s)
I just downloaded the newest version of bsplayer.. I open up a movie that is an .avi file.. But, it is an xvid codec.. but they turn out like this...
anyone know why?

ILM 19th June 2003 06:01 AM

Try right-clicking the player, going to options, preferences, then to the video tab and uncheck the 'Use overlay' box. That should work.

trodas 22nd June 2003 12:50 PM

For me, screenshooting did not work even then, not to mention that using overlay is damn recommended thing, so, BSplay should be able to save the screenshoot IMHO properly, even using overlay... :roll: :wink:

Deadmeat 23rd June 2003 04:20 PM

All xvid screenshots seem to be munted, but as far as i can tell it only happens with xvid.

bst 23rd June 2003 04:52 PM

Xvid usually uses YV12 color space.
Some graphics card can't convert from YV12 to RGB, but driver don't report this.
In next build I'll convert manually. So it will always work.

Deadmeat 24th June 2003 06:31 AM

Awesome :D

Being able to hammer p for a bunch of screenies is a heck of a lot easier than having to boost open something like virtualdub.

trodas 28th June 2003 11:47 AM

True.
Thanks, BTS, it not almost working :wink:

Only when grabing from videos, like Goldmember (604pixels x 256pixels)

It end that:

BSPlayer v0.86.500, Unhandled exception at EIP: 10001FC5
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Access violation at address 10001FC5 in module 'bsrendv.dll'. Write of address 0E939000
EAccessViolation
, 0x004C8C67, 0x004C8EE1, 0x004526B3, 0x00449D1E, 0x77E3A2B8, 0x77E16AE1, 0x77E24F54, 0x71784803, 0x71784722, 0x717847E1, 0x717B420D, 0x71784722, 0x71784642, 0x77E3A2B8, 0x77E145B1, 0x77E15B1D, 0x004DB842, 0x77EA847C


Bytes at EIP: F3 A5 03 F2 48 75 F6 8B 83 C4 02 00 00 5E 83 F8 01 6A


Hope this help debug the last bug, that bother me on BSplay :wink: :!:

And thanks for AMAZING work!

bst 28th June 2003 04:43 PM

Try latest build. Now it must work :)

Deadmeat 29th June 2003 08:20 AM

Works great for me. Cheers :)

trodas 29th June 2003 11:36 AM

True! Congratulations, BST! Now even the movies, what crashed before working fine :wink: :twisted:

Hoooray! Congratulations and thanks very much, dude!!! :!: :!: :!:

trodas 29th June 2003 12:47 PM

Ehm, nope, i was wrong. It works (eg. no crash) but producting a very weird screenshoots from certain movies.

http://sweb.cz/bbone/bscap0000.jpg

Help?

trodas 29th June 2003 10:19 PM

...anyway, all the 640 pixel wide movies are fine...

But there are few, what causing problems. Like Black Hawk Down (576x240), Goldmember (608x256), Go (720x416), Bridget Jones Diary (576x256), Mulan (720x416), Disturbing behaviour (576x320), Startrek first contact (704x320) or Not Another Teen movie (576x304)

Fix?

...not to mean the newly introduced subtitles timing problems :wink: :roll:
Please... fix? :cry:

trodas 8th July 2003 10:14 PM

BST, exourse me, but even the latest build from 7. 7. did not help there... :cry:

bst 11th July 2003 08:09 AM

Quote:

Originally Posted by trodas
BST, exourse me, but even the latest build from 7. 7. did not help there... :cry:

If you press Alt+3 (Video info) what Surface type is reported ?
Do you have checked 'Convert captured images in software' YV12 or/and YUY2 ?


All times are GMT +1. The time now is 09:38 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20