Official BS.Player forums

Official BS.Player forums (
-   Bug Reports And Codecs (
-   -   mpeg-1 layer 2 problem (

seblanders 6th October 2003 11:43 AM

mpeg-1 layer 2 problem
hi again!

after installing and uninstalling various codec packs for another problem, my pc seems to have a problem with mpeg-files, which are made with the mpeg-1 layer 2 audio-codec.

as far as understood the other posts about this codec, it is one of the most standard codecs around and usually is installed with windows. well, guess what: bsplayer provides me only with video, but leaves out the audio!

my questions are:
- how is it possible that this codec was deleted?
- how can i fix it?

my specifications are:
AMD XP 2000+ CPU
Geforce 2 TI 64MB Videocard
I run BSPlayer 0.86 build 501

my video-codecs are:
cvid;Cinepak® Codec;;Radius Inc.;
divf;DivX Video for Windows Codec;4
dmb1;M-JPEG V2;3
hfyu;Huffyuv lossless;;No information available;
i420;Microsoft H.263 ICM Driver;4.4.3400;Microsoft Corporation;
iv31;Intel Indeo R3.1;4.4.3400;No company info;
iv32;Intel Indeo R3.2;4.4.3400;No company info;
iv40;Intel Indeo® Video 4.5;;Intel Corporation;
iv41;Intel Indeo® Video 4.5;;Intel Corporation;
iv50;Intel Indeo® video 5.10;R.;Intel Corporation;
iyuv;Intel Indeo(R) Video YUV Codec;5.1.2600.0 (XPClientMicrosoft Corporation;Microsoft Corporation;
m261;Microsoft H.261 ICM Driver;4.4.3400;Microsoft Corporation;
m263;Microsoft H.263 ICM Driver;4.4.3400;Microsoft Corporation;
mrle;Microsoft RLE Compressor;5.1.2600.0 (xpclientMicrosoft Corporation;Microsoft Corporation;
msvc;Microsoft Video 1 Compressor;5.1.2600.0 (xpclientMicrosoft Corporation;Microsoft Corporation;
uyvy;Microsoft UYVY Video Decompressor;5.3.0000000.900 builMicrosoft Corporation;Microsoft Corporation;
yuy2;Microsoft UYVY Video Decompressor;5.3.0000000.900 builMicrosoft Corporation;Microsoft Corporation;
yvu9;Toshiba Video Codec;5.1.2600.0 (XPClientMicrosoft Corporation;Microsoft Corporation;
yvyu;Microsoft UYVY Video Decompressor;5.3.0000000.900 builMicrosoft Corporation;Microsoft Corporation;

my audio-codecs are:
0x0001;PCM;4.0 .0;Microsoft IMA ADPCM;
0x0002;Microsoft ADPCM;4.0 .0;MS-ADPCM;
0x0006;CCITT A-Law;4.0 .0;Microsoft CCITT G.711;
0x0007;CCITT u-Law;4.0 .0;Microsoft CCITT G.711;
0x0011;IMA ADPCM;4.0 .0;Microsoft IMA ADPCM;
0x0022;DSP Group TrueSpeech(TM);1.0 .0;TrueSpeech(TM);
0x0031;GSM 6.10;4.0 .0;Microsoft GSM 6.10;
0x0042;Microsoft G.723.1;1.2 .1;Microsoft G.723.1;
0x0050;QDesign MPEG;1.1 .0;QDesign MPEG;
0x0055;MPEG Layer-3;1.9 .305;MPEG Layer-3 Codec ;
0x0055;MPEG Layer-3;1.0 .63;MPEG Layer-3 Codec ;
0x0055;Lame MP3;4.0 .0;LAME MP3;
0x0062;Voxware v1.1.6/1.1.8 File-Mode Codecs;4.0 .0;Voxware CODECs 1.5.0;
0x0069;Voxware v1.1.8 Bitstream-Mode Codecs;4.0 .0;Voxware CODECs 1.5.0;
0x0074;Voxware MetaVoice;4.0 .0;Voxware CODECs 1.5.0;
0x0075;Voxware MetaSound;4.0 .0;Voxware CODECs 1.5.0;
0x0130;;3.2 .0;;
0x0160;DivX ;-) WMA Audio 1;4.2 .0;DivX ;-) WMA Audio;
0x0161;DivX ;-) WMA Audio 2;4.2 .0;DivX ;-) WMA Audio;
0x0402;IAC2;2.5 .53;Indeo® audio software;

CharlieX 6th October 2003 12:10 PM


I'm not sure, but I think that the MP3 codec installed with windows only supports MPEG1 Layer 3 audio (short MP3), but you're refering to MPEG 1 Layer 2 or MP2.
But as I said I'm not 100% sure if this is true.

adicoto 6th October 2003 02:35 PM

No, it is about an MPEG 2 codec. Windows don't have something like that. You must install one. Search for topics about mpeg2 and find there links to download.

seblanders 6th October 2003 04:07 PM

I'll try that!

seblanders 6th October 2003 08:23 PM

that doesn't work. I downloaded and Installed Elecard MPEG2 Video Decoder kit ver 2.0.

I am able to play other audio files that use the MPEG-1 layer 2 codec, but this particular file is played withoud sound.

Again, I tried the file on another PC and it worked fine. I tried the file on other players, but still no sound.

adicoto 6th October 2003 09:03 PM

On the pc it worked, right-click on the movie window, go to properties and there you have the codec used to play the file.

seblanders 6th October 2003 09:41 PM

doesn't work either.

on the pc where i can hear the audio, the codec used is morgan stream switcher. after installing the codec on my own pc, i still don't hear audio. but when i right-click and click on properties, the codec used on the pc is Moonlight Odio Dekoda

adicoto 6th October 2003 09:56 PM

Strange thing. Morgan stream swicher is not a codec but a stream swicher. It swiches between two audio chanels in one audio file. And it has a huge problem working with bsplayer. Odio dekoda is mp3 decoder supplyed by Elecard. Try using win media player you should have the MMS loaded and you can use it to swich the audio.

seblanders 7th October 2003 03:58 PM

i have both the elecard and the MSS-codec installed, but when I play the file with Media Player I don't get to choose codecs (or streams), it just plays the file with Moonlight Odio Dekoda.

adicoto 8th October 2003 01:14 PM

Is there any way you can cut something like 2-3 MB of your file and send the piece to me by email ?

seblanders 9th October 2003 08:19 AM

the only way i know to do that is with VirtualDub, but than I get an .avi-file and it's still huge if I have to use the same codecs (as in approximately 100MB).

seblanders 9th October 2003 08:32 AM

funnily enough my stereo (whick provides my pc with the sound) actually shows sound activity, but you can't hear it. also, this sound activity is only on the right side (so it's mono). i'm sure it's not the fault of my stereo, because it plays every other sound.

here are some more specifications of the file:
FileType: MPG
FileDate: 5/10/2003
FileRealSize: 462086512
FileTheoSize: 2651
FileDuration: 63
FileQuality: MPG1
VideoCodec: MPEG 1 (VCD)
vcSuppByVFW: 1
AspectRatio: 4:3
Width: 352
Height: 240
FramesNb: 79450
Fps: 29.970
VSec: 2651
VSize: 381081250
VAvgBPS: 1150
aStreamsNb: 1
AudioCodec1: 0051
a1Name: Mpeg-1 audio layer 2 [0xc0]
a1SuppByVFW: 1
a1Channels: 2
a1SamplesNb: 116909100
a1Sps: 44100
a1AvgBPS: 224
a1Sec: 2651
a1Size: 74228000
AudioCodec2: 0000

seblanders 9th October 2003 09:01 AM

I fixed the problem by deleting 2 identical VideoCodecs!

Thanks for the help everybody!

All times are GMT +1. The time now is 10:38 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20