Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/index.php)
-   Bug Reports And Codecs (http://forum.bsplayer.com/forumdisplay.php?f=10)
-   -   Problem With Italic Font (http://forum.bsplayer.com/showthread.php?t=2805)

peter 19th October 2003 09:58 PM

Problem With Italic Font
 
I have a problem if subtitles contain Italic font.
All works OK to the normal text for example:

1
00:00:10,500 --> 00:00:20,000
Text -Italic

2
00:00:20,500 --> 00:00:30,000
Text -Italic

3
00:00:20,500 --> 00:00:30,000
Text -Normal

4
00:00:20,500 --> 00:00:30,000
Text -Italic
-Sometimes is OK, but not always

5
00:00:20,500 --> 00:00:30,000
Text -Normal

6
00:00:20,500 --> 00:00:30,000
Text -Italic
-Here is never OK. Here should be Italic again, but is normal.


When I press Escape, then show me these Error:
BSPlayer v0.86.501, Unhandled exception at EIP: 0041C36E
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Canvas does not allow drawing
EInvalidOperation
, 0x004C9F33, 0x004CA1AD, 0x004526BB, 0x00449D26, 0xBFBCB402, 0xBFBB3A84, 0xBFBB3FF9, 0xBFBB3DFF, 0xBFB8D73D, 0xBFBB3FF9, 0xBFBB3ECD, 0xBFF7363B, 0xBFF942E7, 0x00008A60, 0x00058F64

When I Click Close, then show me these Error:
Bytes at EIP: F6 C3 02 74 07 8B C6 E8 4E 00 00 00 F6 C3 04 74 07 8B

Close:
BSPlayer v0.86.501, Unhandled exception at EIP: BFF7B997
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Access violation at address BFF7B997 in module 'KERNEL32.DLL'. Read of address 00002DD7
EAccessViolation
, 0x004C9F33, 0x004CA1AD, 0x004526BB, 0x00449D26, 0xBFBCB402, 0xBFBB3A84, 0xBFBB3FF9, 0xBFBB3DFF, 0xBFB8D73D, 0xBFBB3FF9, 0xBFBB3ECD, 0x0044E58E, 0x0044C7EB, 0x00437B77, 0x00449D26, 0xBFBCB402, 0xBFBB3A84, 0xBFBB3FF9, 0xBFBB3DFF, 0xBFB8D73D, 0xBFBB3FF9, 0xBFBB3ECD, 0xBFF7363B, 0xBFF942E7, 0x0000CCA6, 0x00058F64

Close:
Bytes at EIP: FF 76 04 E8 26 89 FF FF 5E C2 04 00 56 8B 74 24 08 8A


The Same Problem is in Different form of subtitles, for example:

{100}{200}{Y:i}Text -Italic
{200}{300}{Y:i}Text -Italic
{300}{400}Text -Normal
{400}{500}{Y:i}Text -Italic -Sometimes is OK, but not always
{500}{600}Text -Normal
{600}{700}{Y:i}Text -Italic -Here is never OK. Here should be Italic again, but is normal.


:cry: I hope that you will dispatch this problem in version 1.0 :D

adicoto 20th October 2003 01:07 PM

Sorry to disappoint you but this is not bsplayer's fault.
Error in kernel means it is time for a windows fresh install.

peter 21st October 2003 10:16 AM

Last time show me these Error:

BSPlayer v0.86.501, Unhandled exception at EIP: 0041C366
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Canvas does not allow drawing
EInvalidOperation
, 0x004C9183, 0x004C93FD, 0x004526B3, 0x00449D1E, 0xBFF7363B, 0xBFF942E7, 0x000085DC, 0x00058F64

When I click Close then show this:
Bytes at EIP: EB 05 E8 29 FF FF FF 33 C0 5A 59 59 64 89 10 68 43

Then program closed!
There is NO Kernel32.dll but the same problem.
I don't know why because everything works OK and I have no problem with Windows.

Even if I format disk and reinstall Windows there is the same problem.

If all text in subtitles is normal then everything works OK.
Even when I press Escape there is NO Errors, all works Perfect, but if subtitles contain Italic font then don't works OK.

There must be Error in BSPlayer!!!
Am I the only one with this problem?

adicoto 21st October 2003 02:38 PM

Nice guy you have at ther bottom. Yes, I do use xnet as a isp. But I am the only one around here. Wher did you get the guy with the banner ?
No, back to work, what videocard do you have, and what resolution do you use ?
What overlay mode do you have set in bsplayer settings ?

peter 22nd October 2003 09:31 AM

I have Windows 98, Celeron 433, 128 MB SDRAM, Hard disk Seagate ST-38410A 8.4 GB, Videocard GeForce 2 MX 400.

I try overlay mode 1 and 2.
I try to use old rendering mode.
When I try use Draw subtitles to Overlay surface, then all works OK to the Italic text, then should be normal again, but was Italic, then I press Escape...

If subtitles contain:
-Normal, Normal, Normal, Normal,...Text all works OK.
-Italic, Italic, Italic, Italic,...Text don't works OK.
-Italic, Normal, Italic, Normal...Text don't works OK.
-Normal, Italic, Normal, Italic...Text don't works OK.

Obvious BSPlayer has a Problem with Italic fonts!!!
I'm sure there is a BUG in BSPlayer!!!


O Yes, I get the green guy on www.danasoft.com


All times are GMT +1. The time now is 06:47 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20