Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/index.php)
-   Bug Reports And Codecs (http://forum.bsplayer.com/forumdisplay.php?f=10)
-   -   VobSubs don't show in bsplayer.ini mode (http://forum.bsplayer.com/showthread.php?t=407)

palesi 9th August 2002 04:06 PM

VobSubs don't show in bsplayer.ini mode
 
The movie filename is movie.avi, and i've created movie.idx and movie.sub with VobSub accordingly. The problem is that if i play the movie manually (starting BsPlayer, then opening the file) the subtitles show up, while if i play the movie automatically with the bsplayer.ini file they don't show up at all. In fact if i open the Properties menu and click on DirectVobSub there's no sub file opened in the Main tab, and i have to load it manually. Not very comfortable.

I have Windows XP and the latest BsPlayer (Build 490).

Any suggestions?
Thanks

Eduardovich 11th August 2002 09:22 PM

Re: VobSubs don't show in bsplayer.ini mode
 
I for a long time search for the answer to the given question

Really, somebody has explanations?

Thanks, too!

xlv600 24th September 2002 03:17 PM

I'm running v0.85.490 and vobsub v2.18 on XP pro SP1.
I'm facing this problem too. But it's half solved know.
In my bsi file I've written:

[SUBTITLES]
Directory=.
Sub1=Film.idx
DefaultSub=0

Now, I can use the [S] shortcut to enable/disable subtitles, but I can't use the shorcut I've setup to cycle through subtitles. (While it works without bsi file !)

A right-click on the movie let me select an other language from the [subtitles][language] submenu. This menu should list the N=6 languages indexed in the idx file, in fact I get 2N+1, that is 13 languages. The first one is blank, it comes from the bsi file, and the idx subtitles list appear twice. More over, 3 languages are checked in this menu, and not necessary the activated one.
If you asked for DVobSub properties from the same right-click menu, DVobSub would let you select from the true list of languages embedded in your idx+sub files.

Still investigating...
-----------------------------------------------------------------------------------
Nota1: It worked too with "Sub1=English|Film.idx" but this idx file contains the subtitles for 6 languages, not only English.
Nota2: With DefaultSub=4 I would get Arabic subtitles (index 3 language of my idx file).
Nota3: If you comment out Sub1 and DefaultSub names, then BSPlayer doesn't load subtitles. Even if you load them afterwards with DVobSub located in the tray bar, subtitles are displayed but BSPlayer is not aware of this. It's subtitle languages list is empty!

Sousuke 13th October 2002 01:57 AM

Re: VobSubs don't show in bsplayer.ini mode
 
Quote:

Originally Posted by palesi
The movie filename is movie.avi, and i've created movie.idx and movie.sub with VobSub accordingly. The problem is that if i play the movie manually (starting BsPlayer, then opening the file) the subtitles show up, while if i play the movie automatically with the bsplayer.ini file they don't show up at all. In fact if i open the Properties menu and click on DirectVobSub there's no sub file opened in the Main tab, and i have to load it manually. Not very comfortable.

I have Windows XP and the latest BsPlayer (Build 490).

Any suggestions?
Thanks

dude can u tell me what versions of vobsub and bsplayer are u using?
i cant even make my subtitles work manually :cry:

Quietseb 14th October 2002 07:04 PM

Quote:

Originally Posted by xlv600
I'm running v0.85.490 and vobsub v2.18 on XP pro SP1.

same for me (except win2ksp3) and it worked too last time I tried

thanks for the tip, btw :D

xlv600 15th October 2002 09:24 AM

Sousuke, you've resolved your problem here

But for others, I would add:
If you're interested in subtitles, even Chinese or Arabic... You should install vobsub v2.18, together with BSPlayer. The filter Dvobsub.ax needs routines from vobsub.dll to be registered.

Once loaded by BSPlayer (a green arrow appears in the tray bar), you may have to edit DVobsub filter settings to feet your needs.

DVobsub now comes with a great debug feature in it's "Misc" tab, that lets you show OSD statistics in real time. It can even help to troubleshoot BSPlayer...
As DVobsub works too with your windows media player (file:\\c:\Program Files\Windows Media Player\MPLAYER2.EXE), you should try it to make shure that your subtitles problems are not related to BSPlayer.

Sousuke 28th March 2003 01:05 AM

xlv600 the link you gave is inactive now...

could u update it pls!

thx

Sousuke 28th March 2003 01:05 AM

xlv600 the link you gave is inactive now...

could u update it pls!

thx

Sousuke 28th March 2003 01:10 AM

xlv600 the link you gave is inactive now...

could u update it pls!

thx

xlv600 28th March 2003 09:43 AM

Good morning Sousuke

Hey, is it so complicated to use the Search button to look for your own posts?

If you did it you would find This.

By the way, BSPlayer forum has several alias, and some become invalid. It's the reason why this link is now inactive, but you should learn to edit them by yourself if you don't want to stand in the way...

You should setup your browser to show the adreess of your current page (if it doesn't already). Look at the end of the current address, and replace in it the parameters found after php?, here: t=508 (the thread number I guess). That's all.


All times are GMT +1. The time now is 03:43 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20