Official BS.Player forums

Official BS.Player forums (
-   Bug Reports And Codecs (
-   -   script not working with embedded subtitles (

BSfan 8th December 2006 11:02 PM

script not working with embedded subtitles
I am a devoted fan of this great player from many years, it was always a pleasure to have a problem, where is that option instead of why it is not possible :))
However I have come to a problem lately regarding embedded subtitles in AVi files or MKV, which are not english - it seems that changing script option in subtitle font changes nothing. Sertainly subtitle files, which are separate files play ok, but once they are embedded, there is no way of displaying country specific symbols, regardles what is choosen in script combo box.

Version of player : BS Player pro 2.10 build 939 10 Jul 2006
Installed codecs: XVID (separately, not in pack), Haali media splitter.
Configuration: DELL Inspiron laptop,Intel 1795 Mhz,512 RAM

adicoto 9th December 2006 09:06 AM

Try to swich from Haali media splitter to Gabest Matroska splitter and the default avi splitter.

BSfan 9th December 2006 09:25 PM

I wish it would help...
Thank You fo Your answer.
I uninstalled Haali, registered Gabest and tryed to open the move. Well first it began to do buffering. After a while it received 100% and then nothing. All right, I figured out that maybe gabest do not support matroska 2 format so I converted the file to matroska 1 format. I started the move, buffering again but this time it was playing. Then I check what subtitles I can choose as the move has three - english from srt file, english from DVD and polish from srt. But when I looked to the subtitles menu, only first english srt was there! no other options available... that was a little dissapointment I must admit. Then I unregistered gabest and returned to haali, started the move - no buffering and in subtitles menu all embedded subtitles to choose as it should be. Unfortunately the original problem has not been solved yet...
Maybe gabest would display regional country characters correctly, but how to check it in this circumstances ? Besides if it recognizes only one subtitle embedded what is the point in using it ?

adicoto 9th December 2006 09:39 PM

Strange, I did tested MKV files with some 17 subtitles and no problems. And with my country specific fonts.
If you try to allow intermediate filters in subtitles options ?

BSfan 10th December 2006 08:48 PM

what about AVI ?
I allowed intermediate filters, unfortunately nothing has changed. But I don't know if dwelling on matroska is a good idea, because as I wrote in the first post AVI format is also involved, in my installation of haali AVI support is disabled. Doesn't it seems to You, that this is a format independent problem ?

Lets look on it from another point of view:

Imagine You watch a move, lets say in AVI. You use:
xviD-1.1.0-30122005 _Final Release
Native AVI splitter
MPEG Layer III decoder
And of course BSPlayer version as before.

You have subtitles in romanian language embedded (I must admit I know nothing about Your country specific characters, but nevermind)
You enter subtitle font dialog box.
You change the font size of the embedded subtitles - they are bigger
You change color, they obey
You make them bold, italic, crossed - they follow
You change font and they reflect the changes.
You change script - nothing, You change every possible option from script combo box and nothing changes. Why is that ??

Next You extract the subtitlest in srt format ffrom AVI container and try to play the move with subtitles as a separate file - this time script combo box acts as it should, Ypu see country specific characters. This is the same file.
Well ? What is Your conclusion ?

adicoto 10th December 2006 09:33 PM

Yes, I understand your point. Does upgrading to latest build of BSPlayer 2.12.941 solve the problem ? I can't test the same situation as you are because I do have the latest build.
Also upgrading XviD decoder won't be a bad ideea even this is not related to it.

Tizio 11th December 2006 11:09 AM

Re: script not working with embedded subtitles
If you (BSfan or adicoto) provide me a sample file I can test it..

adicoto 11th December 2006 09:57 PM

Yes, if you give me a postal adress, because I am talking about HDTV files (usually at least 4,5 GB), and the easiest way is to send them by mail (not e-mail). Just kidding. :)
I do have mkv files, sometimes with a lot of subtitles, but I don't have an embedded avi file (sorry about that) :oops:

Tizio 11th December 2006 11:45 PM


Originally Posted by adicoto
Yes, if you give me a postal adress, because I am talking about HDTV files (usually at least 4,5 GB), and the easiest way is to send them by mail (not e-mail). Just kidding. :)
I do have mkv files, sometimes with a lot of subtitles, but I don't have an embedded avi file (sorry about that) :oops:

Snail mail??? :lol:
If you want... :P

I'm too much busy/lazy to create one by myself..If you create one just give me a link and I'll test the file :wink:

BSfan 12th December 2006 01:16 PM

I have prepared file for testing purposes. Avi with embedded subtitles. 3.7 MB. If You give me email I will send it to You with precise informations.

Tizio 12th December 2006 02:21 PM

See your PM :wink:

BSfan 12th December 2006 04:38 PM


Originally Posted by Tizio
See your PM :wink:

What does it mean ??

Ico-man 12th December 2006 04:42 PM

PM= Private message

adicoto 13th December 2006 05:51 PM

I can confirm the bug using the file BSfan provided. Embedded avi file with polish subtitle. No matter wich script is selected you can't see specific chars. External subtitle works OK. To be tested the file in video editors.

LE: Other video player tested don't recognise the subtitle, also the video editing tool I use and the utility for codec identification. For now, a good point for BSPlayer, at least it does recognise the subtitle from the embeded avi. But the bug still a bug.

Headshot 19th August 2007 10:43 PM

i have similar problem, but on my system the external subtitles are not working properly too
some specific central european letter is not shown if the movie contains any kind of embedded subtitle..
someone knows how to disable the embedded subtitles? or any idea to solve the problem?

codecs used to play the movie:
(gabest) matroska splitter
coreavc video decoder
ac3 filter

i tryed many different font and script type, color and font size, unsuccesfully.. :(

speedtrap 22nd August 2007 01:02 PM

Have you tried disabling the internal subtitle renderer in BS.Player? Also enable support for intermediary filters in the options. Then install DirectVobSub. That is a subtitle filter.

This way you should be able to bypass the BS.Player bugs regarding subtitles.

All times are GMT +1. The time now is 10:22 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20