Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/index.php)
-   Bug Reports And Codecs (http://forum.bsplayer.com/forumdisplay.php?f=10)
-   -   Does not detect subtitles in .mkv videos (http://forum.bsplayer.com/showthread.php?t=8488)

joemamahunt 13th August 2007 10:27 AM

Does not detect subtitles in .mkv videos
 
Using latest BS Player Pro 2.23.

Does not detect subtitles in .mkv video files. Windows Media Player & other players do.

(cannot turn them on or select them, it just does not detect any)

adicoto 13th August 2007 06:14 PM

Gabest or Haali media splitter it's used ?

joemamahunt 13th August 2007 08:23 PM

Gabest, I think.

BSPeter 14th August 2007 12:44 AM

I would suggest to check your settings under
Options > Preferences > Filter management > [General]
("Allow intermediate filters" & "Enable advanced graph building" should be selected for non-text-based subtitles)
and maybe under:
Options > Preferences > Subtitles > [Subtitle properties] & [VobSub]
:wink:

adicoto 14th August 2007 06:22 AM

This is mainly Gabest splitter bug (though Haali poor support it's BSPlayer's fault). Sometimes Gabest splitter doesn't detect all subtitles (for example ssa and ass ones). As an advice, try to change to Haali (you may stumble upon the "cutoff subtitles" problem) but the support it's better for the included subtitles. Give it a try. :wink:

joemamahunt 14th August 2007 11:41 PM

Hmm.. still nothing.

If it helps:

Audio
Codec: Vorbis
Container: MatRoska/MKVmerge 1.7


Again, it works perfectly fine in all other players including WMP and Media Player Classic.

Maybe someone could look into this more?
From what I know I doubt it's the splitter.

Mister X 31st October 2007 01:48 AM

I have the exact same problem. I have Haali Splitter installed, CoreAVC, and AC3. I can't see the subtitles integrated in .MKV files. I've tried disabling the VobSub support in BSPlayer and installing the VSFilter, and enabling in that one, but all I get is subtitles in other programs, such as Windows Media Player and Media Player Classic.
I've tried everything that went trough my mind tonight, I've read the other topics on this problem, I've enabled the 2 options in filter management, and I still can't get subtitles to show up in BSPlayer.
Please help me out, because I really love this player. :)

ND88 1st November 2007 07:41 AM

i had the same problem and found the solution:

1) go to Preferences -> Subtitles.
2) make sure "Subtitles Disabled" is marked with a V
3) there u go, .mkv subtitles should now work

Mister X 1st November 2007 12:20 PM

ND88, I just tried that, and still, no subtitles.. This problem is really bugging the hell out of me.. It isn't the fact that I can't watch movies without subtitles or stuff like that, it's the fact that it annoys me that I can't figure out where's the problem..
More suggestions, anyone?

MegriM 7th November 2007 06:31 AM

same problem here too :?

Danglegin 12th December 2007 05:14 PM

I have the same problem. As many others here, I have tried everything that figured could help, but nothing came out of it.

Is there anyone with other ideas of what could be happening, as this is no new problem, and affects many of us?

Many thanks!

Farlight 15th December 2007 03:28 PM

Yup same problem here as well 2.25, my mkv doesn't display subs anymore even if hali media splitter say it's on and it works if you use FFDShow's "Sub" option.

melixron 19th December 2007 12:40 PM

same problemm.
Other players show subtitles, may be the reason is in Vobsub, all oter players, such as Media classic run Vobsub automatically, but BSplayer doesn't.
Is there anybody an idea, how to make Vobsub work with BSplayer.
That "Grenn Arrow" - is the Key :)

BSPeter 19th December 2007 08:31 PM

Already checked out fourth post (from the top) of this thread?
:wink:

melixron 19th December 2007 11:31 PM

ofcourse.
less words, - more actions - any wise solutions how to activate VobSub in BSplayer?

Tizio 20th December 2007 01:56 AM

Quote:

Originally Posted by melixron
ofcourse.
less words, - more actions - any wise solutions how to activate VobSub in BSplayer?

More words from you would result in less words from us and more actions to fix your problems.
As it's stated in BSPeter sign "Help2Help": Provide us the more information you can about the problem and what have you done to solve it and we will be able to help you ;)

BSPeter 20th December 2007 09:15 PM

Quote:

Originally Posted by melixron
ofcourse. ....

So, unless it is a big secret, maybe you could tell us what/how those settings (which I suggested to look at) are in your BSPlayer-setup?
:wink:

Prime9 28th December 2007 06:03 PM

another bsplayer user having this problem...

BSplayer 2.26, on Vista

Using haali splitter the tray icon appears, (in the files I'm testin, with both ASS and SRT sub streams), and the subtitles menu in BSplayer has all the options assocated with having found subs, but nothing is shown. Note it's the haali icon that appears, not vobsub :/.

Using gabest splitter there's no sign of subs anywhere

With either splitter WMP (shudder) and other players work fine.


In BSplayer's options subtitles are enabled, as are intermediate filters and advances graph building. I've tried it with EVR, VMR9 (and renderless) and overlay surface. In the subtitles I've tried with the subs drawn (and not) to the overlay surface, and playing with subs disabled. So far the best I've managed to is get Bsplayer to admit the subs might exist, but not display em yet.



For now I gotta run, I'll post back if me continuing to poke achievs anything, but for now I'm a bit stumped, reduced to installing/uninstalling stuff till something works or breaks further :(

adicoto 28th December 2007 07:14 PM

I think all this it's caused by the presence of ssa/ass subtitles inside container. I do have a lot of MKV files with 1-15 .srts inside and never had any problems with them. Using Gabest splitter, CoreAVC and AC3Filter. If I find some spare time, I will try to mux a ssa/ass subtitle into one of those files and test if that's the cause. SOmetimes maybe someone else will do it. :lol: :wink:

Prime9 28th December 2007 11:34 PM

well I seem to have solved the problem my end, I forgot I'd had the K-lite codec pack installed to test some other codec problems and didn't rip it out afterwards (damn that piece of bloated junk). Installed CCCP again and everything's hunky-dory.

One of these days I'll manage to finish testing the easy stuff before I post anything :/ oh well.


PS.

I'm hardly an expert on these matters, but all I can see that actually changed (from a cursory look) is that in the filters list, it's now using ffdshow rather than CoreAVC for video decoding. I guess there could be some milage in that. Anyway, I've got videos to watch!

lemon 29th December 2007 02:36 PM

I have this problem too and can't figure out a way to fix it. It seems I have tried everything. I can't believe a commercial player has such flaws.

I'm switching to MPC.

garren 3rd January 2008 03:58 PM

it seems that you guys are in a mess just like me before :(

i know, BSplayer got some bugs when playing mkv file, no subs, and all... but i love BSplayer so much and it seems that, im not sure if this solution would apply the same to you guys, but in my case, i MANAGED to get the subs played in mkv, and managed to make the mkv file played smoothly from beginning till the end. here's what i've done:

considering you guys already done what it need to show the subtitle in BSplayer option such as in preferences>filter management>tick both 'allow immediate filters' and 'enable advanced graph building' AND in preferences>subtitles>tick the 'subtitles disabled' and go to 'VobSub' tab, check the both option in there.

ok, now:

1-I install the latest k-lite mega codec full pack (version 3.6.5), yes, the MEGA, not the common one.(make sure to uninstall any other codecs first)

2-after that, i go to the ffdshow video decoder option that can be found at start menu>program>k-lite codec pack>ffdshow video decoder. the page at the right side of the window, you could see what kind of decoder is used for which codecs to apply to. noticed that the H.264/AVC the decoder for it is disabled (as default). click at 'disabled' and select 'libavcodec'. click ok.

3-now when you play mkv file, the subtitle should be showing by now (in my case, yes there's sub). notice at the taskbar where there's green arrow showing up too (vobsub).

4-double-click the vobsub, go to 'Misc' tab, tick the 'Pre-buffer subpictures' only IF its not tick yet. this is to make the video decoding become smoother, and there wont be like the video slowing down and the voice go play ahead without sync with the frame (in my case). and you're done.

and again, i dont know if these are applied to other users. but for me, it works like a charm tonight. i just wanted to share it with others. so... i would like to apologize if what i give out here didnt make the subtitle appear for mkv file.

feel free to try though.. :)

regards,
garren

adicoto 3rd January 2008 08:28 PM

Sorry to dissapoint you, but I have just 1 or 2 mkv files where subtitles don't work (I assume the subs are in ssa/ass format). The other files play OK, even with 10 different subtitles. Without VobSub or Vsfilter, just default settings in BSPlayer. And at this moment I am allmost sure that BSPlayer it's not the faulty one in here, unless the subtitles are in ssa/ass format.

speedtrap 3rd January 2008 11:31 PM

Since it works correctly in every other player including GraphEdit, the fault MUST be in BS.Player.

adicoto 4th January 2008 06:58 AM

Are you sure that GraphEdit uses the same decoders/filters/splitters as BSPlayer ?

Tizio 4th January 2008 11:02 AM

No, graphedit don't always use the same graph as bsplayer, the same applies to GSPot.. there you can choose the splitters and codecs to use, bsplayer tries to use the best ones (and sometimes fails)

adicoto 4th January 2008 06:25 PM

http://i16.tinypic.com/71ly4ia.jpg

speedtrap 4th January 2008 07:06 PM

Gabest's splitter does not support some of the more advanced Matroska features. People should not be forced to use another splitter because of bugs in the player. BS.Player should just be able to work together with Haali's splitter. It works correctly in MPC, WMP, GraphEdit, GSpot and ZoomPlayer.

BS.Player team should fix this bug.

adicoto 4th January 2008 07:16 PM

It's not about Gabest. See new image, with Haali.

http://i5.tinypic.com/6jejhhi.jpg

speedtrap 4th January 2008 07:50 PM

Sure it will work with some files, but not with for example SSA subs. Also I want to use DirectVobSub instead of the internal subtitle renderer. And yes, I have got thing configured correctly.

adicoto 4th January 2008 07:52 PM

For now, I am the only one specifying that ssa/ass may be a problem, and that's because BSPlayer's support fot this format it's almost 0. So, at this moment you are just quoting me, nothing new.

speedtrap 4th January 2008 07:59 PM

That is one of the reasons why I want to use DirectVobSub. That does support SSA and ASS subs.

DirectVobSub gets loaded correctly for embedded SRT subs. But once a file contains SSA/ASS, then DirectVobSub won't get loaded. So I suspect that the "Subtitles disabled" option in BSPlayer does not disable everything that it is supposed to do.

adicoto 4th January 2008 08:17 PM

If you select always load into VobSub options ?

speedtrap 5th January 2008 03:12 PM

Does not work either.

Here is a sample file:
http://www.matroska.org/samples/mewmew/index.html

Can someone from the BSPlayer development team please comment on this problem? Or better yet, fix it.

adicoto 5th January 2008 05:10 PM

I remember testing this file some 2 years ago, working fine, some 7-8 subs inluded, many colours. Downloading again.

adicoto 5th January 2008 05:21 PM

Same as always:

http://i10.tinypic.com/8a49jib.jpg


LE: You can't swich between subtitles :cry:

adicoto 5th January 2008 05:43 PM

Internal subtitle renderer may be the cause, also poor support for ssa/ass. Seems anime fans still have to wait until BSPlayer will be their first option.


All times are GMT +1. The time now is 10:45 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20