Official BS.Player forums

Official BS.Player forums (
-   General Talk And Support (
-   -   Problem with file associations (

Slym 6th January 2012 03:49 PM

Problem with file associations

my problems started couple of days ago when I tried to open a damaged .avi file with BSP. The file could not be opened, BSP offered me to check for suitable codec but it couldn't find one. I let it go, after that I did the usual work on my computer, I didn't install anything except Echolink software. I turned off the computer, and after turning it on again I noticed that .avi files I had on desktop changed to WMP icon, but I didn't do anything about. Later, I wanted to play a movie, but it opened in WMP. I draged the file to BSP, but it showed me an error DirectShow not installed...

I tried to uninstall BSP, restart the computer and install it again, but that didn't help either.
After that, I researched and found out that the error appears in the case of corrupted quartz.dll file. Then I tried to install DirectX 11, but since I'm using Windows 7 it's already integrated, it wouldn't allow me to install it. Then I took quartz.dll from another laptop with Windows 7 I mange and copied it to system32 folder. Now I wouldn't get the error and BSP would play a file if I dragged it to it. After that I tried to install DirectX again, but I got another error, so I deleted the DirectX key in the registry wich tells it what version is installed. After that I did a chkdsk /r /x /b, sfc /scannow and cleaned up and defragmented the registry with Registry Mechanic. I installed DirectX and BSP, went to BSP file types, unchecked them all, closed BSP, restarted the computer, checked them all again but nothing happens. When I go to Open with... and browse to BSP .exe file, I click open but nothing happens and it doesn't show up on the list. The same happens if i try it through Default programs in Control panel. I "uninstalled" the WMP but that didn't hel in any way either...

I reall don't know what else to do and I'm hopeless :sad::sad:

Slym 16th January 2012 03:12 AM

I managed to solve both the problems.

The first problem (getting the DirectShow not installed 00xx error) was due to BSPlayer's automatic codec installer manager. I got rid of the problem by uninstalling BSP and removing C:\Program Files\Webteh folder, then installing BSP and not allowing it to automatically download codecs. The problem appears if I allow it to install any of this codecs : FFDShow, MPEG 2 video codec, Real media spliter, Haali splitter.

The second problem was that BSP could not associate with files and wouldn't show up in "Open with" menu, even when browsed for. I solved this problem by finding this site Registering programs with the "Open With" dialog
and downloading the application. Then I just ran it, browsed to C:\Program Files\Webteh\BSplayer\bsplayer.exe, clicked "Register" and everything worked again.

I post the solutions here in hope I could help someone else.

Slym 16th January 2012 03:32 AM

So much about that. :omg: BSP doesn't keep the file associations. Every time I click to open a file, I get a "Open with" dialog. Now I can see BSP, I can clik on it, tick the "Always use this program..." option, BSP opens the file and plays it, but after that if I try to open the file again, I get the "Open with" dialog again... :confuse: :frown:

adicoto 16th January 2012 05:16 AM

Windows 7 ?

BSPeter 16th January 2012 12:16 PM

As indicated in Slym's first post: yes Windows 7 (so maybe UAC related).
What version of BS.Player? (Apparently 2.57 1051 had an association-bug:

All times are GMT +1. The time now is 07:39 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20