Official BS.Player forums

Official BS.Player forums (
-   General Talk And Support (
-   -   divx and xvid files lack sound in bsplayer (

Faburitius 23rd June 2004 04:11 PM

divx and xvid files lack sound in bsplayer
I have a problem with audio in divx and xvid files when i play them with Bsplayer or Media player: there is no sound at all. What makes it weird, is that sounds work fine with Divx player. Mpegs work with all of the players. What could cause this kind of behavior?

I have xvid 1.0.1 and divx 3.11 Alpha, 4.12 and 5.11 versions installed. Divx Player's version is 2.5.3 and I have the most recent version of BSPlayer. My display adapter is radeon 9700 with the latest Catalyst installed.

Thanks in advance

adicoto 23rd June 2004 04:44 PM

And you definetly lack some audio codecs and filters. See here for an AC3 decoder/filter

Faburitius 23rd June 2004 05:24 PM

Thanks for the tip but it didn't help. What can be so much different in DivX player compared to the others? Everything works perfectly in it. Otherwise I would be happy using DivX player but since it doesn't support subtitles, I must make BsPlayer work.

adicoto 23rd June 2004 05:55 PM

In windows explorer, if you right-click on file and go to properties, what does it say about video and audio ?
Also, when opening file with BSPlayer, go to options->filters and tell us what filters are in use.

Faburitius 23rd June 2004 06:15 PM

Here are the properties of the file:

Bit Rate : 164kbps
Audio Format : MPEG Layer-3

Frame rate : 25 fps
Data rate : 117kbps
Video sample size : 12 bit
Video compression: XVID

And BSPlayer uses the following filters :

- Hercules Game Theater XP 6.1 MP3 Decoder & Renderer
- XviD MPEG-4 Video Decoder

AVI Splitter and Source are grayed out.

Faburitius 23rd June 2004 07:59 PM

I finally found out the problem. My soundcard, Hercules Game Theater XP, had MP3 hardware acceleration enabled. Although it normally functions properly, something goes wrong when viewing videos with mp3 soundtracks. Apparently DivX Player overrides this setting and thus works even when its enabled. Disabling the setting solved all problems.

Thanks to adicoto for help.

adicoto 23rd June 2004 08:10 PM

Next step was to ask about your soundcard :lol:
If you search the forum about this problem surely you will find at least 2 posts about this problem and the solution.
Also try in audio preferences to use default directsound device.

All times are GMT +1. The time now is 10:59 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20