Official BS.Player forums

Official BS.Player forums (
-   General Talk And Support (
-   -   Problem trying to play a .dvr-ms file (

phoenix 12th January 2006 12:13 AM

Problem trying to play a .dvr-ms file
I just upgraded to version 1.37 Build 826 and was trying to play a .dvr-ms file recorded with Windows Media Center. I previously had version 1.32 build 820. In the older version, the recorded TV opened in the normal BS Player window where I could size the video to 16:9.

When I tried to open one of the files in 1.37, it opened in a window labeled ActiveMovie Window. I am unable to resize that window for aspect ratio.

As I can't get rid of it, I reverted back to 1.32.

I use a Windows XP SP2 computer that is less than 6 months old and I've never had this issue before.

I'd love to have 1.37 as it has a number of features that 1.32 doesn't have. Any help on how to get rid of ActiveMovie Window would be appreciated.

Tizio 12th January 2006 11:43 AM

To "get rid of" that ActiveMovie Window, you have to change the Rendering mode in BSplayer Video -> Video rendering Preferences.
Try with the default renderer :wink:

phoenix 12th January 2006 02:15 PM

Thanks for the advice. It was using the default renderer, but by playing around with that option I was able to find one where the movie played in the main window and not the ActiveMovie Window. I used the Overlay Mixer. THe ActiveMovie Window Still opens, but I can minimize it. :)

Using the VRM modes I could completely get rid of the window, but it compressed the video to square size in a rectangular window and had a lot of flicker.

While the solution I have is not perfect, it is workable.

Kyguy 14th January 2006 06:48 AM

I'm using "VMR9" (and mode 2 on the option below if that makes a difference) and it got rid of the annoying ActiveWindow

phoenix 14th January 2006 07:03 AM

Thanks, Kyguy, but that doesn't work for me. I end up getting a lot of flicker as it goes between filling the whole screen and being only half width with full height.

I think I've tried all the combinations and haven't found a perfect one, but I do have one that will get the recording in the BSPlayer window, which was my main priority.

Tizio 15th January 2006 10:11 AM

If you have problems with the aspect ratio, you can free resize the movie window if the "Keep Aspect Ratio" option (BSplayer menu -> Video) is unchecked.

adicoto 15th January 2006 10:32 AM

What filter is used to decode the file ?

phoenix 15th January 2006 03:58 PM

Tizio, if I get the movie in the BSPlayer window, I can resize it. The resize problem was in 1.32, so I consider that moot point as I'm using 1.37 now.

adicoto, while I'm not sure which filter this file uses, I think it might be the Microsoft Screen Video Decompressor since the file was recorded wtih Microsoft Media Center. I have tons of filters available since I have several video rendering programs on my comptuer.

adicoto 15th January 2006 05:06 PM

:) The one that is shown in BSPlayer's filters (options->filters) when playing the file.

phoenix 15th January 2006 06:12 PM

adicoto, looks like the Intervideo Video Decoder Line 21.

Though I now have a new issue. I have a new recorded show that won't play with the settings above. Okay, I get audio, but no video.

I can get it to show up when I switch to VRM9, but it flickers between full width and 2/3 width in both mode 1 and 2.

I guess I'll be going back to 1.32

I appreciate everyone's help and wish that we could figure it out.

New mix on the newly recorded file (this one not an HD format) I no longer get the ActiveMovie Window in the default mode, just a magenta screen and audio.

adicoto 15th January 2006 06:20 PM

Normally (I haven't played enough with Win XP MC to be sure) Microsoft products record in WMV format, not in AVI. So, the filter that should appear in use must be WM-DMO and not InterVideo. I repeat, I am not sure if they did not swich to AVI format (I really doubt about that) but I guess this is the problem. Do you have WMP 10 installed ? Either on the capture computer or the play computer.

phoenix 15th January 2006 06:54 PM

It's the same computer and all Media Players are up to date with the latest releases. I do not it is some sort of odd format as my main video editor, Vegas, will not accept input from the dvr-ms format, but Intervideo WinDVD will. I think that's why it's coming up as an Intervideo codec. As I said, I have a lot of video programs. In addition, my Roxio DVD creator won't recognize the format either and it will recognize most anything.

I've more or less given up on 1.37 and reverted back to 1.32 which works just fine. I just prefer the BSPlayer to the Windows Media Center player, mostly for the HD recordings. On the regular channel recordings I have no problem with the playback in WMC.

Well, maybe I'm not reverting back. I uninstalled all versions and reinstalled 1.37 from scratch and I can get it to on the 'overlay' render mode again. Now in the ActiveMovie Window I get a magenta screen with the closed caption info, but I can minimize that.

adicoto 15th January 2006 07:03 PM

Sorry, but I've did some reading. DVR-MS files are MPEG2 files. So you need an MPEG2 decoder, other than intervideo. Try elecard. It should solve the problem. PM me please.

DVR-MS files contain MPEG2 audio and video streams which is why a Windows XP compatible direct show DVD decoder is required for playback. If a DVD decoder is not installed media player will not play the file and give an error that it was unable to find a codec to playback the file.

adicoto 15th January 2006 07:18 PM

When browsing just stumbled on an MPEG2 decoder that is free and seems to work ok.

phoenix 15th January 2006 07:38 PM

The deskshare MPEG decoder gave me the same results as the Intervideo one.

I'm just going to call it quits and assume it has something to do with the plethora of codecs I have and something comes up as incompatible with the new version.

I never had any problems with 1.32 and Tizio gave me the hint I needed on the screen size changing. :)

adicoto 15th January 2006 08:48 PM

Seeking is disabled with this decoder. Swiching back to Elecard.

adicoto 17th January 2006 08:19 PM

The file I got from phoenix play OK in BSPlayer, using Elecard MPEG2 decoder and VMR9 renderless. File is 1024x576 @ 29,97

Filters in use:
- Default directsound device
- Video mixing renderer (quartz.dll)
- Elecard MPEG2 video decoder (
- line 21 decoder 2 (quartz.dll)
- mpeg audio decoder (quartz.dll)
- decrypt/tag =0, 0002 and 0003 (encdec.dll)
and, of course
- Source (sbe.dll - Stream Buffer Engine)

phoenix 17th January 2006 08:47 PM

adicoto, thanks for giving this a look for me. I'm glad to see there's a solution, but I'm not up for paying for another codec, so I'll live with the older version. :)

adicoto 17th January 2006 09:01 PM

I am not sure if it's the decoder or just the rendering option. Give it a try. Modify just the rendering option, maybe it will work.

phoenix 17th January 2006 10:14 PM

I tried all combinations of the rendering options. With the VRM options, I can get it in the BS Player window, but it flickers between full and 2/3 width. Using the 'overlay' mode, I can get it to play properly in the BSPlayer window, but the ActiveMovie Window still has to be open. So, yes, I can get it to work, but it's annoying to deal with the AMW. Okay, new devolpment on that, I lose the control panel, so that's a non-starter

I checked the Build 820 and it uses Overlay Mode 1 with the other settings the same.

All times are GMT +1. The time now is 07:31 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20