View Single Post
  #1 (permalink)  
Old 9th May 2003
igor igor is offline
Junior Member
BS.Player Newbie
Join Date: May 2003
Posts: 2
Rep Power: 0
igor is an unknown quantity at this point
Default bsplayer won't work properly

I can see that bsplayer is potentially a much better player than e.g. divx2.1, so I WOULD like to use it. However, I cannot make it working properly.

This is what happens in different situations with all my movies:

1.Remove all codecs, install ffdshow-alpha2003-04-24. bsplayer plays video, no sound.

2.Install DivX5.0.5Pro bundle. The same. divx2.1 player - video, no sound, complains about unknown sound format.

3.Install Nimo pack 5 build 9. divx2.1 player now plays video and sound flawelessy, still no sound in bsplayer.

gspot 2.1 says that movie sound is mpeg1 layer 3 and that the decoder is installed. However, in the "Details" window it says "...DirectShow was unable to render movie overall". In the "details" window of DirectShow it says "DirectShow was unable to play the file. The only information returned is the error message: Error number 0x80040218. Error name: VFW_E_CANNOT_RENDER. Full error text: No combination of filters could be found to render the stream".

Recall that nevertheless divx21. plays the movies ok. In bsplayer the volume knob is freezed, no sound.

Any help? I would also appreciate someone pointing me to a good review of video/audio codecs available. Most places I came across just tell you to do this and that without actually explaining why. I do and then something does not work, and I don't have a clue.

What I don't really understand in my current situation is how different players which are supposed to be independent on particular codecs (that' the whole idea, isn't it?) apparently do depend on them...

Another question: when I deinstall everything to start from a clean state, and run gspot on my video file, it still tells me video/audio codecs are installed and tells the same error message about DirectShow. I tried to remove the video codecs shown by gspot as installed, by hand, got complaints from the system that DirectX90 files are replaced by wrong versions. Apparently DirectX90 does include some codecs? I reinstalled dx90 after that complaint. What a mess... My OS is windows XP Pro.

Reply With Quote

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20