View Single Post
  #5 (permalink)  
Old 24th November 2010
Beaumis Beaumis is offline
Junior Member
BS.Player Newbie
Join Date: Nov 2010
Posts: 5
Rep Power: 0
Beaumis is on a distinguished road

I actually never tried the EVR renderer because it is not an overlay renderer. I tried it now and it works fine. However, since it is not an overlay renderer, it does not serve my purpose.

I have my PC connected to my TV via a HDMI cable. BSplayer has three renderers that should allow overlay mode, Internal Render Overlay, Internal Render RGB Overlay and the Overlay mixer.
  • The Internal Render RGB Overlay does not work. It does not maximize the picture on the second screen, but it does show subtitles.
  • The Overlay mixer does maximize the picture and does not have the green dots, but it does not display subtitles on the overlay screen, even with the "draw sutitles on overlay" option activated. (It shows them fine on the monitor.)
  • The Internal Render Overlay maximizes the picture, shows subtitles but does have the green dots issue.

I use a Desktop PC, have updated my gfx drivers several times to various versions (and back) since the problem appeared first, to no avail. I do not have a second monitor, but since the TV technically doubles as a monitor (and is build for that purpose), I think I can safely say it is independant of the screen and a software issue.

Notice that the problem appears only in a maximized screen and only if the "extend picture to 16:9" option is enabled. Other players have never shown this issue regardless of their options or video size. It is not related to subtitles directly, since it appears independant of whether or not I actually use them. (They are indirectly related as the render that has the dots issue is the only overlay render that shows subtitles on the overlay screen for me)

The whole point of my setup is to watch movies on my large TV screen, from my couch instead of my smalish monitor at my workdesk. However the monitor is in clean view from the couch and seeing the picture twice is irritating, hence the overlay fullscreen setup so the picture is either small or hidden behind other windows on the monitor screen.

So far, I have "solved" the green dots issue simply by changing to another render (such as the IR DDS) and maximize the picture on both screens and then turning the PC monitor off. While this works fine, I would prefer a solution that is not a workaround and allows me to keep the monitor active.

As before, any input is appreciated and I thank you for your time and effort so far. I apologize for the delays in replies, my life has been rather busy and my spare time rather limited lately.
Reply With Quote

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20