Official BS.Player forums

Official BS.Player forums (
-   Bug Reports And Codecs (
-   -   Does not detect subtitles in .mkv videos (

joemamahunt 13th August 2007 10:27 AM

Does not detect subtitles in .mkv videos
Using latest BS Player Pro 2.23.

Does not detect subtitles in .mkv video files. Windows Media Player & other players do.

(cannot turn them on or select them, it just does not detect any)

adicoto 13th August 2007 06:14 PM

Gabest or Haali media splitter it's used ?

joemamahunt 13th August 2007 08:23 PM

Gabest, I think.

BSPeter 14th August 2007 12:44 AM

I would suggest to check your settings under
Options > Preferences > Filter management > [General]
("Allow intermediate filters" & "Enable advanced graph building" should be selected for non-text-based subtitles)
and maybe under:
Options > Preferences > Subtitles > [Subtitle properties] & [VobSub]

adicoto 14th August 2007 06:22 AM

This is mainly Gabest splitter bug (though Haali poor support it's BSPlayer's fault). Sometimes Gabest splitter doesn't detect all subtitles (for example ssa and ass ones). As an advice, try to change to Haali (you may stumble upon the "cutoff subtitles" problem) but the support it's better for the included subtitles. Give it a try. :wink:

joemamahunt 14th August 2007 11:41 PM

Hmm.. still nothing.

If it helps:

Codec: Vorbis
Container: MatRoska/MKVmerge 1.7

Again, it works perfectly fine in all other players including WMP and Media Player Classic.

Maybe someone could look into this more?
From what I know I doubt it's the splitter.

Mister X 31st October 2007 01:48 AM

I have the exact same problem. I have Haali Splitter installed, CoreAVC, and AC3. I can't see the subtitles integrated in .MKV files. I've tried disabling the VobSub support in BSPlayer and installing the VSFilter, and enabling in that one, but all I get is subtitles in other programs, such as Windows Media Player and Media Player Classic.
I've tried everything that went trough my mind tonight, I've read the other topics on this problem, I've enabled the 2 options in filter management, and I still can't get subtitles to show up in BSPlayer.
Please help me out, because I really love this player. :)

ND88 1st November 2007 07:41 AM

i had the same problem and found the solution:

1) go to Preferences -> Subtitles.
2) make sure "Subtitles Disabled" is marked with a V
3) there u go, .mkv subtitles should now work

Mister X 1st November 2007 12:20 PM

ND88, I just tried that, and still, no subtitles.. This problem is really bugging the hell out of me.. It isn't the fact that I can't watch movies without subtitles or stuff like that, it's the fact that it annoys me that I can't figure out where's the problem..
More suggestions, anyone?

MegriM 7th November 2007 06:31 AM

same problem here too :?

Danglegin 12th December 2007 05:14 PM

I have the same problem. As many others here, I have tried everything that figured could help, but nothing came out of it.

Is there anyone with other ideas of what could be happening, as this is no new problem, and affects many of us?

Many thanks!

Farlight 15th December 2007 03:28 PM

Yup same problem here as well 2.25, my mkv doesn't display subs anymore even if hali media splitter say it's on and it works if you use FFDShow's "Sub" option.

melixron 19th December 2007 12:40 PM

same problemm.
Other players show subtitles, may be the reason is in Vobsub, all oter players, such as Media classic run Vobsub automatically, but BSplayer doesn't.
Is there anybody an idea, how to make Vobsub work with BSplayer.
That "Grenn Arrow" - is the Key :)

BSPeter 19th December 2007 08:31 PM

Already checked out fourth post (from the top) of this thread?

melixron 19th December 2007 11:31 PM

less words, - more actions - any wise solutions how to activate VobSub in BSplayer?

Tizio 20th December 2007 01:56 AM


Originally Posted by melixron
less words, - more actions - any wise solutions how to activate VobSub in BSplayer?

More words from you would result in less words from us and more actions to fix your problems.
As it's stated in BSPeter sign "Help2Help": Provide us the more information you can about the problem and what have you done to solve it and we will be able to help you ;)

BSPeter 20th December 2007 09:15 PM


Originally Posted by melixron
ofcourse. ....

So, unless it is a big secret, maybe you could tell us what/how those settings (which I suggested to look at) are in your BSPlayer-setup?

Prime9 28th December 2007 06:03 PM

another bsplayer user having this problem...

BSplayer 2.26, on Vista

Using haali splitter the tray icon appears, (in the files I'm testin, with both ASS and SRT sub streams), and the subtitles menu in BSplayer has all the options assocated with having found subs, but nothing is shown. Note it's the haali icon that appears, not vobsub :/.

Using gabest splitter there's no sign of subs anywhere

With either splitter WMP (shudder) and other players work fine.

In BSplayer's options subtitles are enabled, as are intermediate filters and advances graph building. I've tried it with EVR, VMR9 (and renderless) and overlay surface. In the subtitles I've tried with the subs drawn (and not) to the overlay surface, and playing with subs disabled. So far the best I've managed to is get Bsplayer to admit the subs might exist, but not display em yet.

For now I gotta run, I'll post back if me continuing to poke achievs anything, but for now I'm a bit stumped, reduced to installing/uninstalling stuff till something works or breaks further :(

adicoto 28th December 2007 07:14 PM

I think all this it's caused by the presence of ssa/ass subtitles inside container. I do have a lot of MKV files with 1-15 .srts inside and never had any problems with them. Using Gabest splitter, CoreAVC and AC3Filter. If I find some spare time, I will try to mux a ssa/ass subtitle into one of those files and test if that's the cause. SOmetimes maybe someone else will do it. :lol: :wink:

Prime9 28th December 2007 11:34 PM

well I seem to have solved the problem my end, I forgot I'd had the K-lite codec pack installed to test some other codec problems and didn't rip it out afterwards (damn that piece of bloated junk). Installed CCCP again and everything's hunky-dory.

One of these days I'll manage to finish testing the easy stuff before I post anything :/ oh well.


I'm hardly an expert on these matters, but all I can see that actually changed (from a cursory look) is that in the filters list, it's now using ffdshow rather than CoreAVC for video decoding. I guess there could be some milage in that. Anyway, I've got videos to watch!

All times are GMT +1. The time now is 12:13 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20