Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Answered And Solved Questions (http://forum.bsplayer.com/answered-solved-questions/)
-   -   Subtitle directory (saving sub.) (http://forum.bsplayer.com/answered-solved-questions/11885-subtitle-directory-saving-sub.html)

Azorel 3rd December 2010 11:48 PM

Subtitle directory (saving sub.)
 
Hello all,

I just downloaded the new free version of bs player and I sow that each subtitle what it gives me and downloading it throws in the file of
C:\Program Files\Webteh\BSplayer\cache\
so I went to settings>preference>subtitle and set that each time when new subtitle will be downloaded it will save to a directory named "Subs" in the folder where the movie is. Now here comes the problem:
- it does create the folder "Subs" but not in the same folder where the movie is, it create in the previous director where my movie is stored (i.e. Action/[movie folder name] the Subs would be in Action and not in the "[movie folder name]"), to make it worst, he don't even put in the "Subs" the downloaded subtitle, he put it in the:
C:\Program Files\Webteh\BSplayer\cache\

Can someone tell me what is wrong here? Or I could jump back to the previous free BS Player version?

Thanks in advance for any tips or help.

PS: Sorry for my bad English.

BSPeter 4th December 2010 01:55 AM

Works correctly overhere. [Using XP SP3 - BS.Player 257.1049 (Pro)]
Are you perhaps using Vista or 7?
Sufficient rights/privileges for folders concerned?
UAC?
:wink:

Azorel 4th December 2010 10:29 AM

This is my system:
http://i236.photobucket.com/albums/f...ntitled-17.jpg

And this is the setting what I made so that the sub. files be saved where movie is:
http://i236.photobucket.com/albums/f...7/bsplayer.jpg

I tried many times to do it over and over, even changed language but still it saves in C:\Program Files\Webteh\BSplayer\cache\. I always must take the sub. files out of there and paste into the movie folder after i edit the files name cos in "cache" it saves with a code+[movie name].

PS: I'm talking about the FREE version bsplayer257.1049_video.exe (60MB), sorry that i didn't mentioned this before.

Azorel 4th December 2010 10:42 AM

Problem solved, I uninstalled the bsplayer and reinstalled.

Sorry for double post.
Topic can be closed and thx for your kindness!

BSPeter 4th December 2010 04:22 PM

All's well that ends well!
:wink:

adicoto 4th December 2010 08:12 PM

I can confirm there is a bug in here. Downloaded a subtitle and found it in cache folder and not in movie folder.

BSPeter 4th December 2010 08:37 PM

Quote:

Originally Posted by BSPeter (Beitrag 43370)
Works correctly overhere. [Using XP SP3 - BS.Player 257.1049 (Pro)]...

Another issue where our experiences differ!
:wink:

adicoto 4th December 2010 09:11 PM

Now, another cloud of fog. If you download the subtitle from bsplayer- subtitles.com, it gets into the cache folder. If you download the same but from opensubtitles.org, it gets into movie folder. Probably not a bug but a BS.Player option to keep trace of the subtitles downloaded from BS site vs the ones from another provider. So, it is posible that while my countryman was right (but first downloaded a subtitle from bs-subs.com and second from opens.com) was right in his posts, BSPeter was also right (but downloaded just one subtitle from opens.com and not from bs-subs.com)

On the other hand, even if romanian subtitles are found, english ones are selected by default.

Azorel 5th December 2010 02:07 PM

Well it is possible that if we download from X that goes where we want but from Y goes into cache, now I know and I keep an eye on both place.

Staying on the subtitle issue, why every time when I get a sub. file the settings what I made in BSPlayer keep changing like to a "standard" settings?

I'm speaking about the sub. font size (I always set to font size 36) and script (I always chose "Central European" but it always jump back to "Western" at each new subtitle)? This was not happening in the previous BSPlayer version, when I set to size X and script Y that was implemented to ALL sub. files.
Any idea about this issue? Or this is normal?

Thank you all in advance and sorry to bother everybody with this nonsense!

Cheers

adicoto 5th December 2010 08:53 PM

Draga Azorel, din pacate inca nu am gasit solutii.
There is a workaround by un-checking use new subtitle engine in subtitle options

http://forum.bsplayer.com/bug-report...html#post43407

Ico-man 6th December 2010 10:28 AM

Regarding "I'm speaking about the sub. font size (I always set to font size 36)"

Deselect all options under tab 'Font sizes' and BSPlayer will always display subtitle with the exact size you specify in 'Font'.

Ico-man 6th December 2010 10:55 AM

Quote:

Originally Posted by adicoto (Beitrag 43406)
Now, another cloud of fog. If you download the subtitle from bsplayer- subtitles.com, it gets into the cache folder. If you download the same but from opensubtitles.org, it gets into movie folder. Probably not a bug but a BS.Player option to keep trace of the subtitles downloaded from BS site vs the ones from another provider. So, it is posible that while my countryman was right (but first downloaded a subtitle from bs-subs.com and second from opens.com) was right in his posts, BSPeter was also right (but downloaded just one subtitle from opens.com and not from bs-subs.com)

On the other hand, even if romanian subtitles are found, english ones are selected by default.

No distinction is made regarding subtitle provider and place where to save subs. If the user sets option save subs to movie folder, BSPlayer will always try to save subtitles there; if this option is not set, it will always save subtitles to cache folder. We cant reproduce this behaviour yet.

Do you have both languages selected under 'Default subtitle language'?

adicoto 6th December 2010 03:38 PM

Quote:

Originally Posted by Ico-man (Beitrag 43431)
No distinction is made regarding subtitle provider and place where to save subs. If the user sets option save subs to movie folder, BSPlayer will always try to save subtitles there; if this option is not set, it will always save subtitles to cache folder. We cant reproduce this behaviour yet.

Tested, tested, tested and after that posted. As last days were confusing in behaviour and bugs, I tryed to be as accurate as possible.

Quote:

Originally Posted by Ico-man (Beitrag 43431)
Do you have both languages selected under 'Default subtitle language'?

Default languages, RUM, ENG, in this priority

Ico-man 7th December 2010 01:44 PM

First selected 'preffered language' is primary (in your case RUM), when there are no subs for that language, the second choice (ENG) will be checked by default, if sub in second language is not available, third language will be selected... This is how it should work.

If there are available subtitles for both languages, only primary (RUM) will be checked automatically.

Regarding BSPlayer saving subtitles found online into different folders, we are still checking it.

adicoto 7th December 2010 03:54 PM

Probably my post wasn't clear enough.
BS.Player found subtitles, both romanian and english. By default, english ones were checked, not romanian ones, even RUM is the prefered language (first in list = primary).
Seems to be fixed in build 1050.

adicoto 8th December 2010 08:41 PM

1 Attachment(s)
Or not :bug:

Azorel 8th December 2010 08:56 PM

Thank you for your time and kindness. Lately I didn't had much time to watch a movie.. it's the end of the year and my work take all my time up.

Ico-man 9th December 2010 08:10 AM

Quote:

Originally Posted by adicoto (Beitrag 43475)
Or not :bug:

Please try 1051.

adicoto 9th December 2010 01:23 PM

1 Attachment(s)
Same :bug: in new build

BSPeter 11th December 2010 06:55 PM

I just tested (running build 1051; new subs engine; XP SP3) with "rum, eng" as "Default subtitle language" and ... I cannot confirm adicoto's problem.
Romanian subs pre-checked; the English are not.
You didn't test with a previously played movie and "Remember movie settings" selected by any chance?
(I also had to deselect "Download only if local subtitles are not available", otherwise it would meanwhile find sufficient subs on my HD because of previous testing.)
:wink:


All times are GMT +1. The time now is 03:24 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20