Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Feature Requests, Feedback And Suggestions (http://forum.bsplayer.com/feature-requests-feedback-suggestions/)
-   -   AC3 Filter (http://forum.bsplayer.com/feature-requests-feedback-suggestions/3426-ac3-filter.html)

Carl Lewis 9th December 2003 03:24 PM

AC3 Filter
 
Hi 2 all

1) BsPlayer 4ever !!! :-)
2) When playing divx ao xvid with AC3 audio, AC3 filter properties is not present in the filters list. In previous versions it works.

HI :D

Fallen 13th December 2003 10:09 AM

Re: AC3 Filter
 
Quote:

Originally Posted by Carl Lewis
Hi 2 all

1) BsPlayer 4ever !!! :-)
2) When playing divx ao xvid with AC3 audio, AC3 filter properties is not present in the filters list. In previous versions it works.

HI :D

I have same problem... Audio preferences ISN'T WORKING as they worked in previuos versions :evil: ... and there aren't so many options... and even i have 5.1 hometheater system I can't get S/PDIF work.. because I can shoose it but it doesn't remain!(when I go again to preferences there is no speakersystem chosen even i just put mark to S/PDIF... :? there are also lot of another things in preferences which doesn't work... And the worst thing.. i cannot find older version :(

Carl Lewis 15th December 2003 12:57 PM

Quote:

And the worst thing.. i cannot find older version
Give me an a-mail address and i send you 086.499 version.

adicoto 15th December 2003 03:23 PM

Do you use AC3Filter or intervideo decoder ?

Carl Lewis 16th December 2003 02:23 PM

Quote:

Originally Posted by adicoto
Do you use AC3Filter or intervideo decoder ?

AC3Filter
Codec works, but the player don't display its properties.

adicoto 16th December 2003 05:27 PM

Options->filters, AC3 filter settings are showed. All is OK here. AC3Filter ver 0.7, BSPlayer 1.803. What are your versions ?

BSPeter 16th December 2003 09:56 PM

You should also be able to configure AC3filter through (default)
[Start] > Programs > AC3filter > AC3 Filter config.
(Further - if you really need it - you can find actual version as well as previous versions of BSPlayer here!)
:wink:

hugohenrique 5th January 2004 04:52 AM

same ac3 filter properties problem here
 
hello all, I have the same problem. I got all the final versions, bsplayer and ac3filter, but the ac3 filter properties is gone. I can't make any changes I was able to do with 0.8 Bsplayer versions on AVI with AC3 sound. Even if I go to ac3 filter folder on start menu, the changes I make there don't work out on the movie.

Thanks,
Hugo

maGot 6th January 2004 12:19 AM

I have the same problem. Think that's the only problem i have with bsplayer. Hope it will be fixed soon!

BSPeter 6th January 2004 02:10 AM

Have you tried reaching the filter (with a movie loaded) through right-click > Options > Filters > Advanced ....?
:wink:

maGot 6th January 2004 10:55 PM

That dose not have any effekt. I can only look at the codecs there. And the ac3 filter is not in the list.

BSPeter 7th January 2004 01:47 PM

I apologize: you're wright. In 803 build AC3 filter isn't shown like it did e.g. in 501 build. (Had to find a movie with AC3 sound in my collection before I could test it.)
:(

maGot 9th January 2004 02:56 PM

Thats ok! Do you think it will be fixed in the next version?

adicoto 9th January 2004 09:36 PM

In build 803 ac3filter 0.7 certainly is shown in filters. But only if is an AC3 stream. For videos with MP3 you must use matrix mixer if you want 5.1 sound.

BSPeter 9th January 2004 10:55 PM

Quote:

Originally Posted by adicoto
In build 803 ac3filter 0.7 certainly is shown in filters. But only if is an AC3 stream.

Nope, not with me.
Tested with 2CD-James Bond movie "Die Another Day" (XVID - AC3 48.000Hz - 2Ch.)
Played with build 501: yes, AC3 filter shown.
Played with build 803 (on very same PC) with AC3Filter selected under "For AC3 decoding use": nope! (played by Microsoft's quartz.dll)
:wink:

adicoto 10th January 2004 08:20 PM

Tested with my old HArry Potter 1 who has 5.1 AC3 audio. I'll search for an 2 AC3 audio soundtrack and test with that to.

BSPeter 10th January 2004 10:41 PM

Also tested with CD1 of Harry Potter and the Sorcerer's Stone (DIV3 - AC3 48000Hz - 5 Ch.) and result is the same: AC3filter again shown in build 501 and not in build 803. Build 803 only shows Default DirectSound Device (=quartz.dll)
Avicodec render details are as shown below
(Edited/Correction: Of course these are GSpot render details and not Avicodec! Thanks adicoto)
:wink:
http://members.home.nl/van.raak/AC3filter.png

adicoto 11th January 2004 12:20 AM

1 Attachment(s)
This is Gspot you are talking about.

adicoto 11th January 2004 12:26 AM

1 Attachment(s)
And those are the filters declared by avicodec:

BSPeter 11th January 2004 12:15 PM

Quote:

Originally Posted by adicoto
This is Gspot you are talking about.

You're so very right of course. As a matter of fact I almost never use Avicodec, but prefer GSpot, so a very strange "slip of the typing fingers" by me indeed!
To even show you the difference better see top half (for build 501) and bottom half (for build 803) of the below picture for the same movie on the same PC. Under builld 501 AC3 filter is shown and fully accessible, on build 803 it doesn't show AC3 filter (picture shows the Advanced section).
:wink:
http://members.home.nl/van.raak/build501_803.png

adicoto 11th January 2004 02:36 PM

1 Attachment(s)
Yes, strange things happening around. Something is mixed-up. But on who's computer, yours or mine. Is there an explanation we can give to those who read this thread ? Ialso add an atachement with advanced properties. I find an AC3 2 channel file, Runaway Jury. AC3 filter is also shown. But why is your Quartz.dll file size 0 bytes ?

adicoto 11th January 2004 02:38 PM

Hey, wait a minute, do you run on Win98 or ME ?
Because I am on XP SP 1.0a.

BSPeter 11th January 2004 03:32 PM

Quote:

Originally Posted by adicoto
But why is your Quartz.dll file size 0 bytes ?

In reality it isn't. It's file-size is 1.133.056 bytes.
Quote:

Originally Posted by adicoto
do you run on Win98 or ME ?

Yes Win Me [but I have also access to and can - if necessary - also check on Win XP 2002 SP1 on my son's PC, but he has only build 501 installed sofar, or on an older Win98 SE Pentium III PC (which I was condemned to over the past holidays as the PSU of my PC broke down just before X-mas)].
:wink:
(By the way why isn't CompanyName, FileDescription etc. etc. shown re Quartz.dll in your version?
On my son's PC quartz.dll's size is 1.250.304 bytes)

adicoto 11th January 2004 09:02 PM

Probably because of SP 1.0a. I don't know. I have just installed it a couple of days ago. But it worked before ok. Is dated 30.05.2003. And I just find that is a part of DX9.0b.

private 2nd March 2004 03:32 PM

Solution to the AC3Filter problem

If AC3Filter is not shown in BSPlayer, you have to add these two lines to the file bspfilters.dat in BSPlayer directory:

AddFilter {AEFA5024-215A-4fc7-97A4-1043C86FD0B8},MatrixMixer
AddFilter {A753A1EC-973E-4718-AF8E-A3F554D45C44},AC3Filter

If you don't have the file bspfilters.dat, then you should rename bspfilters.sam ---> bspfilters.dat.

You can also download the working file here:
http://www.hot.ee/reameez/bspfilters.dat

I hope BST adds this to the next version automatically :)

maGot 3rd March 2004 04:38 PM

Nice!! Working verry fine! Thanx :D


All times are GMT +1. The time now is 03:43 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20