Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Feature Requests, Feedback And Suggestions (http://forum.bsplayer.com/feature-requests-feedback-suggestions/)
-   -   Screen expansion [1.66 to 1.78] (http://forum.bsplayer.com/feature-requests-feedback-suggestions/8237-screen-expansion-1-66-1-78-a.html)

ZanderZ 19th March 2007 07:58 PM

Screen expansion [1.66 to 1.78]
 
Hi,
I've got a couple of movies that are in 1.66 ratio. I watch movies on a widescreen tv. When I want to watch one of those movies, I either get black bars all around the movie, or I miss part of the movie when I zoom to 16x9 (1.78) ratio.
It would be very nice if there was a screen expansion option (not sure what the English translation is, I use the Dutch translation. It's in Options - Video - Video rendering, and can be set to "no change", 4:3, 16:9, 480 lines and 576 lines) to expand the screen to 16x9 by adding black bars to the side.
Then, when you zoom in on a widescreen tv, you see the movie in 1.66 ratio with black bars just on the side, not on top+bottom.
I hope this is clear enough and it might get added one day :)


-offtopic-
In previous versions when you pressed I (i), it would show the current time of the video, now it shows the last OSD text which is completely useless. What happened to the old setting?

BSPeter 20th March 2007 01:36 AM

Did you already try to add a custom aspect ratio (yours 5:3)?
(rightclick >) Options > Preferences > Video > [General]
You can add "Custom aspect ratios" in the "grey" area at the bottom, by typing in the desired ratio in the small white box and then click on [Add] (so that it is added to the list in the larger white box).
If you have added a ratio, it is shown and can be selected under
(richtclick >) Video > Aspect ratio
(the added custom ratio will be shown below the predefined ratios)

-offtopic- :
You can select what you want to be displayed when depressing [i] under:
(rightclick >) Options > Preferences > Video > [OSD Options]
(in Dutch "Keuze schermmeldingen")
:wink:

ZanderZ 20th March 2007 05:06 PM

The problem is not that the video is in the wrong aspect ratio, which would be fixed with what you suggest :)
Let me clarify with an image:
http://www.zanderz.org/stuff/bsplayer.png
In red is 4x3 ratio, which is what BSPlayer "sends" to the tv
In blue is the size of the movie
The green dotted lines show the part that is displayed when I use zoom on my tv. Everything below/above those lines is not visible. It doesn't look like much here, but it's a few cm on a tv.

So it would be nice to have an option to do it like this:
http://www.zanderz.org/stuff/bsplayer2.png
In blue the movie, expanded to widescreen (black bars) in green. The black bars is the 4x3 signal that is sent to the tv.
Now, when you zoom, you see the movie in the correct aspect ratio without losing anything of the image.
Get it? :)

@offtopic:
Thanks a lot, can't believe I missed that! :oops:

BSPeter 20th March 2007 08:31 PM

Quote:

Originally Posted by ZanderZ
The problem is not that the video is in the wrong aspect ratio

You nevertheless did say having ...
Quote:

... a couple of movies that are in 1.66 ratio.
which is why I suggested to add that ratio as a custom aspect ratio (5:3).
To be sure: you use zoom function of your TV-set (and not of BS.Player)?
Did you already try (in full screen mode) to pan-out a bit ([-] on numeric keyboard)?
:wink:
(together with "Remember Pan Scan settings" (Instellingen van de beelduitsnede onthouden) in Video preferences/General?)

ZanderZ 20th March 2007 11:25 PM

Hm, okay, once more then :P

The movies are in 1.66 ratio, which is the correct ratio (for example: Bound by Honor)
The tv-out signal is 1.33, so there are black bars when you watch a 1.66 movie on a tv. When you have a 4x3 (1.33) tv, this is no problem.
However, when you have a widescreen tv (1.78 ) like me, you have to zoom in (on the tv). When you watch a 1.78, 1.85, 2.35 or whatever, this is fine. But a 1.66 movie is higher than 1.78, so when you zoom, you miss part of the movie. I don't want that. When you don't zoom, you get black bars all around. I don't want that either.
So it would be nice if BSPlayer could add black bars on the side of a 1.66 movie so appears to be a 1.78 movie. Compare this with enabling "Scherm uitbreiden tot" (Expand screen to?) 16:9 when watching a 2.35 movie. BSPlayer will add black bars on the top and bottom so the 2.35 movie appears to be 1.78 (useful for having subtitles below the movie)
Then, when you zoom in, all is fine.

Quote:

Did you already try (in full screen mode) to pan-out a bit ([-] on numeric keyboard)?
Can't do that, since I'm watching on overlay. As far as I know, you can't pan using overlay. It only pans on the primary screen.
Disabling overlay is no option either, because then the resolution of my monitor and tv don't match and you will get scrolling on the tv.

-edit-
If it's still unclear, I could upload a short movie showing my problem. I also know VirtualDub can do it, but by recompressing you always lose some image quality...

BSPeter 21st March 2007 02:21 AM

Quote:

Originally Posted by ZanderZ
Can't do that ....

One can always try ("niet geschoten is altijd mis!") :lol:
It's quite clear what feature you want to be added so you needn't explain further.
I'm just trying to achieve a similar result in a different way.
You havn't selected "Cut top and bottom of video in full screen mode" under Video-preferences/General by any chance?
:wink:
P.S.:
My TV has 4:3, 14:9, 16:9, 16:9 subtitle mode, expanded screen, wide screen and PALplus. Suppose you have similar options. Which are you using?

ZanderZ 21st March 2007 12:41 PM

Quote:

Originally Posted by BSPeter
One can always try ("niet geschoten is altijd mis!") :lol:

Absolutely, and I appreciate your input!

Quote:

You havn't selected "Cut top and bottom of video in full screen mode" under Video-preferences/General by any chance?
:wink:
P.S.:
My TV has 4:3, 14:9, 16:9, 16:9 subtitle mode, expanded screen, wide screen and PALplus. Suppose you have similar options. Which are you using?

Nope, that option is deselected. Doesn't seem to mather though when I select it. Maybe because overlay is enabled?
My tv has 4:3, 16:9, 16:9 subtitle (I guess... it shows the bottom 16:9 part of the 4:3 signal) and stretched (4:3 signal stretched to 16:9)
For watching movies I use 16:9 (unless the movie is in 4:3 ofcourse)

dzver 10th October 2010 04:24 AM

Quote:

Originally Posted by BSPeter (Beitrag 29411)
Did you already try to add a custom aspect ratio (yours 5:3)?
(rightclick >) Options > Preferences > Video > [General]
You can add "Custom aspect ratios" in the "grey" area at the bottom, by typing in the desired ratio in the small white box and then click on [Add] (so that it is added to the list in the larger white box).
If you have added a ratio, it is shown and can be selected under
(richtclick >) Video > Aspect ratio
(the added custom ratio will be shown below the predefined ratios)

-offtopic- :
You can select what you want to be displayed when depressing [i] under:
(rightclick >) Options > Preferences > Video > [OSD Options]
(in Dutch "Keuze schermmeldingen")
:wink:

Thank You very much, You helped me a lot


All times are GMT +1. The time now is 10:04 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20