Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   [Lang. Problem] Seeing gibberish instead of Hebrew. (http://forum.bsplayer.com/general-talk-support/12003-lang-problem-seeing-gibberish-instead-hebrew.html)

NSH 21st January 2011 12:05 PM

[Lang. Problem] Seeing gibberish instead of Hebrew.
 
Hi there
I'm running Windows 7 Home Premium, and my problem is that when I change the language to Hebrew, I get gibberish letters. Like in these photos:


Selecting Hebrew Language

The Gibbrish letters as a result



kindly help me :teeth:

BSPeter 21st January 2011 12:41 PM

I noticed that you're not using most up to date BS.Player version.
Therefore...
maybe first try an updated language file: http://peterg.coi.co.il/תרגום-BSPlayer.htm ( http://forum.bsplayer.com/40907-post7.html ).
Only if that doesn't help read on...
This maybe related to a known bug in the last three builds.
As a temporary solution:
Under (rightclick >) Options > Preferences > Subtitles [Subtitle properties] ...
(1) ... verify setting of the box "Use new subtitle parser/renderer"; try if (de)selection makes any difference.
(2) ... verify what script is selected under [Font]; if (e.g.) Western .. change it to correct script.
:wink:
Another possibility is to load the file Hebrew.lng (in subfolder "lang" of BS.Player's installation folder) in Notepad. Without making any changes click on "File" > "Save as" and verify at the bottom what Encoding is selected (e.g. UTF-8 or ANSI). Now change this setting and save file.
:wink:
(Please let us know the result!)

NSH 21st January 2011 02:20 PM

Thank you,
saving the lang format in various formats [UTF-8, UNICODE]
- proved a success .......

BUT:
it's partly ok,
the prefrences menu is still in gibberish:

Partly Hebrew Partly gibberish

BSPeter 21st January 2011 03:02 PM

Did you meanwhile update BS.Player version/build?
Are you now using the more up-to-date language-file (or the adapted old one as included in the distribution)?
:wink:

NSH 21st January 2011 03:06 PM

Quote:

Originally Posted by BSPeter (Beitrag 44141)
Did you meanwhile update BS.Player version/build?
Are you now using the more up-to-date language-file (or the adapted old one as included in the distribution)?
:wink:

Thank u very much - problem solved while trying each and every coding method :)

[even while still using my older BSplayer build]

:teeth:

BSPeter 21st January 2011 03:15 PM

And what encoding did eventually solve it? I suppose either ANSI or UTF-8 (with "Byte Order Mark") as suggested by me?
:wink:

NSH 21st January 2011 10:29 PM

it was indeed UTF-8, the tricky and minor detail was changing the extension back to .lang , because after editing the lagauge file with notepad, even when I chose 'save as all files', it kept the file it in a .txt form.

i dont understand, however the meaning of (with "Byte Order Mark")

BSPeter 22nd January 2011 11:05 PM

Byte order mark - Wikipedia, the free encyclopedia
:wink:


All times are GMT +1. The time now is 02:38 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20