Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   How to prohibite for BSPLayer to set itself as a default player? (http://forum.bsplayer.com/general-talk-support/12071-how-prohibite-bsplayer-set-itself-default-player.html)

Marillion 7th March 2011 12:38 PM

How to prohibite for BSPLayer to set itself as a default player?
 
Please, help me with my question.

I don't like that BSPlayer sets itself as a default player for 'mms://' streams, there is not always only video in those streams, sometimes it only audiostreams, that i prefer to listen in Windows Media Player.

I change presets as default in a Control Panel to Windows Media Player as default media player, and then i can play 'mms://' in WMP as default. But if i start BSPlayer after that procedure, even without any media file or media stream, and then i close it, after that BSPlayer becomes default media player in my system, and when clicking on 'mms://' link, it starts instead of WMP, that i wouldn't like.

How to prohibite for BSPlayer to set itself in system as a default player for all media, after each simple starting?

Tizio 7th March 2011 01:30 PM

Have you already took a look at BS.Player Options window?
There you can set/unset BS.Player as the default player for the preferred filetypes (mms protocol included)

Just open BS.Player, press CTRL+P to open the Preferences window (or open it from the player menu Options -> Preferences).
Now choose General -> File types section and uncheck all the extensions you don't want BS.Player to be set as default player. At the bottom you can also uncheck mms protocol association.

Let me know if this helps you :wink:

Marillion 7th March 2011 09:08 PM

Quote:

Originally Posted by Tizio (Beitrag 44517)
Have you already took a look at BS.Player Options window?
There you can set/unset BS.Player as the default player for the preferred filetypes (mms protocol included)

Just open BS.Player, press CTRL+P to open the Preferences window (or open it from the player menu Options -> Preferences).
Now choose General -> File types section and uncheck all the extensions you don't want BS.Player to be set as default player. At the bottom you can also uncheck mms protocol association.

Let me know if this helps you :wink:

The check opposite 'MMS protocol' is always unset. And even i set it forcibly, and close Preference window, and the open it again, the check opposite 'MMS protocol' is unset again.

I don't know, is it correct work or not, but after each starting of BSPlayer the mms-protocol have been automatically associated with BSPlayer.

However, i could solve my basic problem by unsetting "Register extensions on player start" check.

Tizio 7th March 2011 10:22 PM

No, it isn't a correct behavior.. I can't reproduce it, but there could be a bug in associations window (there are definitely problems with personal icons)

Unsetting "Register extensions on player start" checkbox is an option, but not the solution to the problem


All times are GMT +1. The time now is 12:42 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20