Official BS.Player forums

Official BS.Player forums (
-   General Talk And Support (
-   -   DVD Playback (

Tizio 28th June 2005 09:18 AM

DVD Playback
Hi! I'm trying to watch a (protected) DVD with BSplayer by using "DVD Region+CSS Free" trial.
My problem is that when I hopen 1GB VOBs the player stucks (as it is buffering the whole file). I have no problem with smallest (50-100MB) protected files.

It's a BSplayer problem or a CSS Free one?
Or it could be a decoder problem (Elecard)? But I don't think so...

If someone (adicoto?) can help me I would appreciate it very much :wink:

Thanks :)

adicoto 28th June 2005 04:34 PM

I must try this before giving an answer.

BSPlayer's fault, I don't think, I've played files bigger than that.
Elecard ? Neither, same reason.
Probably other software included in process, or maybe descrambling the file requires a large amount of free space on hard drive ? (FAT or NTFS ?)

Tizio 29th June 2005 10:23 AM

FAT32.... :(

I've tried with only one DVD, I ca try with another one.

Originally Posted by adicoto
or maybe descrambling the file requires a large amount of free space on hard drive ?

Yes, it's probably that the problem. I will try again and check if there are other programs that could make the process to stuck.

Thank you again :)

Tizio 29th June 2005 06:14 PM

Ok, I made some tests.

I tried to see another DVD (LordOfTheRingsSpecialExtendedEdition) and after 20 seconds the playback started :shock: ! WOW!
The list of available audio strams also let me to choose between languages!

An here I found one problem (don't know if BSplayer or Elecard or AC3 Filter) when I changed audio stram in the first 7-8 minutes of first VOB the playback restarted from the first frame, but BSplayer time counter continued to go on from those 7-8 minutes :?
The same beaviour appened also wen seeking.

Note: after other tests I noticed that not always this appens, but quite frequently

But if I seek or change audio stream after the first 7-8 minutes everithing works fine!!

Then I tried again my previous DVD and with Sysinternals Process Explorer utility I inspected BSplayer process, and saw that BSplayer buffered the DVD stream (by watching the I/O Read Bytes column).
In fact after the I/O Read Bytes counter reached the 1GB dimension, the playback of my DVD started, and this seemed strange to me, since with the LOTR DVD BSplayer didn't buffered it....

I hope this can be fixed or that a full DVD playback support is added to BSplayer (or that I can find a solution to this inconveniences) :wink:

Thank you adicoto for reporting that you had no problem in watching DVDs with BSplayer, so I was able to see that not all my DVDs act that way :)

adicoto 29th June 2005 07:07 PM

Normaly, FAT32 is limited to 2GB files. It may be the problem of descrambling to a larger file than 2 GB and only NTFS (under win) can accept files larger than 2 GB.

Tizio 30th June 2005 08:38 AM

AFAIK FAT32 limit is 4GB (2GB is for FAT16), but it should not be a problem to me since the maximum VOBs size is 1GB (for my tested DVDs)...
And CSS Free works on the fly (I don't know if it uses hard memory, but I don't think so) and if I enable/disable it, immediately the video on BSplayer becomes readable/scrambled...
Plus, after 2-3 VOBs have playied, the ProcessExplorer I/O Read Bytes column indicates only about 50MB read from CSS Free...

At the moment I can't try with NTFS partitions, but when I will have more time I'll try.

Thank you :wink:

All times are GMT +1. The time now is 01:04 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20