Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   Sync Problem (http://forum.bsplayer.com/general-talk-support/6888-sync-problem.html)

Romulous 22nd October 2005 02:18 PM

Sync Problem
 
Hi everyone,

I have an odd problem playing video files through BSPlayer (using v1.36 build 825). On certain video files, the audio and video get out of sync. The video seems to play at normal speed, but the audio lags behind by a few seconds. I use ffdshow (alpha 20041012) as my codec. My PC has a 1.7ghz CPU and 512MB of ram. The odd thing is that Media Player Classic plays these files fine - no sync problems. So far, I've tried changing render modes (tried all the different one's, now have gone back to using the default), tried disabling yv12, blacklisting the ffdshow filter and nothing has helped a bit. I thought it may have been the post-processing in ffdshow, so I disabled that as well, but that didn't help any. So far, I can get the problem to happen on certain .mpg and .vob files (it doesn't seem to happen on every single .mpg or .vob which is odd). I haven't found an .avi that exhibits the same problem as yet, so I don't know if that is significant or not. I also run just in a normal, non resized BSPlayer window. The other thing that I noticed was that on the files that it has a problem with, the timer in the BSPlayer control bar was displaying that the file was 00:00:00 in length, and as the video played, it was also showing that 00:00:00 of the video had been played. I don't know the significance of this, but I assume it is either the cause of the problem, or some symptom, because it only seems to happen with the video's that fall out of sync.

Thanks.

**Edit: Yes, it only seems to happen on MPEG's and VOB's. I tried opening a few different .avi's and .wmv's, and they all played fine.***

BSPeter 22nd October 2005 11:11 PM

I would follow the suggestion of adicoto in several of his' posts: install an MPEG2 decoder, such as Elecard, BitCtrl or others.
:wink:
(Check which codec/filter is used by BSPlayer for playback; see last line of item (3) of my Help2Help-post)

Romulous 24th October 2005 02:54 PM

Hi BSPeter,

So ffdshow doesn't decode MPEG2 files? :shock: It's definitely being used as the playback codec. Actually, ffdshow is being used for every file except for .wmv's on my PC.

CM

BSPeter 24th October 2005 10:32 PM

Now, where did I say ffdshow doesn't decode MPEG2 files?
I'm merely suggesting that a proper (uniquely dedicated) MPEG2 decoder might be a solution to your problem.
Did you try?
:wink:

Romulous 26th October 2005 12:15 PM

BitCtrl looks to be shareware, so I'm not interested. Elecard Decoder Pack I think is freeware by the looks of the site, but it has a bad reputation for being difficult to configure and clashing with other installed applications. If there is a good freeware one around, I'm willing to try - I just don't see why ffdshow is the problem. Media PLayer Classic (which uses ffdshow for MPEG) works fine on these files. Only BSPLayer doesn't play them ok. Therefore, logically BSPlayer is the problem, not the codec.


All times are GMT +1. The time now is 06:25 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20