Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   no video on BSPlayer (http://forum.bsplayer.com/general-talk-support/7262-no-video-bsplayer.html)

KissCoolMan 24th February 2006 07:43 PM

no video on BSPlayer
 
Hi there !

First, excuse me for my very poor english, i'm a french guy .... :( :oops: .

I've a very strange problem with BSPlayer since yesterday ... on the one hand, when I launch the program, there is no video on the screen :shock: ! The program window is here, the video window too, but no video .... I've tried with several video files which are encoded with differents codecs but no video ...

On the other hand, when I try to look a video with WMP or VLC it works ...

What I already tested:
- uninstall / reinstall BSPlayer 1.39
- uninstall / reinstall my codec pack : SLD Codec pack

Do you want anything else (screenshot, windows version, etc) ?

adicoto 24th February 2006 07:58 PM

Usually codec packs do more harm than good.
Try to re-register quartz.dll
If you open the file with WMP, can you post here what filters are used in rendering the file ?

KissCoolMan 24th February 2006 08:23 PM

(ho, my english is not so poor... you succeed understanding me :lol:)

I know codecs pack is not really a good solution, but I think it's a bit hard for n00bs to install codecs without a pack ...

How can I re-register the dll file ? Just downloading it on the web and replace it ?

and how can I know what filters are used in rendering the file with WMP ?

thanks for the help :D

Tizio 24th February 2006 08:29 PM

Directly from BSplayer creator BST:
How to re-register quartz.dll

adicoto 24th February 2006 08:29 PM

Go to system32 folder and run
regsvr32.exe quartz.dll

Open the file with WMP, File->properties

Open with Mplayer2 (old WMP)->view->settings

Nice Tizio, how many seconds are youahead ? :lol: :D

Tizio 24th February 2006 08:33 PM

Quote:

Originally Posted by adicoto
Nice Tizio, how many seconds are youahead ? :lol: :D

I think only 2µs :lol:

J7N 24th February 2006 08:34 PM

To register a DirectShow library enter this command in Run:
Code:

regsvr32.exe <myfilter.ax>
To unregister a filter, add /u parameter
Code:

regsvr32.exe /u <myfilter.ax>
<Myfilter.ax> is the full path to your library. For quartz you just enter "regsvr32 quartz.dll" because it is in the searchpath (system).

To find out what filters are in use you can load your video file in mplayer2.exe (legacy Windows Media Player), rightclick in the play window, choose Properties and Advanced. Mplayer2 most likely can also be run by typing its name in Start -> Run.

adicoto 24th February 2006 08:39 PM

And even if BSPlayer is not playing the file, in filter (right click->filters) you'll have the filters used to render the file. It's good to do that too.

KissCoolMan 24th February 2006 08:40 PM

Codec audio : Morgan Stream Switcher
Codec vidéo : XviD MPEG-4 Video Decoder
(but it's the same with all the videos :s)

I re-register the DLL ... have i to reboot my system ?
'cause it doesn't work :( ...

thanks for all this fast help :D :D

KissCoolMan 24th February 2006 08:42 PM

hum, i'm just thinking to that ... do you think Nero 7 can do this kind of problem ? 'cause I installed it this morning, and I think there is some codecs in ...

adicoto 24th February 2006 08:44 PM

Uninstall Morgan Multimedia stream Swicher. You don't need it. I didn't remember of it, since nobody was using it for years now.
Probably most of your videos are XviD encoded. But to be sure, click on it in filters and disable support for DivX and DX50

J7N 24th February 2006 08:51 PM

Nero installs a load of its own filters. Nero 6 caused problems for me by hijacking many formats only to display a dialog that I need to pay or smth.

Nero 7 in contrast to 6 actually offers user the ability to unselect unneeded features during the setup. However I don't remember whether it allowed to unselect its DS components.

adicoto 24th February 2006 08:59 PM

By the way, wich version of SLD do you use ? Last one I found on the net is like 1 year old !!!

KissCoolMan 24th February 2006 08:59 PM

adicoto : Morgan Stream Switcher is not in the selection in the "Codec Selector" of SLD Codec Pack, so i can't do that ... how can i do ?

J7N : yes, i just installed Nero Burning Rom & Nero Start Smart ...

KissCoolMan 24th February 2006 09:01 PM

I use the SLD Codec Pack 2.2 : http://www.skynet4ever.tk/

KissCoolMan 24th February 2006 09:02 PM

I used to use K-Lite Mega Codec Pack ... do you think SLD is better than that one ? Which pack do you advise for me ?

Tizio 24th February 2006 09:05 PM

I suggest you to not use codec pack at all.
But if you really want to use one then use K-Lite!

adicoto 24th February 2006 09:06 PM

Yes, 2.2 version is 10 months old. And normally it should let you uninstall Morgan stream swich.
Do a search in windows for the file mmswich.ax and unregister it or just delete it.
As for codecs:
http://forum.bsplayer.org/viewtopic.php?t=3042

J7N 24th February 2006 09:07 PM

I advise not to use any codec pack and keep control of what your software installers (Nero) change in your system. I can only advise what decoders to use for a specific format.

As for the Nero filters which usually go into "%PROGRAMFILES%\Common Files\Ahead", I think none of them is needed. It is possible that Nero libraries still are being loaded, while not showing up in the list of filters in use, and – causing problems. To see what dynamic link libraries are loaded I use TaskInfo2000 system information tool.

KissCoolMan 24th February 2006 09:25 PM

i uninstalled SLD Codec Pack & reinstall K-Lite Codec Pack, and ... IT WORKS :D :D :D !!!!

Thaaaaaaaaank you a lot :) !!


All times are GMT +1. The time now is 09:19 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20