Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   Bad fullscreen aspect ratio (http://forum.bsplayer.com/general-talk-support/7727-bad-fullscreen-aspect-ratio.html)

Tungsten 2nd August 2006 04:04 AM

Bad fullscreen aspect ratio
 
I've been using BSPlayer 1.37 b826 for a while without any problems, but a couple days ago I must have changed an extra setting or two. The .m2t clips from my HD camera(1440x1080) are in the correct aspect ratio but when I fullscreen them, they go to 4:3. Of course, it's just a matter of hitting Shift+2(Shift+1 sets the vid to 4:3 as well) during every fullscreen but it bothers me nonetheless. Is there something I can set? By the way, this used to work just fine before...this is not a function of the .m2t files I'm playing.
Thanks!

J7N 2nd August 2006 04:48 AM

Re: Bad fullscreen aspect ratio
 
Perhaps you have activated "Don't resize video in full screen" option?

Tungsten 2nd August 2006 05:31 PM

Unfortunately, that is not the case. The only two things checked in the general video preferences are 'Remember Pan-Scan Settings' and 'Remember movie window size'. I also have 'Keep aspect ratio' checked if that helps.
Shouldn't Shift+1 show me the original aspect ratio? Because in this case, Shift+1 brings the screen back to 4:3.

J7N 3rd August 2006 12:42 AM

You said your camera was 1440*1080. If this is true then 4:3 is the original aspect ratio which you should scale afterwards (1440*3/4=1080).

I don't have any further recommendations ATM.

Tungsten 3rd August 2006 03:56 AM

Yes, your math is correct but I failed to mention that HDV uses a pixel aspect ratio of 1.3333 which compensates for this. To eliminate any questionable codec settings, I just tried some clips in WMPlayer and they were 16:9 in both windowed and fullscreen modes

J7N 3rd August 2006 10:35 PM

Yes, but BSPlayer allows to easily return to the original image prior scaling to 0.75 height.

Back to topic: You can try to remove all BSPlayer's settings by renaming BSPlayer*.xml file to something else and then change options you suspect might affect full screen display one by one. The settings file should be located where Bsplayer.exe is or in "Documents and Settings\<windows_login>\Application Data\BSPlayer*\".

Edit:
I have reproduced your situation with anamorphic MPEG-2:
- Click on "Context -> Video -> Pan-Scan -> Auto"
****= Bad full-screen
- Click on "Context -> Video -> Pan-Scan -> Auto" again
****= Correctly scaled picture

BSPeter 3rd August 2006 11:15 PM

Settings which may perhaps be of interest under (rightclick >) "Options" > "Preferences" ... could also be:
... > "General": "For full screen mode switch to" (& "At start switch to")
... > "Video" > "Video rendering" : "Extend picture to"
... > "Playlist": "Aspect" (ditto in "old style playlist" itself)
:wink:

Tungsten 9th August 2006 05:14 PM

Thanks a lot, guys!


All times are GMT +1. The time now is 06:34 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20