Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   Unhandled exception... (http://forum.bsplayer.com/general-talk-support/7843-unhandled-exception.html)

Puffi 12th September 2006 08:19 PM

Unhandled exception...
 
i have a strange problem with bsplayer... when i run MPEG1 files i get an unhandled exception with the error code 74833897. bsplayer doesn't shut down, it runs, but does not play the file. if i double click the same MPEG1 file again after shutting down the error window, it plays it fine! any .avi files work the first time without any problems.

i've tried 3 different versions and all are like that, including the 2.11 version. it's pissing me off. i dont know what happened, but this just started one day on some older version i was using... then i started trying other versions and forgot what that version was. but it doesn't seem to matter as none of them work. maybe some ancient version would work, but i dont really want to go back to those. some other guy here had this problem and an older version worked, but he never spesified which version it was.

so is there ANY way i can get this to work on any newer version? if not, which version of bsplayer would work?

adicoto 12th September 2006 09:06 PM

If BSPlayer doesn't close then by rightclick-ing on it you can see wich filters were intended to be used to play the file (options->filters). Can you post here those filters ?

Puffi 12th September 2006 10:01 PM

well.. it doesn't load the file when that window comes so i cant see a filter, but once i click it again and it runs it i can see this filter:

MPEG-1 video decoder.
this is the file, in the windows/system32 folder:
quartz.dll, Size: 1287168 bytes, Version 6.5.2600.2749

i first thought about codecs and all.. but then once i noticed that it DOES run the file after i try again, i kinda figured it cant be that - that it has to be in the program.

adicoto 13th September 2006 03:57 PM

It also must have an audio filter in use. :wink:

Puffi 13th September 2006 08:18 PM

actually that clip didn't have any audio, so no audio filter was needed. but i tried another clip that has audio and the "Default DirectSound Device" is the same file, as is the MPEG Audio Decoder: quartz.dll. and the sound works fine too - once i get that thing to run. i'd have no complaints if it didn't show that error message. it's like the error message is the problem here!

i tried zoom player, WMP classic, 1337player, crystal player, VLC player... and bsplayer 0.8. they all play these clips without any problems. though the 0.8 version is the only one that doesn't play my .avis right (overlay fails), so i cant use that either. ANNOYING.

and why i like bsplayer? cos i can change the size of the player window with the mouse scroll, and cos the player window is just that, a window, with nothing extra.

Puffi 28th November 2006 07:21 PM

i'm bumping this - if that even works in this place...

i'm still having this problem. anyone have any idea on how to fix it?? it really sucks that i cant use this program because of this thing.

adicoto 28th November 2006 09:25 PM

Can you tell us what video card do you have ?

Puffi 29th November 2006 05:13 AM

i have an Asus 7800 GT...

kimiraikkonen 29th November 2006 12:46 PM

Can you play Mpeg-1 files properly with NEW other players? Did you try re-installing BsPlayer?...

Puffi 29th November 2006 03:56 PM

as i stated earlier, ALL other players play them fine. even bsplayer 0.8. i've uninstalled and installed bsplayer sooo many times i cant even count but it does nothing.

i'm thinking it has to leave some sort of registry entry or other print somewhere that's messing this stuff up. it's just so strange that it's able to play it after i click "continue" on the error message and then double click the file again...

Tizio 29th November 2006 05:11 PM

Maybe it doesn't help, but have you tried to delete C:\Documents and Settings\USER_NAME\Applicvation Data\BSplayer\ folder and then reinstalling BSplayer :?:

Puffi 29th November 2006 10:25 PM

hmm... just tried it. but nah, doesn't help.

adicoto 30th November 2006 05:21 AM

Can you try to change rendering method (options->preferencies->video->rendering methode) and swich for example to VMR9, or overlay mixer ? Won't do no harm.
Also, maybe re-registering quartz.dll may help, also installing an alternate MPEG decoder such as Elecard.

Puffi 30th November 2006 10:44 PM

re-registering quartz.dll? what do u mean by that? i think i've deleted and reinstalled it before, but dont know how to re-register...

also, what do u mean by elecard? i cant find a MPEG-1 decoder by that name, just other MPEG formats?

i tried to change the rendering mode, but that didn't work...

adicoto 30th November 2006 11:22 PM

1. Go to options->preferencies->filter management. In there go to filter manager tab, scroll dow until the one called avi splitter (if you click on it at the bottom of the window you'll see the name quartz.dll0 and the press re-register button on the right.
2. Elecard is an alternate MPEG decoder, who can take over the job of decoding MPEG1 and MPEG2 files from standard window's decoder.

Puffi 1st December 2006 02:34 AM

re-registering didn't help...
...but installing elecard DID. it works now. but i'm not sure if i downloaded some crappy evaluation version of it or not, i guess i'll see in time.

but it works! yay! thank u all for your efforts.


All times are GMT +1. The time now is 11:11 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20