Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   Always starting in full screen mode, unexpectedly (http://forum.bsplayer.com/general-talk-support/8360-always-starting-full-screen-mode-unexpectedly.html)

cefis 20th May 2007 10:26 PM

Always starting in full screen mode, unexpectedly
 
Whenever a movie file is opened, BSPlayer always starts it in full screen mode even though I have unchecked the option "Always start in full screen mode".

Has anybody else experienced this? What's the fix?

I can then play the movie with the "x" key, but the main window does not appear at all when I press "h" or ESC. The only way to exit the program is with the F10 "boss key".

I'm using BSPlayer version 1.20 (Build 815, 2/22/05)

Thanks for any help.

-Stan

BSPeter 20th May 2007 10:32 PM

You probably unintentionally changed some setting.
To return to default situation: close BS.Player.
Then rename file "BSplayer.<yourname>.xml" into anything different
(e.g. put an "x" in front of it: xBSplayer.(etc)).
(For version 1.x this file is in BS.Player's installation folder; usually C:\Program Files\Webteh\BSplayer\ )
Restart BS.Player.
Result?
:wink:

BSPeter 20th May 2007 11:12 PM

Unfortunately I cannot test with version 1.2 (I don't have it installed any more) and I don't know whether it had a bug which may cause your "problem". I do still have version 1.37 installed though.
FYI here is the changelog file upto version 1.37 (click here).
:wink:

kimiraikkonen 21st May 2007 12:26 PM

Although it seemed to run in full screen, it's a deception.

All you have to do is resize the video when it's running in fake full-screen. It's not in full-screen in real. It's just too big and seems strecthed.

Just resize and make resolution lower.

BSPeter 21st May 2007 07:46 PM

That possibility also crossed my mind, but it seemed too simple.
Also (repeated) pressing [H]-key should then bring up main window, which doesn't seem the case.
Maybe main window is somewhere "off visible screen"?
@cefis: You aren't using nView's "Dual view" or similar by any chance?
:wink:

adicoto 21st May 2007 07:55 PM

If you resize video window with the mouse scroll button ? Just a guess. Does 1,2 have playlist function, I don't recall ? If so, maybe you have enabled there "full screen" option.

BSPeter 21st May 2007 08:02 PM

Good idea adicoto! Didn't think of that! Don't know about 1.2 but 1.37 surely does have a playlist function.
@cefis: Check playlist defaults under
(rightclick >) Options > Preferences > Playlist
Is checkbox "Full screen" checked?
:wink:

adicoto 21st May 2007 08:49 PM

I think playlist was one of the new implemented function in ver 1.00

BSPeter 21st May 2007 09:10 PM

No, playlist itself was already there in version 0.86 and earlier. However I think the possibility to define defaults was introduced in the earlier 1.00 builds.
:wink:
(I still keep i.a. versions 0.86 and 1.37 on my PC, together with latest 2.x version.)

cefis 24th May 2007 02:37 AM

Thanks to all who replied. But the problem still exists.

In order:
- Renamed the XML file, no difference.
- For [kimiraikkonen], there's no way to resize the video window using mouse or keyboard. There are no window borders to resize. (unless I'm not understanding your suggestion)
- Not using nView's "Dual view" or similar .
- resize video window with the mouse scroll button - nothing happens.
- Playlist 'full screen' is disabled.



What's interesting is that when I exit the full screen mode with F10 (boss key) I can very briefly see the smaller video window and main window on the desktop right before BsPlayer completely closes.

In addition, the problem I've described occurs only on my laptop, but not my desktop PC.

Perhaps I'll try to uninstall and re-install.

BSPeter 24th May 2007 11:49 AM

Quote:

Originally Posted by cefis
Perhaps I'll try to uninstall and re-install.

I would suggest not to re-install version 1.2 then, but a later version (at least 1.37, which I've also still on my PC) so that we can "talk" with the same version as a reference. [This way possibly excluding that it may have been a bug in 1.2 which is no longer present in the version that we (i.e. fellow users like me) may still have available for testing-purposes].
:wink:

adicoto 24th May 2007 04:29 PM

Is it possible to have BSPlayer using in fact ActiveMovie window ? And it covers the video window ?

BSPeter 24th May 2007 07:11 PM

I must say that same thought has also crossed my mind, but my knowledge on the subject is simply totally inadequate (and I'd like to keep it that way).
:wink:

adicoto 24th May 2007 08:26 PM

There are 2 informations in the post above, one about "nothing happens" when using scroll button (if full screen, the the scroll button will modify audio volume - if not full screen then it's one who is not responding to this command-> probably activemovie window), and the second about "smaller video window and main window" in fact there is the real video window and the window in wich the video is played-> activemovie window.

So, my guess->faulty video decoder or video rendering inapropriate. Suggestions:
1. post here wich video decoder it's used when playing the files (rightclick->options->filterrs)
2. Open BSPlayer, rightclick>options->preferencies->video and there select any othe rendering method than the one used.

Do we talk about avi files or MPEG2 files ?

kimiraikkonen 25th May 2007 04:27 PM

cefis,
Forget what i suggested, just tell:

Hold down your left mouse button and drag the screen somewhere, are you able to do this?

cefis 26th May 2007 01:36 PM

Solved!
 
1 Attachment(s)
Again, thanks for all replies.

I installed version 1.37 and problem still occurred.
So I started playing around with the system and solved the problem.

In monitor Display Properties,
Settings tab,
Advanced button,
Displays tab

there was another 'video mode' (see attached picture) setting which I chose.
The left button is the correct one to use ; I don't even know what each signifies, the Help didn't mention it.
When BSPlayer starts a movie file, it is no longer in full screen mode.

So it had to do with my notebook display settings and is not due to any program bug or option.

adicoto 26th May 2007 03:30 PM

Quote:

Originally Posted by BSPeter
@cefis: You aren't using nView's "Dual view" or similar by any chance?
:wink:

:wink:

BSPeter 26th May 2007 05:11 PM

Glad the mistery is solved eventually!
:wink:


All times are GMT +1. The time now is 09:32 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20