Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   Video window left on the secondary monitor (http://forum.bsplayer.com/general-talk-support/8428-video-window-left-secondary-monitor.html)

brother 10th July 2007 10:59 AM

Video window left on the secondary monitor
 
Hi,

Sometimes I use an extended desktop with multiple monitors, and use the secondary to watch Bsplayer.

The problem comes when I use again a simple monitor; the video window remenbers its position on the secondary monitor, i.e., beyond the limits of the current monitor.
You can only wacth video when do a double-click to use fullscreen, but no way to use the video window ...


Anyone knows how to recover that lost video window??

BSPeter 10th July 2007 07:28 PM

Is "Don't remember movie window position" selected?
under (rightclick >) Options > Preferences > Video >[General]
:wink:
(Suggest to (re)check settings of your graphics card; what type of card do you have?)

adicoto 10th July 2007 08:41 PM

Did run into this problem some hundreds of times myself. Just plug in your TV and move the window back.
As a general advice, don't turn off your TV until you haven't take back the video window to the primary display.

Ico-man 11th July 2007 08:07 AM

Solution =
 
As stated by BSPeter above:

Check option "Don't remember movie window position" selected?
under (rightclick >) Options > Preferences > Video >[General].

Doing this will solve the isssue.

adicoto 11th July 2007 08:10 AM

Should be "don't remember movie position if on secondary monitor"

BSPeter 11th July 2007 06:51 PM

Quote:

Originally Posted by adicoto
Should be "don't remember movie position if on secondary monitor"

I fail to see why this should be restricted to secondary monitor. I would expect the option (i.e. not to remember) to work irrespective of whether we're talking about the window being on primary or secondary display.
:wink:

Tizio 13th July 2007 09:29 AM

But with adicoto's suggestion you can let BSplayer remember its Movie window position when on single monitor, but forget it if you left it on the second one..

Otherwise another option can be (not an option, but hardcoded to always be performed) to place the Movie Window at 0,0 when that window is entirely out of sight :)

Ico-man 13th July 2007 10:20 AM

"Otherwise another option can be (not an option, but hardcoded to always be performed) to place the Movie Window at 0,0 when that window is entirely out of sight"

This is already implemented in BS.Player, as long as you have Single display enabled.
If you are watching movie on a second display under Dualview mode, and then want to move the movie window to primary window, all you need to do is change display mode to Single display, and BS.Player will detect that movie window is out of sight and will display it on primary display.
Tested.

If you want to keep using Dualview all the time(i.e. do not want to change display modes everytime you watch different display), but don't want to drag movie window from primary to secondary and back all the time, just check the "Don't remember movie window position". BS.Player will then always display played movie in primary display.

:)

Tizio 13th July 2007 11:24 AM

:wink:

brother 21st August 2007 10:30 AM

Hi folks,

Thank you all for the suggestions. The funny fact is, that the option "don't remenber window position" does not work for me; I check it and bsplayer still moves the window around for each different file opened :shock:

Yeah, I closed and reopened Bsplayer to make sure the setting takes effect, but ..... still not working.

Any way to force this behaviour through registry editing?

Regards,

bROTHER

BSPeter 21st August 2007 07:37 PM

Quote:

Originally Posted by brother
.... bsplayer still moves the window around for each different file opened ....

Seems a different issue as the one mentioned in your initial post at the start of this thread.
Could you please check if "Remember movie settings" is selected under
(rightclick >) Options > Preferences > General > [General settings]?
(It's just below "Remember last movie position")
If so: deselect it.
:wink:

brother 17th September 2007 05:25 PM

Hi,

I lost the post link ....
Thx for the answer.

Yep, I deselected the "Remember movie settings" and now it does not remember the window position. :D

The fact is that I want some parameters to be remembred (AR,Subtitles, font... the ones that the contextual help claims to remenber) but not the position:

For me this is the natural behaviour; once you selected the subtitles among several ones, changed the AR for those who were wrong, etc, if you play fullscreen then ok, no problem, but if you want/need to play windowed like when you're reviewing content, then having the window jumping all around the desktop is quite bothering.

I mean, as long as I understood it the first time, and as long as I (imho) think this is a usual way of working, I would suggest to render those both commands to be independent.

Regards,

bROTHER


All times are GMT +1. The time now is 11:13 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20