View Single Post
  #1 (permalink)  
Old 4th March 2005
herk-u-less herk-u-less is offline
Junior Member
BS.Player Newbie
Join Date: Feb 2005
Posts: 7
Rep Power: 0
herk-u-less is an unknown quantity at this point
Default DirectShow not installed (codec probs) :(

No matter what I do, I get the error DirectShow not installed on ALL movies i try to play with BSplayer... I Know it's a codec-related problem,
but I just can't fix it no matter what I try?

I have reinstalled BSP lots of times, uninstalled all codecs at 2 separate times, gone back to a previous system restore point, tried lots of codec related programs, some wouldn't even run. I ran 3 different reg-cleaning tools and Norton WinDoc AFTER uninstalling all codecs, reinstalled and tried to play with settings in ffdshow, tried to uninstall codecs with RegSvr32 - which didn't work because Regsvr32 doesn't install or uninstall ANYTHING these days etc. etc.

Also, as I said part of the problem is that it seems like regsvr32 is not working at all, so I can't either register or unregister anything (can't run various codec related programs normally either, like Gspot or that Graph thingie!), which I think I have to do to fix this problem.

I'm now at a total loss for what I should do, leaving out a full reinstall... I wish there was a simple way to just reset the codec status to the standard windows settings when fresh installed.... But, it seems I shouldn't keep my hopes up, or what?

Any help or tips, very appreciated!

(Ps - I've been googling like crazy on the web, to find solutions, but there seems to be very little to be found on this problem! Been searching for both the codec/DS issue, and the regvr32 problem. I could barely find one entry on "directshow" in the MS knowledge base... Is this problem unique for me or what?)
Reply With Quote

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20