View Single Post
  #1 (permalink)  
Old 13th March 2012
wildheart25c wildheart25c is offline
Junior Member
BS.Player Newbie
 
Join Date: Mar 2012
Age: 36
Posts: 7
Rep Power: 0
wildheart25c is on a distinguished road
Default proper fonts of subtitle file not showing up in bsplayer

I am using Subtitle workshop to create arabic subtitles. This software has been mentioned many times in the topics I read (did a bit of searching before posting :D) so I'm sure many of you readers are familiar with it.
The output settings of that program include settings for ssa so i chose the font, the size, etc and saved the file.

I opened it with bsplayer and i got wierd english letters/symbols. So I opened the srt file and saved it as UTF8 and opened the movie again and the letters were displayed. Is there a way to display it while in ANSI instead of saving with UTF8 encoding? Moving on, even though it worked, the font was clearly not the one i set via subtitle workshop.

One user said, from an old topic, to go to preferences - subtitles - then select the right font from the list when you click on font.

This is not the solution I'm looking for. The font should be the one mentioned in the ssa file.

What do you suggest I do?

In vlc something different happened. I'm mentioning this because it might help. Hopefully! in vlc when the encoding was ANSI the letters were separated and not in order. they were arabic but their collective didnt make up any word i knew. in UTF the letters were separated and in reverse! BUT this time it was clear to me that it followed the font I had set via subtitle workshop!

What do you suggest I do?

Thank you.
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20