Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Answered And Solved Questions

Answered And Solved Questions A good place to check before you post your question. All answered / solved posts are archived here.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19th October 2010
Junior Member
BS.Player Newbie
 
Join Date: Oct 2010
Posts: 9
Rep Power: 0
Surpriser is on a distinguished road
Default No sound and old AC3 Filter

Hello,

I have installed BS player 2.56 Free.
There is no sound with 1920x1080 px HD movies in MP4 format while the sound is OK with the M2TS files!
I also get message of an old AC3 filter in codec manager.
I tried to installed it myself and still no luck.

Please help!

Thank you.
Reply With Quote
  #2 (permalink)  
Old 19th October 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

MP4 usually stores audio in AAC format. You will need an aac decoder, such as CoreAAC. Also, if sound is in DTS, I recomend also dtsAC3source to be installed.
Reply With Quote
  #3 (permalink)  
Old 19th October 2010
Junior Member
BS.Player Newbie
 
Join Date: Oct 2010
Posts: 9
Rep Power: 0
Surpriser is on a distinguished road
Default

Thanks!
But still nothing.
I have installed CoreAAC-1.2.0.573.exe.
The sound is stereo.
Reply With Quote
  #4 (permalink)  
Old 19th October 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

When the file is playing, please open preferences -> filters -> advanced and post here the filters used.
Reply With Quote
  #5 (permalink)  
Old 20th October 2010
Junior Member
BS.Player Newbie
 
Join Date: Oct 2010
Posts: 9
Rep Power: 0
Surpriser is on a distinguished road
Default

You mean filter management - filter manager? There are many installed filters.
Reply With Quote
  #6 (permalink)  
Old 20th October 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

No.
Open such a file, press Pause button, rightclick on the image and select:
Options -> filters -> advanced.
Reply With Quote
  #7 (permalink)  
Old 20th October 2010
Junior Member
BS.Player Newbie
 
Join Date: Oct 2010
Posts: 9
Rep Power: 0
Surpriser is on a distinguished road
Default

ffdshow?
Attached Images
File Type: jpg Untitled-1.jpg (99.5 KB, 12 views)
Reply With Quote
  #8 (permalink)  
Old 20th October 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Maybe also post what's under "Source".
(Seems like this problem where Haali splitter doesn't recognize audio-stream).
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #9 (permalink)  
Old 21st October 2010
Junior Member
BS.Player Newbie
 
Join Date: Oct 2010
Posts: 9
Rep Power: 0
Surpriser is on a distinguished road
Default

Here!
Attached Images
File Type: jpg Untitled-2.jpg (65.5 KB, 5 views)
Reply With Quote
  #10 (permalink)  
Old 21st October 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Yes, same as problematic file reported earlier. Also Haali which only detects video and no audio stream. So seems quite similar indeed! I bet that if one problem is solved, the other is too! I don't know if Ico-man (of BS.Player team) meanwhile tested further with that "Lion and frog"-file. No solution was reported back anyhow. I don't think adicoto, who also tested that file has found a solution. Otherwise he would surely have reported it. I'll ask Ico-man's attention to this thread. Hopefully a solution is found. Certainly now that more users have reported this (apparently similar) problem.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #11 (permalink)  
Old 21st October 2010
Junior Member
BS.Player Newbie
 
Join Date: Oct 2010
Posts: 9
Rep Power: 0
Surpriser is on a distinguished road
Default

Thanks!

If it helps, the non-working video was made by me. Other MP4 files I have tested are working fine. They were also made by me, but rendered as avi files, uploaded to youtube and re-downloaded in MP4.
Reply With Quote
  #12 (permalink)  
Old 21st October 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Maybe you could also make (in the same way as you did your problematic file) a short example file for testing purposes and upload it?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #13 (permalink)  
Old 22nd October 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

IIRC, lion and frog was a TS file, isn't ?
For the MP4, you could disable MP4 support in Haali media splitter and install Gabest MP4 splitter and test if works.

LE: yes, MPEG-TS,
Video= AVC, Profile: High@L3.0,
audio= MPEG1 LAYER 3, danish,
subtitles= DVB, danish
Reply With Quote
  #14 (permalink)  
Old 22nd October 2010
Junior Member
BS.Player Newbie
 
Join Date: Oct 2010
Posts: 9
Rep Power: 0
Surpriser is on a distinguished road
Default

Where can MP4 support be disabled?
-the MP4 files are working well in VLS player! Can it still be that Haali is having troubles with decoding?
Reply With Quote
  #15 (permalink)  
Old 22nd October 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

VLC doesn't use Haali. In fact I am allmost sure it's using Gabest.
I don't use Haali so I am not sure if my memory of it's configuration it's good.
On the other hand, I see your Haali is from 2009. On it's developper site it writes:




14/08/2010
  • Fixed items:
    • Fixed aspect ratio processing in certain Matroska files, which caused errors on open
20/05/2010
  • New Features:
    • Added support for WebM files
  • Fixed items:
    • Fixed a lot of issues with mp4 muxer
    • Better support for VC-1 in MPEG Transport streams
27/03/2010
  • New Features:
    • Added AC-3 in MP4 support
  • Fixed items:
    • Show error code in GDSMux when muxing is aborted
    • Accept more AAC media types in the muxer
    • Use correct timescales when processing MP4 edit lists
    • Scan the folder for more segments only if the file references external segments
So, maybe an update can solve the problems.
Reply With Quote
  #16 (permalink)  
Old 22nd October 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

I think version 1.10.262.12 (as shown in Surpriser's image) is latest Haali version at present (apparently they omitted to update the copyright string).
Again: it would be nice to have a small file to test, created the same way as the problematic file.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #17 (permalink)  
Old 22nd October 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

@ BSPeter So it seems ;)

Test Gabest.
Reply With Quote
  #18 (permalink)  
Old 22nd October 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Offtopic

@BSPeter

VLC seems to be the only player that can play corectly the lion and the frog on my computer. KMP states that the file have mpeg1 layer 3 audio (no audio), but VLC plays an AAC audio stream.
Reply With Quote
  #19 (permalink)  
Old 22nd October 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Presently I havn't installed VLC player (will think about it).
Like I mentioned before the file does play correctly in the player-part (MPlayer?) of "Any Video Converter" (which I do have installed).
Anyhow Ico-man let me know "We will try to do something about it in new beta. This is a splitter (Haali) problem."
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #20 (permalink)  
Old 25th October 2010
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,440
Rep Power: 10
Ico-man is on a distinguished road
Default

"There is no sound with 1920x1080 px HD movies in MP4 format while the sound is OK with the M2TS files!"

Can you post a sample of this file (in mpeg4), lion and frog was mpeg2.
Reply With Quote
Reply

Tags
ac3, filter, sound

Thread Tools
Display Modes

Posting Rules


All times are GMT +1. The time now is 05:01 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19