Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Answered And Solved Questions (http://forum.bsplayer.com/answered-solved-questions/)
-   -   Having problems with some mkv files (http://forum.bsplayer.com/answered-solved-questions/19595-having-problems-some-mkv-files.html)

Aemrod 16th September 2012 03:31 PM

Having problems with some mkv files
 
My bs player doesnt play some mkv files. Tried to search from google and several forums but no luck. Actually when i try to play those files in other players it plays but when i try bs player its like there is no file to play this happened before with some mkv files. İ have 80 mkv files and 3 of them doesnt work with bs player
If it is a codec problem how come other players can play it.
Also just downloaded k-lite mega pack to see if it changes anything. Well nothing changed.

Hope somebody can help me.

adicoto 16th September 2012 05:10 PM

Probably, indeed is a codec problem. Other players, suc as VLC, KMP or MPC have their own built in codecs, while BSPlayer rely on system codecs and those installed internally by codecmanager.
At this moment I believe that those MKVs have internal DirectVobsub subtitles and probably this is the cause. Can be solved instaling VSfilter (VobSub).
Can you post here or PM a link to such a file ?

adicoto 17th September 2012 06:37 PM

OK, downloaded 14 GB file and all I can say it's that it plays OK in here. File is 1920x1040, AVC, DTS, AC3 dual audio stream.
Decoded using Haali (and tested Gabest too), CoreAVC and Ac3Filter.

But......
seems that the filename contains some special characters. So, my advice is to copy the file to another location ( if you still want to seed it) and change it's name to something else, like Jurassic 2 or whatever and test it again.
If it works, it's probably related to your Windows' regional settings ( I am using central european for diacritics).
If it doesn't, then probably your filters can't handle the streams and we'll need to work out the problem.

Aemrod 18th September 2012 01:36 PM

Well i tried to change name and it worked can't belive it was because of stupid characters. For vobsub still trying to figureout how to remove that sub from mkv file.

edit1: Forgot to mention after installing vobsub. 13th warrior movie(i think i sent you the link but not sure) has new problem now a box pop-up with "Mkx" named and says;
"a decoder for the new track could not be found. Tracktype:Vobsub"
after clicking ok bs player opens a black screen and still dont play. It indicates mkv file time like "00:00:00 / 1:42:46". But when i try to press space or click play icon it does not play. Working on this right now.

adicoto 18th September 2012 01:51 PM

As you can read in this post:

http://forum.bsplayer.com/general-ta...subtitles.html


I have stumbled on such a file. But for me it works OK, using old subtitle engine, and in preferences -> subtitles -> vobsub I have enabled VobSub suport and load subtitle into memory.
It may be related to using ffdshow as decoder (I am not sure). I am using CoreAVC for x264 files not ffdshow.

elpidisp 22nd October 2012 07:31 PM

easy solution
 
after bs player opens the black window, without playing anything, just do a search for subtitles, copy them from the Sub folder, into the movie folder and start again the movie, that works for sure ! (windows 7 ultimate 64bit)

ntontos 5th November 2012 05:51 PM

problems with bsplayer
 
i have a problem with bsplayer..It cannot play movies(MKV files)..neither the screen opens,neither you can see the time of the movie(for example it does not show 01:00:12/01:30/16,only 00:00:00/00:00:00)..I don't have problem with music..It plays all mp3 songs..I have uninstall and install the bsplayer a lot of times, but nothing happened..i tried to solve the problem by installing codec packs, but nothing happened too..

please help me!!:frown:


All times are GMT +1. The time now is 02:53 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20