Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   Static frame shown when on screen text displayed (http://forum.bsplayer.com/bug-reports-codecs/11333-static-frame-shown-when-screen-text-displayed.html)

BarnyStewart 3rd May 2010 04:55 AM

Static frame shown when on screen text displayed
 
BS Player has recently started showing a fixed frame when I change the volume or seek forward or back (left or right arrows) through the file. The frame will remain static while there is text being displayed/updated (such as the volume level or time) and then normal playback will resume.

The fixed frame is usually a blank frame when you start a file but may display a random image from earlier in the video. While the frame remains static the text being displayed will update correctly.

I am currently using version 2.53 build 1034, however I cannot be sure if the problem was introduced with this version or if it began with an earlier version.

This problem appears to be unique to the EVR video renderer as it does not occur when using the VMR9 video renderer, however the quality of the displayed image is significantly reduced with VMR9 - noticably more blocky or pixellated when in full screen.

I am using Windows 7 with an Ati Radeon 4850 and the latest Ati drivers.

BarnyStewart 7th May 2010 06:54 PM

Update
 
I have experimented some more and found the following:

The problem occurs with both 2.52-1031 and 2.53-1034.
When seeking forward and back the static frame that is displayed changes.
When changing volume the static frame is displayed but is unchanged.
The problem also occurs when subtitles are displayed.

This problem is evident on 2 separate computers.
This problem is evident with the latest graphics drivers as well as the older ones that I was using when I originally observed the problem.

As stated previously, this problem is only evident with the EVR video renderer. The problem does not appear with either the overlay renderer or with the VMR9 renderer, however these are not viable alternatives as the overlay renderer is incompatible with Aero and the VMR9 renderer produces a very low quality image.

It appears as if any text on screen is being rendered to a buffer containing a still image from the video and this still image is obscuring the active video frames rather than having the text simply blended as intended. Once the text dissappears the active video can be seen again.

Any help would be very welcome indeed!

Cheers

Barny


All times are GMT +1. The time now is 04:52 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20