Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   Overlapping subtitles in full screen mode//BS freezes once in a while (http://forum.bsplayer.com/bug-reports-codecs/11827-overlapping-subtitles-full-screen-mode-bs-freezes-once-while.html)

mishec 15th November 2010 11:55 AM

Overlapping subtitles in full screen mode//BS freezes once in a while
 
Hello,
I have new problem with my BSP. Everytime I play the video in fullscreen mode, with subtitles under the video frame, old "lines" are still there, while the newer lines "overlap" them. It looks really bad, however you have 3- 4 lines over themselves at once, making them unreadable. I found only one solution - not playing video in a full screen mode, just in a window maximized for the whole screen (I use mousewheel for it)
Any suggestion? I tried changing preferences for subs, but nothing happened.
Thanks.

BSPeter 15th November 2010 04:17 PM

And you're using BS.Player (Pro) version/build nr?
What type of subtitles are we talking about?
I assume in the past you never had such problem?
Any new video card drivers installed recently? (or auto-update?)
Are you using old or new subtitle engine or.. is "Use new subtitle parser/renderer" selected/deselected under
(rightclick >) Options > Preferences > Subtitles [Subtitle properties] ?
Also is "Enable drawing subtitles under image with EVR renderer" selected/deselected?
(What happens if you change that setting?)
What OS are you running on your PC?
What video "Rendering mode" do you use?
(rightclick >) Options > Preferences > Video > [Video rendering]
:wink:

adicoto 15th November 2010 08:27 PM

Not a fix, but maybe a little help: hit F 3 times in a row (Go to fullscreen,windowed, fullscreen again). Sometimes it fixes the problem.
Option "draw subtitles on overlay" is it disabled ?

BSPeter 15th November 2010 08:37 PM

Quote:

Originally Posted by mishec (Beitrag 43151)
...Everytime I play the video in fullscreen mode, with subtitles under the video frame...

Quote:

Originally Posted by adicoto (Beitrag 43156)
...Option "draw subtitles on overlay" is it disabled ?

As far as I know if one has "Draw subtitles to overlay" enabled, subtitles can only be drawn on overlay = on the video picture, and not below, or ...?
:confuse:
At least that's why I didn't ask (my hunch).

mishec 16th November 2010 12:44 PM

Well, I have BS player PRO 2.53. After changing to another rendering mode and than back to mine, anything started to work properly.

BUT, still.
BS player keeps freezing in the end of the video. 9/10 times in the end, it stops 1 second before end, freezes, does nothing. i have to kill the process via task manager. This happens almost everytime, mostly in longer videos (10mins +). If I rewind the video to the end and watch it, it will properly stop/or restart playing, depending on my settings. But, if I watch it second by second, it tends to freeze. This also happen often when I have to close movie I ve been watching for 20 minutes, anything will freeze. Any suggestions? :)
PS: I use Direct Draw Surface (or something similar, its the first item on a list of rend.). Any other renderers dont work properly, one of them makes subtitles too big, others tend to make OSD too long, some of them play just sound without picture etc. Id really appreciate some help with this. Happens with any movie types, mostly .avi. .rmvb, .mkv, .flv etc.
I also have K-Lite Codecs installed, the biggest pack without player. Anything works properly except this freezing.

But mostly THANK you for quick response and help !

BSPeter 16th November 2010 07:16 PM

Could you please update to latest version through your user-area and let us know if the problem still exists?
:wink:
P.S.
I've always and consistently advised against using codec-packs, so in that connection I certainly don't think "bigger is better", to the contrary!!

mishec 17th November 2010 08:00 AM

OK, i updated my BSP to 2.56 and anything seems to work properly. Thank you guys !
PS: I only played 1 episode, so we ll see about it later, but i think that anything will be fine now.

mishec 17th November 2010 06:09 PM

Update: Today, it froze only 2/10 times, so id call that a small victory. But still the problem has to be somewhere.
Anyway,Subs are working properly :)

mishec 20th November 2010 01:19 PM

Problem appeared once again. Im pretty desperate :(
2.56 PRO
.avi+.rmvb
Renderer: Internal DirectDraw Surface

Thinking of using the Media Player Classic, its seriously pissing me off :-/

BSPeter 20th November 2010 06:46 PM

Quote:

Originally Posted by BSPeter (Beitrag 43152)
And you're using BS.Player (Pro) version/build nr?
What type of subtitles are we talking about?
I assume in the past you never had such problem?
Any new video card drivers installed recently? (or auto-update?)
Are you using old or new subtitle engine or.. is "Use new subtitle parser/renderer" selected/deselected under
(rightclick >) Options > Preferences > Subtitles [Subtitle properties] ?
Also is "Enable drawing subtitles under image with EVR renderer" selected/deselected?
(What happens if you change that setting?)
What OS are you running on your PC?
What video "Rendering mode" do you use?
(rightclick >) Options > Preferences > Video > [Video rendering]
:wink:

Sofar only the first and last question answerred (both greyed out in this quote). Also:
Quote:

Originally Posted by BSPeter (Beitrag 43164)
....I've always and consistently advised against using codec-packs, so in that connection I certainly don't think "bigger is better", to the contrary!!

Maybe also reveal some info on your PC & video card please. When you installed BS.Player did you allow it to internally (i.e. to be used by BS.Player only and not interfering with other programs on your system) install its preferred codecs? Could you please load a videofile which causes problems and then select "rightclick > Options > Filters > Advanced" and let us know the filters/codecs (including what's mentioned under "Source") actually used by BS.Player for playback of that file? (By clicking on the [+]-signs in front of the filters/codecs you reveal further info and access.)
:wink:
P.S.:
As a purchaser of Pro-version, you're entitled to obtain direct (e-mail) support by BS.Player team (click here). Did you try that route already?

mishec 20th November 2010 08:19 PM

What type of subtitles are we talking about?
- As i wrote in past: standart .srt (mostly)
I assume in the past you never had such problem?
- Well, yes, I had it in the past, updated to 2,56 and now, I have this problem once again.
Any new video card drivers installed recently? (or auto-update?)
NO.
Are you using old or new subtitle engine or.. is "Use new subtitle parser/renderer" selected/deselected under
(rightclick >) Options > Preferences > Subtitles [Subtitle properties] ?
Also is "Enable drawing subtitles under image with EVR renderer" selected/deselected?
(What happens if you change that setting?)
Yes, its unabled, but nothing happens even if I disable it.
What OS are you running on your PC?
Windows 7 Ultimate
My GPU is old one - Radeon X1600 Pro

--- However, now the subtitles arent the problem, I am worried about FREEZING now :(. It sometimes happens in the end (1 sec before) and sometimes when I pause the actually running video and doubleclick another - BS will freeze - I have to shut the process down via Task Manager. This often happens with opened video and doubleclicking .mp3 files. Simply, when I have loaded video, BS tends to freeze everytime it has to open new file and/or reopen old file (when the video ends and repeat is enabled).


PS:
Yes, i thought about it, but this BSP was a gift from my friend who is now far away and has some family problems, so I didnt want to bother him with this, + I thought that I will get faster reply here (and I was right ! ;)).
Anyway, if we cant solve this problem here, I will not hesitate and ask him about the e-mail he used ;)
Thank you again for help !

BSPeter 26th November 2010 01:39 PM

Re overlapping SECONDARY subtitles see this post
:wink:

mishec 26th November 2010 01:57 PM

Thanks for help, but subs work properly this time. Anyway, subs werent overlapping that much, only overlap happened under the picture in fullscreen mode - i mean that black frame added in order to play video in fullscreen without resizing.
Anyway, BS keeps freezing once in a while. Still. Any suggestions? :)

BSPeter 26th November 2010 02:03 PM

Quote:

Originally Posted by mishec (Beitrag 43262)
... i mean that black frame added in order to play video in fullscreen without resizing.

What do you mean by that? Do you mean you're using "Extend picture to"-option?
:wink:

mishec 26th November 2010 03:13 PM

No I dont use anything like it. It just normally happens however the aspect ratios of video and my lcd arent the same, so in order to play it in a fullscreen mode, the BS had to "overpaint" the parts of the screen which is not covered by video.

BSPeter 26th November 2010 05:39 PM

OK thks for the info. Your remark was very confusing!
:wink:

mishec 26th November 2010 06:23 PM

Well, sorry for that, I didnt want to call it black frame, but maybe it would be more accurate :)


All times are GMT +1. The time now is 01:52 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20