Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   [CONFIRMED for right to left subs] The subtitles are reversed ! (http://forum.bsplayer.com/bug-reports-codecs/11884-confirmed-right-left-subs-subtitles-reversed.html)

HeaDRaZoR 3rd December 2010 11:24 PM

[CONFIRMED for right to left subs] The subtitles are reversed !
 
The version of my BS Player is 2.57..
I dont know why but from yesterday BS Player show me the subtitles reversed..
I mean.. if it show " Hi man " so its show " man Hi "
First I thought its the subtitles and tried to download another one.. but no I just saw that its all the subtitles ! and it wasnt like that :sad:
Can somebody tell me how to fix it ?

By the way.. the subtitles that i use are Hebrew..

BSPeter 4th December 2010 12:12 AM

1 Attachment(s)
Build nr?
So how does it show? !שלום איש
Wyssinwyg (what-you-see-sometimes-is-not-what you-get), therefore also an image below!
What script is selected under
(rightclick >) Options > Preferences > Subtitles > Font ?
If you open the subs in e.g. Notepad, they are correct?
:wink:

HeaDRaZoR 4th December 2010 10:51 AM

Quote:

Originally Posted by BSPeter (Beitrag 43367)
Build nr?
So how does it show? !שלום איש
Wyssinwyg (what-you-see-sometimes-is-not-what you-get), therefore also an image below!
What script is selected under
(rightclick >) Options > Preferences > Subtitles > Font ?
If you open the subs in e.g. Notepad, they are correct?
:wink:

No man.. you didnt got it..
I told u.. some days before the text was ok.. now its reversed !
I mean.. if its showed " How you doing man.. you know that im married ? "
So it massed! it show " ? married im that know you.. man doing you How "
get it ? the subtitles are ok.. cause I already watched the movie.. and its was good.. but I dont know what happen.. now its reversed/messed.

BSPeter 4th December 2010 04:06 PM

I'm unfamiliar with Hebrew. I just used an internet translation for 'Hi man'.
One of the meanings of 'man' is husband.
But in fact if it is nonsense, that is of no importance.
It only serves to get a better idea what exactly you mean.
Your second post isn't helpfull at all.
It most surely doesn't help me to "get it".
E.g. it doesn't even answer my clear and entirely relevant question about the script.
Another question: is the box "Use new subtitle parser/renderer" selected?
((rightclick >) Options > Preferences > Subtitles [Subtitle properties])
If so, could you test what happens if you deselect it (or vice versa)?
:confuse:

HeaDRaZoR 4th December 2010 07:23 PM

Quote:

Originally Posted by BSPeter (Beitrag 43387)
I'm unfamiliar with Hebrew. I just used an internet translation for 'Hi man'.
One of the meanings of 'man' is husband.
But in fact if it is nonsense, that is of no importance.
It only serves to get a better idea what exactly you mean.
Your second post isn't helpfull at all.
It most surely doesn't help me to "get it".
E.g. it doesn't even answer my clear and entirely relevant question about the script.
Another question: is the box "Use new subtitle parser/renderer" selected?
((rightclick >) Options > Preferences > Subtitles [Subtitle properties])
If so, could you test what happens if you deselect it (or vice versa)?
:confuse:

Tnx.. man it works !
I deselected "Use new subtitle parser/renderer" now its work fine ! i mean.. its not messed/reversed !
tnx for help me
:teeth:

BSPeter 4th December 2010 08:34 PM

:teeth: Glad your problem is solved.
Nevertheless, I'm still curious what script is/was selected under
(rightclick >) Options > Preferences > Subtitles > Font ?
(This when using new subtitle parser/renderer!)
:wink:

sapir 8th December 2010 11:21 AM

reverse subtitle
 
when i add a subtitle the subtitle show reverse it means the text
"i love you" look "you love i" how i fixed it?
i have pro bsplayer 2.57

BSPeter 8th December 2010 12:46 PM

Quote:

Originally Posted by sapir (Beitrag 43467)
when i add a subtitle the subtitle show reverse it means the text
"i love you" look "you love i" how i fixed it?
i have pro bsplayer 2.57

This is a bug in build 1049 with the box "Use new subtitle parser/renderer" being selected
(under (rightclick >) Options > Preferences > Subtitles [Subtitle properties]).
It appeared that font script was then automatically set/fixed to "Western".
So if you're not using build 1050, please update!
I'm not sure if fixed in build 1050, but would like to see your feedback on this.
If not fixed, please deselect new subtitle engine for the time being.
:wink:

BSPeter 8th December 2010 01:33 PM

This appeared to have been a bug in 1049 build (perhaps repaired in 1050/1051 build?)
:wink:

siwesam 24th December 2010 03:51 PM

Same here with arabic
 
I have the same bug in Arabic...
I have build 1051 and it is still there...
Using the old renderer works fine.


All times are GMT +1. The time now is 08:00 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20