Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   5.1 Surround on BSPlayer (http://forum.bsplayer.com/bug-reports-codecs/18151-5-1-surround-bsplayer.html)

alanarg 27th August 2012 09:40 PM

5.1 Surround on BSPlayer
 
Hi everyone, my name is Alan and I'm new here. I'm from Argentina so, sorry for my rusty english.

I was trying to make it work a 5.1 sound system Bose with BSPlayer and AC3Filter (and Intervideo Audio Decoder) but it doesn't work.

At first I installed just the BSPlayer, but when I tried to change the audio preferences it doesn't work (the part of the "audio > intervideo audio", I selected the 5.1 option) so I google the issue and I found this forum, and this thread.

There, an user called "hazmat42" says that if you download AC3Filter or Intervideo Audio Decoder it should worked, and the user that had the same problem as me confirmed that "hazmat42" was right. I did everything what "hazmat42" says, but it didn't work for me. I mean I download "AC3Filter" and change the configuration (no results) and then I download "Intervideo Audio Decoder" and change the configuration in BSPlayer's preferences (as hazmat42 says) but no results either because when I change the preferences and close the preferences window and open it again I discover that it cames back to stereo.

Reading a bit more about this I found another forum that says that if you change the BSPlayer's preferences you have to keep the window open, because if not the changes don't save. I tried this too, but there wasn't luck.

I'm connecting my notebook with HDMI to my home theatre system Bose, video and sound it's perfect, but just stereo.

I hope you can help me, thanks for everything.

adicoto 28th August 2012 04:58 AM

First of all, that InterVideo configuration window is legacy and doesn't actually do something. So, forget about it.
Second, does your speaker configuration is set to 5.1 in audio configuration (Window's configuration, not BSPlayer's) ? Usually, by default, on a laptop this is set to stereo.
When you play 5.1 sound, in AC3Filter's main window can you see input signal as 5.1 or is it stereo ?
Output is set to 5.1 ?

alanarg 28th August 2012 05:07 AM

Quote:

Originally Posted by adicoto (Beitrag 60387)
First of all, that InterVideo configuration window is legacy and doesn't actually do something. So, forget about it.
Second, does your speaker configuration is set to 5.1 in audio configuration (Window's configuration, not BSPlayer's) ? Usually, by default, on a laptop this is set to stereo.
When you play 5.1 sound, in AC3Filter's main window can you see input signal as 5.1 or is it stereo ?
Output is set to 5.1 ?

Yes, in Window's configuration I choose the option that says "Bose etc." and 5.1, I also do a test prooving that works the 5.1 sound.

What you mean with "AC3Filter's main window"? The main window is the config window?

adicoto 28th August 2012 05:15 AM

1 Attachment(s)
See the attachement. Main window of AC3Filter, 5.1 config (top left) input and output signal on the right

alanarg 28th August 2012 05:26 AM

1 Attachment(s)
Quote:

Originally Posted by adicoto (Beitrag 60389)
See the attachement. Main window of AC3Filter, 5.1 config (top left) input and output signal on the right

The "output format" it's in 5.1, but when I play the input and output signal didn't change as you can see in this picture.

Attachment 1679

adicoto 28th August 2012 05:32 AM

I can see that AC3Filter reports unknown input.
What kind of file are you playing ? (AVI, MKV..... ?)
Sound is AC3 ? DTS ? AAC ?

alanarg 28th August 2012 05:35 AM

Quote:

Originally Posted by adicoto (Beitrag 60393)
I can see that AC3Filter reports unknown input.
What kind of file are you playing ? (AVI, MKV..... ?)
Sound is AC3 ? DTS ? AAC ?

The file is ".mkv", and I don't know what sound is, I don't know how to know it if you know what I mean.

Thanks for everything.

adicoto 28th August 2012 05:42 AM

Usually MKV's come with AC3 or DTS sound.

So, first of all, play the file and post here filters used to decode the file ( play file -> rightclick -> options -> filters)
Second, open the file in programs such MediaInfo (which shows which codecs were used to encode the file)

cvrak 3rd December 2012 08:58 PM

Hi,

I've made a clean win 8 pro 64 bit clean installation in my laptop, and I've installed bs player and AC3 filter.
I have connected Creative X-Fi Extreme Audio Notebook 5.1 speakers.
When I play an MKV file with DD 5.1 sound, in bs player the ac3 input is 2.0 stereo, the output 5.1 (set by me).
Any ideas why the bs player doesn't understand the 5.1 input? Before new installation the mkv played ok.

Pls advise

Regards
Chris

BSPeter 4th December 2012 01:52 AM

Like adicoto already mentioned in his last post in this thread:
Please let us know the filters used by BS.Player when playing the file:
rightclick > Options > Filters > Advanced.
Be sure to click on "Source" and on the small +signs in front of the filters/codecs shown so that further info (and access) becomes available.
:wink:
(If applicable: forget about BS.Player's "InterVideo AC3-page".)

cvrak 4th December 2012 08:15 AM

1 Attachment(s)
Hi,
I send you a screen capture from Options/Filters/Advanced

cvrak 5th December 2012 06:15 PM

Hi again,

I uninstalled bs player 2.51, installed the latest version and also the ac3 2.5 version.
Still, while playing 5.1 mkv file, the audio input is 2.0.
Can anyone help? Is it possible combatibility issue with win 8?

BSPeter 7th December 2012 03:11 PM

Regretfully, I'm not on Windows 8 yet, so I cannot test.
Maybe adicoto or Ico-man?
:wink:

adicoto 7th December 2012 08:12 PM

1 Attachment(s)
One of the first problem when Win 7 was introduced it was about setting sound configuration to 5.1. By default, laptops have stereo output so, in my opinion, when installed Win 8 will set audio output to stereo. And that is in Window's control panel, audio output, speaker configuration. So, the decoding chain will be set to stereo before inputing to AC3Filter. If it's available in speaker configuration, the option 5.1 must be set.


All times are GMT +1. The time now is 01:27 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20