Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   3 bugs in 1.0 807 (http://forum.bsplayer.com/bug-reports-codecs/4134-3-bugs-1-0-807-a.html)

casperboy77 3rd March 2004 04:07 PM

3 bugs in 1.0 807
 
Hello, I decided to register and report these bugs so that hopefully they can get fixed. The "Problem 1" I have listed is a new problem since version 1.0 806 and is still in 1.0 807. As for the other 2 problems, I have been having them problems for a very long time. Bsplayer is an extraordinary player. I only seem to be having problems since I went to your 1.0 version. But I really don't want to switch back to an old version. Below are my 3 problems. Thank you.

-----------------
Problem 1:

When I goto Options then to preferences... and then click close I get the following:

BSPlayer v1.00.807, Unhandled exception at EIP: 00477BB7
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
List index out of bounds (11)
EListError
, 0x004E9B4B, 0x004E9D49, 0x004535B3, 0x0044A8FE, 0x77D43A50, 0x77D43B1F, 0x77D43D79, 0x77D44374, 0x004EAC88, 0x77E814C7

Then when I click close on that box I get the following:

Bytes at EIP: 85 DB 74 13 8B C3 8B 15 F4 71 47 00 E8 40 B6 F8 FF 84


-----------------
Problem 2:

That is the first bug now here is the second bug I have been having. This bug has been in BS Player 1.0 for a while now and is still in builds 806 & 807:

Goto Options then to Preferences. Click on the Video Menu, in the Video section click on the "Use RGB Overlay". A Pop-up menu will appear. The mouse gets trapped in that menu and gets all screwey. The Link below will show a bit of a screenshot, but it doesn't really show the problem.

Here is screenshot: http://www.hoogle.org/bsplayerprob1.jpg

-----------------

Problem 3:

Ok, I haven't been able to open .wmv files since you went to version 1.0. Yes I have the latest and greatest MS Codecs installed. I can open .wmv files in every other player on my computer and watch them with no problem. I just wish BSPlayer would open .wmv files, so that I can use just 1 player for all movies.

Quietseb 3rd March 2004 05:59 PM

I too get bug 2 in builds 806&807 [I suppose it's a consequence of the new 'video preferences' layout]
however the mouse is not trapped in the menu each time.
on the other hand an error 'List index out of bound (11)' always appears.
if I choose continue I can still use bsplayer (but I'm not sure whether it did use RGB overlay) BUT each time I try to access preferences I get the List index out of bound error again and I can't access preferences.

after closing/restarting bsplayer I can access preferences once and change video settings but on closing preferences I again get the same error (that's casperboy77's bug 1) and same thing as above (can't access preferences at all until closing/restarting bsplayer)

Wolfied 3rd March 2004 07:59 PM

An other bug : when i disable OSD and in fullscreen want to change aspect ratio with shift+1 2 or 3 the screen becomes black .

bluedan 5th March 2004 07:51 PM

? Can't confirm your bugs.
But subtitle support has definitely been borked. Again.
Someone has already posted about wrong characters (?¤,?¶,??,??,...)
And -bsi support is still broken, too!!

Quietseb 5th March 2004 09:33 PM

Quote:

Originally Posted by bluedan
? Can't confirm your bugs.

know what ? I wasn't able to reproduce bug 1 (= persistence of the error) with a clean bsplayer...
in case bug2 depends on hardware, I have an ATI Radeon Mobility 9000 64Mo (and the bug doesn't appear on my Geforce1 & 2 cards because: RGB overlay isn't even supported on these => the RGB type combobox doesn't appear)

Quote:

Originally Posted by bluedan
But subtitle support has definitely been borked. Again.
Someone has already posted about wrong characters (?¤,?¶,??,??,...)

even after selecting a suitable script in the fonts options ??? my french subs display ok [tested only with avi + srt, I don't have anything else right here]

one remark on that aspect though:
for one video file (clock.avi [found in c:\windows]), having the sub file name clock.srt => subs were displayed but video output was black in overlay mode 1 (mode 2 ok)
I renamed the sub file so it wouldn't be loaded -> clockt.srt
it was loaded nevertheless (yes, I had forgotten that I had 'load any subtitle in current directory' checked), but this time video was ok
other video files don't seem to have this problem. since it's RLE avi, I suppose it's unimportant. but it's curious (I lack a better word) ;)

adicoto 5th March 2004 11:04 PM

Sorry, but I can't reproduce none of these bugs using 1.807.
But for "List of index..." check the language file, maybe there is the error.

casperboy77 10th March 2004 07:03 AM

I forgot to mention I have Win XP Pro with SP1 and all the latest updates. And an ATI Radeon 7000 64MB. So what you are saying is that the RGB overlay doesn't work with the ATI cards? Anyways the reason I was trying that setting is because I just can't figure out why it won't play .wmv movies. As I said in my previous post all the latest codecs are installed and working properly. I tried every checking utility to make sure they were proper. Windows Media Player, Divx Player (One that comes with 5.1.1. codec) and a few other players I have play .wmv files perfectly. Also the versions before your 1.0 came along played them perfectly as well. It seems right after I updated to this 1.0 the problems began. Everytime I update the 1.0 version it gets worse :? . I'll try completly uninstalling it and I'll seach for registry entries and delete them and try a fresh install. I'll post what happens here. Thanks.

Quietseb 10th March 2004 10:33 PM

Quote:

Originally Posted by adicoto
But for "List of index..." check the language file, maybe there is the error.

sorry I didn't reply earlier; no it has nothing to do with the language file (I always use the default english; even with absolutely no lang file it still crashes)

I dont think it's related to ATI hardware since this bug appeared with a new video preferences menu layout, not before... (I can select RGB overlay for the same ATI card in build 805)
But I just noticed that both casperboy77 and I use custom windows themes [which influences the display of comboboxes as well as the rest]... in my case it is achieved by using a hacked uxtheme.dll (in %windir%\system32 ); presumably it is the same for you casperboy77 ?
I'd have to try with the original uxtheme.dll to check that. just in case

casperboy77 11th March 2004 04:46 AM

I use stylexp 2.01 (http://www.tgtsoft.com/) which does hack the uxtheme.dll. Thanks for catching that I forgot to mention that. I run a few other programs as well probably nothing that interfears but here is a few: MacDrive 5.x, Yahoopops 0.5, Hotmail Popper 2.1.0, Norton Anti-Virus 2004, Quicktime 6.5, Yamaha XG Synth., Logitech Mouseware 9.79, Epson Photo 820 Software, and my Wireless LAN monitor. Those are about all the programs that are always running in the background. Hope this info helps, and thanks again.

-Jim

adicoto 11th March 2004 03:07 PM

Just changed my TNT2 with an Radeon 7000. And gues what ? My mouse get trapped. :wink:

Quietseb 11th March 2004 05:28 PM

ok.
thanks a lot for checking that :wink:
I guess something beyond the layout was changed :roll:

casperboy77 12th March 2004 05:32 AM

Phew! I'm glad people are confirming the same issues I'm having. I was begining to think it was all me. So with the Mouse getting stuck issue, and the preference crash issue, and .wmv issue, is it possible that these can be fixed in another release of bsplayer? What I mean is: Is this enough information for the programmer to locate the issues within their coding? I don't know much about how programming works. But if there is any more info or anything that is needed let me know and I'll do my best to get it. Thanks again.

plas 18th March 2004 06:12 PM

Quote:

Originally Posted by Wolfied
when i disable OSD and in fullscreen want to change aspect ratio with shift+1 2 or 3 the screen becomes black .

Thank you. I had the same problem and I didn't know that OSD must be enabled. I don't like OSD, so I have set its font size to 1.

adicoto 18th March 2004 06:47 PM

Running last Catalyst, and overlay mode 2 no problem. All working clean.
No other bug.

Zhasha 29th March 2004 03:01 PM

Re: 3 bugs in 1.0 807
 
Quote:

Originally Posted by casperboy77
Problem 1:

When I goto Options then to preferences... and then click close I get the following:

BSPlayer v1.00.807, Unhandled exception at EIP: 00477BB7
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
List index out of bounds (11)
EListError
, 0x004E9B4B, 0x004E9D49, 0x004535B3, 0x0044A8FE, 0x77D43A50, 0x77D43B1F, 0x77D43D79, 0x77D44374, 0x004EAC88, 0x77E814C7

Then when I click close on that box I get the following:

Bytes at EIP: 85 DB 74 13 8B C3 8B 15 F4 71 47 00 E8 40 B6 F8 FF 84

I fixed this by uninstalling my BSP and then installing it again, i guess it was colflicts between some registry entries from an older version and the current one that made it crash...

casperboy77 29th March 2004 05:08 PM

Zhasha:

Thanks for the tip. I'm going to try that now.

casperboy77 29th March 2004 05:29 PM

Yup, that's what it was. BSplayer has changed where it installs a couple times. So I also went through the registry and deleted all the old key. I reinstalled it and now I don't get that error any more. Problem #1 solved :D , Thanks

Fenyo 31st March 2004 03:08 PM

I can confirm the WMV problem!
For the first time, BSPlayer 1.0 807 could play WMVs, but now something is changed(maybe just a registryentry about BS), and now BSPlayer says for WMVs: "Can't open file". And all other player can play WMVs right now.
I think maybe the reason is that WMV filters are DMO (Direct Media Object) filters, not just DirectShow filters.
BST please have a look to this.


All times are GMT +1. The time now is 11:59 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20