Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   When I open starcraft, Couldn't create primary surface (http://forum.bsplayer.com/bug-reports-codecs/4509-when-i-open-starcraft-couldnt-create-primary-surface.html)

taz_eat 1st May 2004 11:17 PM

When I open starcraft, Couldn't create primary surface
 
I have had this issue since i got bsplayer several versions ago. I like it because I can use it with my winLirc, but if I launch starcraft it cuts out the audio and it makes a Message Box pop up saying:

Couldn't create primary surface.

I searched the forum and tried different video rendering modes, they all show same error except for VMR-9 which made a message box that said I did not have direct x 9 (which I do, and it works until I launch starcraft).

I run:
Athlon XP 2600+
Integrated SoundMax soundcard (Did same thing on my Creative SB live! value)
Geforce fx 5200

Nothing out of the ordinary for hardware

Note: this is the same for nearly all fullscreen games, not just starcraft, I used it simply as an example.

deff 24th May 2004 07:40 PM

same here
 
it happens with all games that use directx. it's pretty annoying and should be fixed somehow already, this "feature" is here for way too long.

adicoto 24th May 2004 07:49 PM

Both games and BSPlayer are using the overlay surface generated by the videocard. But only one of them can use it at a time. Not both at the same time. That is why MPlayer can do that, because is not using overlay.


All times are GMT +1. The time now is 05:10 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20