Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   bug opening xvid (http://forum.bsplayer.com/bug-reports-codecs/4881-bug-opening-xvid.html)

jsmile 27th June 2004 10:56 AM

bug opening xvid
 
Have encountered a weird bug associated with Xvid files:

- If I just open BSplayer, and then open a file encoded in xvid (avi/ogm/or mkv), it will indefinitely hang, refuses to ctrl-alt-del, and must be hard-rebooted.

- If I open a file encoded in something else (mpg/divx/wmv9/etc), close it, and THEN open a file encoded in Xvid, it works just fine.

I'm using XviD-1.0.1, but have also tried 1.0 RC3. Did a clean install about 2 weeks ago, and am using a relatively small amount of codecs (xvid/divx5.1.1/wmv9/and an mpeg2 decoder are all the 3rd party codecs i've installed, plus the usual audio, aac/ogg/ac3filter/etc).

Running win98se, P4 2.8, asus P4P-800E, 1gb, R9600 w/latest cat 4.3, dx9b.

Obviously, everything renders fine using gspot/etc, but just hangs for some reason if i don't open another file first. I've also experimented using different overlays, but they all seem to have the same result.

[EDIT]: using build 809 currently, but have replicated bug using build 805 also. Xvid opens fine on the first try using WMP 6.4.

BSPeter 27th June 2004 11:08 AM

Is "Support Generic Mpeg-4" under "Quality Settings" tab of DivX Decoder's properties selected or deselected?
([Start] > Programs > DivX > DivX Codec > Decoder Configuration Utility)
:wink:

jsmile 27th June 2004 11:16 AM

DivX: support generic mpeg-4 is deselected.
Xvid: DivX, DX50, MP4vX are deselected also.

I'd forgotten about those, will have to mess around with them a bit, thanks for quick reply.

BSPeter 27th June 2004 11:31 AM

Re: bug opening xvid
 
Quote:

Originally Posted by jsmile
I've also experimented using different overlays, but they all seem to have the same result.

Just checking: (assuming that you probably needn't "Disable YV12 format" for your graphics-card) you did also include "Use VMR-9" in those experiments, or...?
:wink:

facff 2nd July 2004 03:18 PM

Same Problem
 
I am exactly with the same problem.

My conf.
P III 700, Win ME 2 ED
Codecs: DivX 5.11 only
Player: BSplayer 1.00 RC1 Build 809

I already try to uncheck the generic support in the divx's 5.11 decoder utility and not worked.

When playing another file and play the xvid again the player play without problems. Otherwise I have to shutdown the computer manually.

Any help?

adicoto 2nd July 2004 07:49 PM

So you don't have another MPEG4 decoder on your computer. YOu should install XviD 1.01 because newly encoded movies do have compatibility problems even with older XviD releases.

facff 3rd July 2004 02:41 AM

XviD Bug
 
Thanks for the help!

I already installed the XviD 1.01 decoder but didn't work.

I disabled the generic support of mpg-4 from DIvX 5.11 Decoder Utility and the FourCC Support from XviD Configuration. So the DivX files are decoded by DivX 5.11 and XviD files by XviD decoder.

Thanks.

jsmile 5th July 2004 09:15 AM

I mucked around a bit with the divx/xvid configs, but couldn't seem to get the problem resolved that way. I then decided that this would be a good opportunity to make the upgrade to winxp, and I've not experienced the problem since then, but thanks for the suggestions :)

facff 5th July 2004 01:26 PM

DivX Bug (worked for me)
 
I solved this intalling ffdshow decoding filter (http://sourceforge.net/projects/ffdshow) together with DivX 5.1.1 (http://download.divx.com/divx/DivX511.exe) and XviD 1.0.1 (http://www.roeder.goe.net/cgi-bin/fe...1-05062004.exe) codecs.

In DivX's Decoder Utility (start/programs/divx/divx codec) in quality settings disable Support Generic Mpeg-4.

In XviD's Configure Decoder (start/programs/xvid/configure decoder) disable all fourCC support for DIVX, DX50, mp4v

So the divx files will be play by DivX 5.11 codec and the XviD players by XviD codec instead generic or support ones.

There is no changes in ffdshow decode filter


All times are GMT +1. The time now is 05:57 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20