Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   Full screen problem using VMR-9 renderless build 812 *pics (http://forum.bsplayer.com/bug-reports-codecs/5447-full-screen-problem-using-vmr-9-renderless-build-812-pics.html)

mirkuma 13th September 2004 08:15 PM

Full screen problem using VMR-9 renderless build 812 *pics
 
I'm using Bsplayer to play movies on my TV via TVout.
Using Overlay mode 1 and 2, when I move movie to my TV and press F key the movie is displayed full screen using TV resolution. Option Pan scan (O key) only works with Overlay 1 renderer and not with Overlay 2 (I can live with that).
If I use VMR-9 mode (better movie quality when movie is resized) I also got full screen movie on TV (using F key), but it won't display subtitles.

VMR-9 (renderless) mode displays subtitles correctly but when i hit F key to put movie in full screen on my TV I can only see 1/4 of movie on TV...It seems that bsplayer use resolution from my primary monitor (1280x1024) when I resize movie to full screen and not from my TV resolution (768x576).

Also when i put my mouse down on TV under movie the full screen skin is swown on primary monitor and not on TV!


Im using GeForce4 Ti4200 with latest detonators/forceware drivers and latest TVTool in extension mode: LCD monitor 1280x1024@75Hz and TV 768x576@60Hz.

Garet_Jax 13th September 2004 08:21 PM

Re: Full screen problem using VMR-9 (renderless) build 811
 
Quote:

Originally Posted by mirkuma
If I use VMR-9 mode (better movie quality when movie is resized) I also got full screen movie on TV (using F key), but it won't display subtitles.

Have you tried "Draw subtitles to Overlay surface" in subtitles options?

mirkuma 13th September 2004 08:55 PM

Quote:

Have you tried "Draw subtitles to Overlay surface" in subtitles options?
Yes but doesn't work...

Can somebody confirm fullscreen VRM-9 (renderless) and "fullscreen-skin" bug usind two monitors (or monitor and TVout)?

P.S. What's the diference between VRM-9 and VRM9 (renderless) mode anyway?

bst 14th September 2004 09:52 AM

It's fixed in build 812.

mirkuma 14th September 2004 04:19 PM

OK VRM-9 renderless works now in full screen correctly, thanks, but picture has bad quality compare to VRM-9 / Overlay 1 / Overlay 2 mode!

Start some movie that begins with big starting text (movie title, staring...etc) in black background (Farenheit 9/11 for example)...you will notice that when movie is played in full screen, quality of 'in movie letters and picture' are bad (unclear edges). Subtitles are also not so good in quality (not so clear edges) comparing to Overlay mode 2 subtitles.

When video is in its original size, (not in full screen) it seems that there is no problem with quality in renderless mode.

It only hapens with VRM-9 renderless mode in full screen. Why?
Is image/movie incoreectly resized?

bst 14th September 2004 07:44 PM

Can't reproduce this here, picture is actually better, but we'll look into this.

mirkuma 14th September 2004 08:07 PM

Hm very strange..I have capture a frame in full screen mode, with print screen key.
If a use internal bsplayer capture comand there is no diference between screenshots.

It can be hardy noticed...(look for O, D or N characters/letters in Fellowship Adventure Group Inc text) on the begining of Farenheit 9/11 movie...
...also the OSD mesage Pause has the same artifacts. It is a kind of blury saw effect.
VRM9 mode is perfect! Renderless is not :-(

VRM-9 renderless.png (~160 KB, 1280x1024):
http://freeweb.siol.net/mirkuma/bspl...renderless.png

VRM-9.png (~180 K, 1280x1024B):
http://freeweb.siol.net/mirkuma/bspl...renderless.png

Edit: Images are no more needed, so I have remove them..links to images are stil working.

bst 15th September 2004 11:32 AM

Please try night build and choose VMR-9 renderless, rendering mode 2.

mirkuma 15th September 2004 11:55 AM

Thanks, I will gladly try that, but I can't find any night build in download page!
Can you provide me a direct link to night build here please?

mirkuma 15th September 2004 10:08 PM

Thank you bst, I have try night build, here are results:

Yes, VMR-9 (renderless) Mode2 works great, picture quality is equal to VMR-9 mode and much better than VMR-9 (renderless) Mode1.
But there are subtitles problems...Look at screenshot VMR-9_renderles_Mode2.png...subtitles are streched in hight!
In VMR-9 (renderless) Mode 1 subs are OK.

VRM-9 renderless Mode 2.png (~580 KB, 1280x1024):
http://freeweb.siol.net/mirkuma/bspl...rles_Mode2.png


VRM-9 renderless Mode 1.png (~616 KB, 1280x1024):
http://freeweb.siol.net/mirkuma/bspl...rles_Mode1.png

Edit: Images are no more needed, so I have remove them..links to images are stil working.

bst 16th September 2004 09:54 AM

Should be ok in latest night build.

mirkuma 16th September 2004 11:08 AM

Thanks a lot! Will try it tonight and let you know if enverything is ok!
Edit: Subtitles are OK now in VRM9-renderless mode 2! Many thanks!

mirkuma 16th September 2004 11:51 PM

Sorry to bother you again, but there is another problem when using VMR-9 renderless mode 2 in secondary display (TV):

Movie isn't playing smoothly, BSPlayer uses 100% of CPU. With the same rendering mode there is no problem on primary display (monitor) about 30% CPU needed (P4 2,4GHz, GF4 4200Ti). No mather if I use window or full screen mode on TV, the movie isn't playing smoothly (100% CPU load))...but as soon I move movie window from TV to monitor the movie plays smoothly on monitor (30% CPU load)!

This problem only occours with VMR-9 renderless mode 2, as VMR-9 renderless mode 1, VMR-9, Overlay 1 and Overlay 2 modes don't have any problems and runs/plays smoothly on both displays in full or in window mode (uses up to 30% CPU power).

Can you please also fix this?

mirkuma 2nd January 2005 08:09 PM

Any new info regarding 100% CPU load bug using VMR-9 renderless mode 2 in secondary display?
I can reproduce the same problems with ATI Radeon 9600 card so I thing that this is no driver related problem as the same bug occurs with Nvidia GeForce4200 Ti card.

trodas 5th January 2005 06:23 PM

mpeg2 + WinDVD6.00.6 filter + overlay mode2 = crash
 
Since WinDVD v6 GUI and UI suxx like hell, I want (for subtitles too) use BSplayer for mpeg2 HDTV video too. (BSplayer rules!)

I did not have any conflict with decoders, tought using filers from WinDVD v6.00.6 give me only half the height size output.
Source is HDTV mpeg2 stream, typicaly 1920x1080 pixels :roll:

I have no idea what is going on, honestly :? :(

DVDsubber can use the WinDVD filters pretty well for DVD decoding... hang on, what about try HDTV in DVDsubber too?

Damn, crash on Floating point division by zero. Same happens when I try BSplayer to play a HDTV mpeg2 with set any other video render type that overlay1 :evil: Damn!

Time to write a complete bugreport... :(


All times are GMT +1. The time now is 09:40 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20