Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   BUGS in BSplayer v1.35.823 (Normal/Pro) (http://forum.bsplayer.com/bug-reports-codecs/6695-bugs-bsplayer-v1-35-823-normal-pro.html)

Tizio 19th August 2005 10:14 PM

BUGS in BSplayer v1.35.823 (Normal/Pro)
 
THANK YOU FOR THE MANY FIXES!! :lol:
Here are the not yet fixed bugs:

BUGS:
- CD association not remembered in Windows ME systems

- When BSplayer updates the tray icon tooltip with a new Movie name, the icon is removed-then-recreated in the tray bar, instead the icon should stay loaded (it is possible to use the API call Shell_NotifyIcon with parameter NIM_MODIFY = 1 instead of parameter NIM_ADD = 0).

- Every time a device is opened, BSplayer tries to connect to address 0.0.0.0 port 80.

- Every time Playlist is opened->closed->reopened, its window is resized vertically. (this error occours only with skinned windows)

- When you start capture, Channel name changes to the channel number. eg.: "Channel One" -> "//24"

- When capturing videos, if the PAUSE button is pressed the displayed captured size freezes, but number of frames captured and seconds elapsed continues counting, then re-pressing the PAUSE button the size counter continues counting, but the resultant captured file is BAD! The playback is ridicolously fast and the audio is out of sinc.
This appens with NO Compression filters, and ONLY if the PAUSE button is pressed.

- Whenever the computer is restarted, the first time BSplayer is started the TV tuner is mute until the current channel is changed or BSplayer is restarted (my audio-in is Line-in).

- BSplayer doesn't recognise "." character sent by Girder!
This only appens in Windows2000/XP systems. In Windows 9.x "." character works.
AFAIK it's a BSplayer issue since Girder is able to send "." char to others applications.

- (Windows ME) When "Shutdown computer when finished" option is enabled, at the end of the movie the pc doesn't shutdown, it only log-off and then log-in (and the movie is re-played from the begin)

- Command line -ar doesn't work (http://forum.bsplayer.org/viewtopic.php?t=7037)

- BSI: Error with Audio paths (http://forum.bsplayer.org/viewtopic.php?t=3955), recently reported by khon here

- Audio: (Since tv capture exists) If for example audio source is Line-in and in "Capture settings" Line-in is selected, there is a sort of echo, this is because BSplayer sound is delayed in respect of Line-in one, and don't use Line-in sound only, but overlap Line-in sound with BSplayer sound.

- SKIN ENGINE: "Version" information text is not displayed in the skin (this bug is present from build 800, maybe also before).

- Oldskin.dll ENGINE: old actions 36,46,47,48,49 are not properly converted, correct values are respectively 78,83,84,90,91
Code:

OLD ACTIONS TABLE:

Action 36 = Close movie
Action 46 = Increase subtitle font size
Action 47 = Decrease subtitle font size
Action 48 = Increase brightness
Action 49 = Decrease brightness


Not working translations:
- In section [Strings] -> 88="N/A"


Missing translations:
- TAB Title in sutitle preferences -> "Subtitle properties"

- Menu -> "Teletext"

- About Window -> "version", "Registered to", "Icons created by", (Language) "by" (translator), Month abbrevation

- Teletext window title -> "TTX"

- Filter management -> Filter priority the whole Add media type dialog

- Playlist -> "Audio stream"

- Capture settings -> Configuration ->
Channel [displayed over the automatic scan button when scanning]
Channel [channel name when a channel is added]
Channel [channel name when a channel is auto added by automatic scan session]

- All Explorer shell menu items ->
Play in BSPlayer
Enqueue in BSPlayer
.....


Not reported but working translations:
- [WID17] section items ->
113="VobSub"
114="Enable VobSub support"
115="Load subtitles into memory"
116="For subtitles compressed with RAR, unrar.dll is required (http://www.rarlab.com/rar/UnRARDLL.exe)\nCompressed subtitles are always loaded into memory."

Tizio 22nd August 2005 01:27 AM

Slovak language file (made by artam) is not updated from about an year: http://forum.bsplayer.org/viewtopic.php?p=21287#21287

Tizio 22nd August 2005 03:43 PM

Bug in subtitles
Another bug in subtitles

I don't paste the links to already posted bugs to steal visibility to the original posters, but to keep the forum organized :wink:

bst 24th August 2005 10:37 PM

Most should be fixed in night build (here or here)

Quote:

- CD association not remembered in Windows ME systems
Audio CD is not currently supported under Win9x,Me

Quote:

- Every time a device is opened, BSplayer tries to connect to address 0.0.0.0 port 80.
BSplayer doesn't try to connect, must be some driver or other system component.

Quote:

- When capturing videos, if the PAUSE button is pressed the displayed captured size freezes, but number of frames captured and seconds elapsed continues counting, then re-pressing the PAUSE button the size counter continues counting, but the resultant captured file is BAD! The playback is ridicolously fast and the audio is out of sinc.
This appens with NO Compression filters, and ONLY if the PAUSE button is pressed.
Known bug, it will be fixed

Quote:

- BSplayer doesn't recognise "." character sent by Girder!
This only appens in Windows2000/XP systems. In Windows 9.x "." character works.
AFAIK it's a BSplayer issue since Girder is able to send "." char to others applications.
We'll look into this.

Quote:

- SKIN ENGINE: "Version" information text is not displayed in the skin (this bug is present from build 800, maybe also before)
It's not menat to be :) This is version of skin file, all 1.x version skins should have line: Version=1.00 under [BSPlayer.Skin]
section.

trodas 25th August 2005 12:52 AM

I hope the crash bug, when one switch Audio streams on the movie play get fixed too.

When I switch the streams (during play, of course, how else...) things are fine, yet only untill I click on close to exist BSplayer.
Then crash of the v1.35 come. Never happen for 1.30, tough... :roll: :(

trodas 25th August 2005 01:03 AM

Great, crashing after audiostreams switching stoped :wink: :)

Thank God... errr, bst! :!:


Errr, almost... :(

BSplayer v1.35.823, Unhandled exception at EIP: 00403F04
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Access violation at address 00403F04 in module 'bsplayer.exe'. Read of address 612E7362
EAccessViolation
, 0x005618C3, 0x00561AC1, 0x00455A3F, 0x0044CD8A, 0x77E11D0A, 0x77E13D4B, 0x77E13DB6, 0x71784803,

Bytes at EIP: 8B 4A F8 49 7C 10 F0 FF 4A F8 75 0A 50 8D 42 F8 E8 53

Normal video, but just 2 streams, and seeking. This is the result of the build and the video (Nixon, dual Spanish/English rip, BTW)

Tizio 25th August 2005 02:07 AM

Quote:

Originally Posted by bst
Quote:

- CD association not remembered in Windows ME systems
Audio CD is not currently supported under Win9x,Me

Ok, now it makes sense :)

Quote:

Originally Posted by bst
Quote:

- Every time a device is opened, BSplayer tries to connect to address 0.0.0.0 port 80.
BSplayer doesn't try to connect, must be some driver or other system component.

Strange since it didn't appened before, but thank you for telling that BSplayer doesn't try to connect, I'll investigate in my system configuration :wink:

Quote:

Originally Posted by bst
Quote:

- SKIN ENGINE: "Version" information text is not displayed in the skin (this bug is present from build 800, maybe also before)
It's not menat to be :) This is version of skin file, all 1.x version skins should have line: Version=1.00 under [BSPlayer.Skin]
section.

I didn't meant that "Version", I know that all 1.x version skins should have line Version=1.00 under [BSPlayer.Skin] section, I use that string in my Skin Editor too to check if the skin file is supported. The one I meant is the one present in [Display] section (extracted from TinaZ's Base skin "skin.ini" file):

[Display]
; x,y;<font name>,<size>,<style>;<Font color>
; style can be N - Nornal font
; B - Bold
; I - Italic
; U - Underline
; or combination of above, for ex. Bold italic -> BI

; Movie title/file name
Title=63,13;Arial,9,B;000000
; Max width of title, if it's longer it will be scrolled
MaxTitleWidth=240

;Version=253,88;Arial,8,B;71964F
MovInfo=205,43;Arial,9,N;000000
MovInfoMaxWidth=175
Status=311,13;Arial,9,N;000000
MovTimeLen=63,43;Arial,11,B;000000
MovTimeLenMaxWidth=135
sRepeat=63,33;Arial,7,N;000000
Subs=205,34;Arial,7,N;000000
SubsMaxWidth=162



Thank you very much for the fixes and for the replies in the forum :D

Tizio 25th August 2005 03:33 AM

BUG
- If you put audio default number in Audio settings, BSplayer doesn't play the setted audio stream when that stream is embedded in an OGM container, whereas using Audio=X in BSI files works!
(http://forum.bsplayer.org/viewtopic.php?t=7063)


Missing translations:
- Teletext -> Go to page

- Teletext -> Subpage

- Playlist (right pane when selecting TV tuner channels) -> tuner:

- (when .ogm files are opend) Menu -> Audio -> Audio streams -> -- Ogm streams --


Certainly fixed/solved bugs:
- CD Associations in Win 9.x/ME systems
- Tray icon updating problems
- Connection to address 0.0.0.0 port 80
- Command line -ar
- BSI error
- Not working translation in section [Strings] -> 88="N/A"
- "Shutdown computer when finished" under Windows ME

Tizio 29th August 2005 03:05 PM

BUGS:
http://forum.bsplayer.org/viewtopic.php?t=7076
http://forum.bsplayer.org/viewtopic.php?t=7083

Tizio 31st August 2005 08:44 PM

BUG:
Long file names (more than 54 chars) error

Tizio 3rd September 2005 05:09 PM

BUG:
If you try to do a frame-by-frame seek (PAUSE+ARROWS) when you go backward the AspectRatio changes to an unknown ratio (this only appens in FULLSCREEN mode).

Tizio 4th September 2005 12:19 PM

BUG:
Can't play locked files

sn00py 11th September 2005 05:24 AM

BSplayer v1.35.823 crashed on all mkv file
 
I installed the latest Matroska lite pack (v1.1.1) and I never able to play a MKV file again on BSplayer 1.35 (build 823) Pro. I thought it was the codec but I am able to play on VLC and Media Player, so the codec should not be an issue. Any help/bug fix will be much appreciated. Thx.

Looks more like the player issue.

BSplayer v1.35.823, Unhandled exception at EIP: 0050B2E0
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Access violation at address 0050B2E0 in module 'bsplayer.exe'. Read of address 00000000
EAccessViolation
, 0x005773BF, 0x005775BD, 0x004565E7, 0x0044D932, 0x77D48734, 0x77D48816, 0x77D4C63F, 0x77D4E905, 0x004CB1B1, 0x0044D932, 0x77D48734, 0x77D48816, 0x77D489CD, 0x77D496C7, 0x004562FC, 0x00579E24, 0x7C816D4F

Bytes at EIP: 8B 10 FF 52 14 8B F0 4E 85 F6 0F 8C 96 00 00 00 46 33

Tizio 11th September 2005 12:07 PM

@ sn00py
Try to not use codec paks!
First try to update your BSplayer version since a new one is out, then download the proper codec for MKV files (if you don't find it search BSplayer's forum for it, there are links in many posts).
If you uninstall codec paks re-register "quartz.dll" as mentioned here by adicoto :wink:


All times are GMT +1. The time now is 01:35 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20