Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   Can't seek backwards with this movie..?! (http://forum.bsplayer.com/bug-reports-codecs/8630-cant-seek-backwards-movie.html)

Juggalo 25th November 2007 11:04 AM

Can't seek backwards with this movie..?!
 
If I play this movie in BSplayer:

http://tinyurl.com/39p33q (25 MB, sorry couldn't find a smaller example that demonstrates this bug, alternative link)

I can't seek backwards. When I press the left cursor key, it jumps back half a sec or so, but when I keep pressing the left arrow repeatedly or keep it down, it doesn't seek back further than half a sec where I was.

Note that seeking forward works ok.

Can you please fix this????

Tizio 26th November 2007 05:52 PM

I don't know if it's this specific file that has problems, I remember I used to seek backwards Chobits ogm serie in the past.. I don't have it here to test, sorry.
Anyway this file doesn't let you seek forward by 1 second per hit, but 5 seconds per hit, maybe it's a compression issue. Use Jump Backward (default key is ",") instead of Seek :wink:

J7N 27th November 2007 09:00 AM

Playing file backwards is much more difficult because of the inter-frame compression used in most formats. To jump backwards an arbitrary number of frames the player must decode all video from the last keyframe. Keyframes in MPEG-4 are added in rather large intervals, normally every 5-10 seconds (variable). While jumping forward by a small step like 0.5 seconds the decoder needs only to process about 12 frames.

Also I suppose during normal forward decoding the system is pre-buffering a small amount of data.

adicoto 27th November 2007 02:17 PM

OGM splitter it's the fault.

Ico-man 28th November 2007 10:44 AM

OGM rewind feature
 
We have tested the supplied video sample on several computers, and we found both ff and rew (2s steps) work without any problem on all systems.

Adicoto may be right there, please try to uninstall all codecs and install only the ones you need for your video files (Use G-spot to find out which codecs are missing).
Also try to use "," and "." buttons to ff and rew video, the skin (buttons) itself may be corrupted. Try to use default skin and see if it helps.

Let us know if you manage to solve the issue.

adicoto 28th November 2007 07:40 PM

The error reported here it's about FF and REW frame by frame not about jump 1, 2 or 10 seconds. Gabest OGG splitter (that I usually use) don't allow you to do a frame by frame rewind of the file just until the last keyframe played. It doesn't allow you to go back more then that keyframe.
Uninstalled Gabest, default becomes Nero OGG splitter. No luck with it either.
So, I think adicoto it's not right :cry: , the fault it's elswhere.

@ Ico-man
Wich splitter do you use ?


All times are GMT +1. The time now is 02:52 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20