Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   Subtitle resizing & screen resolution (http://forum.bsplayer.com/bug-reports-codecs/9045-subtitle-resizing-screen-resolution.html)

Seregwethrin 2nd October 2008 09:03 PM

Subtitle resizing & screen resolution
 
Hello;

I'm using 22" monitor. HD movies are not resized too much so subtitles looks great. But dvdrip movies are resized too much, about 3 times when watching in fullscreen mode and subtitles looks too bad. Please look at the pictures:

Dvdrip movie (original: 624 * 352, resized to: 1680 * something)
http://img528.imageshack.us/img528/7127/bssub1sz0.jpg

HD movie (original: 1280 * 528, resized to: 1680 * something)
http://img517.imageshack.us/img517/8599/bssub2jx1.jpg


How can i fix this problem? Is there a way?

BSPeter 2nd October 2008 10:37 PM

Type of moviefile?
Are we talking external subtitles? Type?
:wink:

Seregwethrin 2nd October 2008 10:52 PM

Of course with external subtitle .srt or .sub files. I'm working with subtitles over 2 years dude i'm not a beginner :)

First is a dvdrip movie (40 minute 350mb size) and second one is a hd movie. Type is not important, problem is at resolution. I write resolutions at first post. BSplayer is not using font-size increasing for subtitles. It enlargements subtitles like an image. So if movie's resolution increases much (dvdrip movies has low resolution so increases much in fullscreen), subtitles cause that problem.

I tried to change video rendering mode but none of options solved the problem.

Also I tried "Draw subtitles to Overlay surface" as enabled at Subtitles options. I though it must fix the problem but didn't. (At some other players the option like "subtitles overlay movie" solves the problem, but not at bsplayer.)

Seregwethrin 2nd October 2008 11:17 PM

The low-resolution movie (dvdrip type)
http://img215.imageshack.us/img215/17/dvdripss1kw7.jpg (original res)
http://img373.imageshack.us/img373/5...dripss2vs7.jpg (fullscreen, the problem)

The high-resolution movie (hd type)
http://img261.imageshack.us/img261/9946/hdss1tr0.jpg (original res)
http://img206.imageshack.us/img206/9199/hdss2mw0.jpg (fullscreen, no problem)

I really want to solve this problem :)

adicoto 3rd October 2008 06:27 AM

In subtitles preferences, please try to disable "auto resize subtitle and OSD font" and enable "auto resize font if line too long"

I assume you are using windows XP and not Vista and that you are using a fairly new release of BSPlayer. Some 1 year ago it was a release who had this bug, I hope it's not the case.

LE: after looking at the images you provided I really believe you are using windows vista. ;) .

Seregwethrin 3rd October 2008 08:38 AM

It's a little better but font is still resizing as an image and still not useful.

Also it's not a solution. Now subtitle font is changing for per movie. I need to set font size everytime before watching a movie with this option disabled.

http://img442.imageshack.us/img442/8139/newbs1mn4.jpg (dvdrip fullscreen, still has the problem but a little less)
http://img101.imageshack.us/img101/474/newbs2dy9.jpg (hd fullscreen)

Quote:

I assume you are using windows XP and not Vista and that you are using a fairly new release of BSPlayer. Some 1 year ago it was a release who had this bug, I hope it's not the case.

LE: after looking at the images you provided I really believe you are using windows vista. Wink .
I'm using Vista (x64) mate :). And I'm also using the latest version of bsplayer, 2.31

Tizio 3rd October 2008 01:02 PM

Disable the "Draw subtitles to Overlay surface" option (CTRL+P -> Subtitles -> Subtitle properties) and you problem shoulg get fixed :roll:

Seregwethrin 3rd October 2008 01:15 PM

Nope, not fixed. Subtitles still enlarge as an image not text.

Tizio 3rd October 2008 01:29 PM

And the rendering mode you use is?
Try to change it (CTRL+P -> Video -> Video rendering -> Rendering mode)

Seregwethrin 3rd October 2008 01:32 PM

I've already tried a lot of combination but none of them solved. Maybe you can say your options ?

Seregwethrin 3rd October 2008 05:34 PM

Draw subtitles overlay surface: unchecked

Renderin mode: overlay: Internal Renderer RGB Overlay or Internal Renderer RGB or Internal Renderer DirectDraw Surface

Resize OSD and subtitle font automaticly: unchecked

With these options everything looks great. No Vista Aero problem, no font resize as image problem. Just useful :). But one problem, on fullscreen mode subtitles good. But when you use normal mode, original resolution or lesser, subtitles still have same font. Maybe this can be fixed other releases.
http://img401.imageshack.us/img401/6868/bssonoa8.jpg

Thanks for everything bs professionals :)

Tizio 4th October 2008 11:00 AM

Finally it works :D
Anyway my options are all at DEFAULT (WinXP):

Video renderer: Internal renderer overlay (default)
Draw subtitles to Overlay surface: unchecked
Auto resize font if line is too long: unchecked
Resize OSD and subtitle font automatically: checked

Seregwethrin 4th October 2008 12:23 PM

Not default on Vista mate :)


All times are GMT +1. The time now is 10:19 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20