Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Feature Requests, Feedback And Suggestions

Feature Requests, Feedback And Suggestions Post your suggestions and feature requests here, what would you like to use in BS.Player. Any feedback is appreciated and will be reviewed by our team.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 15th November 2003
Junior Member
BS.player Regular User
 
Join Date: Nov 2003
Posts: 20
Rep Power: 0
MaxB is an unknown quantity at this point
Default Overlay and subtitle "features"

I actually never understood why filters like DivXG400 or DirectVobSub are loaded ONLY when using Overlay mode 2. Most other players use these filters no mather what "overlay mode" is being used, or if they use overlay at all. What's the deal with that? Why can't these filters be loaded even if there is no overlay? :?

Now in 1.00.800 I see that these filters are not loaded in any case! Other players load them, bug BSPlayer don't. Is that a bug or yet another "feature"?

BTW don't write that BSPlayer has it's own subtitle support, because they are not drawn to overlay if you select overlay mode 2, and when they are drawn, they are displayed over the picture - DivXG400 adds black bars on the top and the bottom of the picture and tries to write subtitles to those black bars as much as possible.
Reply With Quote
  #2 (permalink)  
Old 16th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 5
Rep Power: 0
Harts is an unknown quantity at this point
Default

Same problem here. I just want to use vobsub for displaying subtitles, because Bsplayer can't play all the sub formats I need. :P But now (bsplayer ver 1.0)the directvobsub doesn't load at all.
Reply With Quote
  #3 (permalink)  
Old 20th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 8
Rep Power: 0
RainyShadow is an unknown quantity at this point
Default try newer DivXG400

DivXG400 have "Force" loading option in newer versions
Reply With Quote
  #4 (permalink)  
Old 20th November 2003
Junior Member
BS.player Regular User
 
Join Date: Nov 2003
Posts: 20
Rep Power: 0
MaxB is an unknown quantity at this point
Default Re: try newer DivXG400

Quote:
Originally Posted by RainyShadow
DivXG400 have "Force" loading option in newer versions
Doesn't work!

bst, please answer us if this is a compatibility issue between BSPlayer and DivXG400/DirectVobSub or something else! Will newer builds support DS filters that display subtitles, and will they load in all modes and not only in overlay mode 2?
Reply With Quote
  #5 (permalink)  
Old 21st November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 5
Rep Power: 0
Harts is an unknown quantity at this point
Default

Yes, bst, please answer our question.
Reply With Quote
  #6 (permalink)  
Old 26th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 5
Rep Power: 0
Harts is an unknown quantity at this point
Default Re: try newer DivXG400

MaxB, can you get the directvobsub working with the new bsplayer version 1.00 RC1 Build 803 released (24 Nov 2003)? I still can't. If I have ffdshow and vobsub installed, and I switch to video 2 mode from bsplayer and change one ffdshow option (I don't remember its name, "use videomixer" or smth), then directvobsub loads when the film has subtitles, but ffdshow doesn't load anymore:( I just can't get them both working in the same time using bsplayer...
Reply With Quote
  #7 (permalink)  
Old 27th November 2003
Junior Member
BS.player Regular User
 
Join Date: Nov 2003
Posts: 20
Rep Power: 0
MaxB is an unknown quantity at this point
Default Re: try newer DivXG400

Quote:
Originally Posted by Harts
MaxB, can you get the directvobsub working with the new bsplayer version 1.00 RC1 Build 803 released (24 Nov 2003)? I still can't. If I have ffdshow and vobsub installed, and I switch to video 2 mode from bsplayer and change one ffdshow option (I don't remember its name, "use videomixer" or smth), then directvobsub loads when the film has subtitles, but ffdshow doesn't load anymore:( I just can't get them both working in the same time using bsplayer...
Similar situation here... After doing what you said you have done (and undoing any changes), Build 803 won't even show picture! Maybe after restart will help... Actually, I don't care. I returned back to 0.86 - I really don't understand what's the deal with these filters when every other player (except of that crappy DivX Player) can use them.
Reply With Quote
  #8 (permalink)  
Old 11th December 2003
Junior Member
BS.Player Newbie
 
Join Date: Dec 2003
Posts: 1
Rep Power: 0
newells is an unknown quantity at this point
Default

I could make the DirectVobSub load and working sometimes. The other times makes the computer crash. The same happened with the .86 version. I don't know why. I use the extend to 4:3 option a lot, because it lets me place the overlay subtitle outside the movie, on the black bars, when it is 16:9. That option should be on the next version of bsplayer, or fix the crash problem. Perhaps make the DirectVobSub not load when I use BsPlayer.
Reply With Quote
  #9 (permalink)  
Old 16th December 2003
Junior Member
BS.player Regular User
 
Join Date: Apr 2003
Posts: 28
Rep Power: 0
Pnar is an unknown quantity at this point
Default

in my case, directvobsub loads but doesn't find the subtitles (empty listbox), whith same .mkv file perfectly working in mpc AND wmp9 (vobsub autoloads and displays the list of subs ...)

weird ???
Reply With Quote
  #10 (permalink)  
Old 6th March 2004
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 5
Rep Power: 0
Harts is an unknown quantity at this point
Default

Heh, it isn't still fixed. Would you please fix it, so I could use my favorite video player (bsplayer) with ffdshow and use directvobsub for displaying subs...
Reply With Quote
  #11 (permalink)  
Old 6th March 2004
Junior Member
BS.player Regular User
 
Join Date: Apr 2003
Posts: 28
Rep Power: 0
Pnar is an unknown quantity at this point
Default

you're right Harts.

I've switched to mpc just for this feature, but I'd rather use bsplayer if I could (matroska is nowadays an inevitable container) ...
Reply With Quote
  #12 (permalink)  
Old 20th March 2004
Junior Member
BS.Player Newbie
 
Join Date: Mar 2004
Posts: 2
Rep Power: 0
bkornel is an unknown quantity at this point
Default VobSub

ffdshow -> codec -> Use overlay mixer -> YES
bsplayer -> preferences -> Overlay Mode 2 -> YES

Since using this combination I havent encountered problems with .mkv subtitles.

Btw. uptodate ffdshow&bsplayer
Reply With Quote
  #13 (permalink)  
Old 24th March 2004
Junior Member
BS.Player Newbie
 
Join Date: Mar 2004
Posts: 1
Rep Power: 0
Kei-Haesen is an unknown quantity at this point
Default Re: VobSub

Quote:
Originally Posted by bkornel
Since using this combination I havent encountered problems with .mkv subtitles.
this problem don't concern MKV files. Here is the problem i think :
One video (video.avi) and one subtitle (video.ssa)
Before : bsplayer 0.86 auto-loaded Directvobsub and showed the subtitle.
Now : Direct Vobsub is not loaded with Bsplayer 1.00+ (it works with other players like MPC for example)
How can we resolve that please
Reply With Quote
  #14 (permalink)  
Old 21st April 2004
Junior Member
BS.Player Newbie
 
Join Date: Apr 2004
Posts: 5
Rep Power: 0
neviden is an unknown quantity at this point
Default

It's posible to use external subtitles in bsplayer. Here is how:

- disable subtitles in BSPlayer, use Overlay 2
- ffdshow -> Tray & dialog setings -> show tray icon -> ON
- start movie, click ffdshow
- ffdshow -> subtitles -> ON
- ffdshow -> subtitles -> leterbox -> .....
- ffdshow -> overlay -> output -> use overlay mixer -> ON

this should work..
Reply With Quote
  #15 (permalink)  
Old 21st April 2004
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,163
Rep Power: 27
adicoto is on a distinguished road
Default

HAve you tryied build 808, download page, under nightly builds ?
Reply With Quote
  #16 (permalink)  
Old 22nd April 2004
Junior Member
BS.Player Newbie
 
Join Date: Apr 2004
Posts: 5
Rep Power: 0
neviden is an unknown quantity at this point
Default

Yes, I have tried this with 808, and it still doesn't load vobsub or divxg400. It starts divxg400 if i force it to run, but divxg400 quits right away.

FFdshow and ReClock do work. FFdshow can also show it's subtitles.
Reply With Quote
Reply

Tags
features, overlay, subtitle

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 04:46 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20