Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 13th July 2002
Junior Member
BS.Player Newbie
 
Join Date: Jul 2002
Posts: 1
Rep Power: 0
syntholik is an unknown quantity at this point
Default dolby digital 5.1 not working. I cannot figure out why

Hi all,

I have an audiophile 2496 card using the spdif output to my AVR-520 receiver. I am trying to play ac3 dolby digital 5.1 divx's but my receiver is only seeing the bitstream as pcm 2 channel digital audio (it does play but not 5.1) I installed the audiofilters.zip from doom9 but that only allowed me to actually hear the sound (but still 2 channel) I set the audio format to 6 channel but that doesnt seem to change anything. One of the audio filters is showing 2 channel DOLBY SURROUND and cannot change it. the 5.1 is greyed out. (I cant remember which filter I was looking at now) another one of them did show the audio as ac3/48khz/5.1 so the content is okay (I tried it with different divx's so it isnt the divx itself) and another filter is showing it's using directsound.. is this normal? could directsound be corrupting the bitstream or downmixing it somehow?

I am really at a loss.. and would appreciate any assistance that anyone could provide!

Thanks
Reply With Quote
  #2 (permalink)  
Old 3rd August 2002
Junior Member
BS.Player Newbie
 
Join Date: Jul 2002
Posts: 7
Rep Power: 0
techguru is an unknown quantity at this point
Default

To have proper Dolby Digital 5.1 output you need to use SPDIF properly.

This is what you need to do! =)

Configure BSPlayer:
Start BSPlayer, go to options (preferences).

1. On first tab, make sure "Don't load AC3 settings" is NOT checked.

2. On "Audio" tab, "Disable equa..." should be checked!

3. "For AC3 decoding use" must be "Intervideo Audio decoder".
Output device can be either DirectSound or WaveOut, I myself get clicking Dolby Digital with WaveOut, but everything runs fine with DirectSound.

4. On "InterVideo AC3" tab select "Enable S/PDIF output".


Ok, now BSplayer is correctly configured. Now comes the fun part.
You must have a version of InterVideo Audio Decoder that can handle SPDIF output, not all versions do I believe. I am not sure if the version that comes from doom9 works, actually I think it doesn't.

To find out if it does you now play a movie with Dolby Digital 5.1. Hook up your reciever to the SPDIF out from your soundcard. Rightclick the movie itself, select "Intervideo ..." and see if SPDIF is selected, if it is you should have 5.1 sound from your reciever by now! =)

If Dolby Surround is checked you will need to uninstall Intervideo codec and install another version.

Good luck!
Reply With Quote
  #3 (permalink)  
Old 30th June 2004
Junior Member
BS.Player Newbie
 
Join Date: Jun 2004
Posts: 1
Rep Power: 0
knight_of_ni is an unknown quantity at this point
Default

I couldn't get 5.1 audio through spdif. I set the intervideo decoder from preferences to spdif but when I close bsplayer or open another file, it resets to analog. This is very annoying, having to switch manually every time you open a file. I installed version 0.86 again and it works as it should!
Reply With Quote
Reply

Tags
digital, dolby, figure, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 04:41 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19