Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   Subtitle in Unicode (http://forum.bsplayer.com/general-talk-support/4275-subtitle-unicode.html)

videotree 23rd March 2004 04:46 PM

Subtitle in Unicode
 
I edited a .srt file and saved it as Unicode (or rich-text) with a .srt extension but BSPlayer does not load it. Does anyone know how to display subtitle in language other than English. Please input. Thanks.

adicoto 23rd March 2004 05:35 PM

Use text files for subtitles. In options->preferences->subtitles->font, select the script more suitable for your location (IE, i use central european for my language to be dislpayed correctly)

videotree 25th March 2004 05:36 PM

Thank you Adicoto. If I saved the text file using encoding ANSI, I lost the Unicode characters. If I saved using encoding UNICODE, BSplayer does not recognize it. Any other hints, please!

adicoto 25th March 2004 06:48 PM

So, let's see if we talk the same language.
1. You open notepad (text based editor)
2. Change keyboard layout to your mother-tongue
3. Type the subtitle using the new layout (not combinations of alt+ )
4. Save the subtitle as a text file, using txt extension.
5. Open the file again. Do you see the special chars speciffic to your country ? If not, then you don't installed Windows with support for your language. But this is not fatal for BSPlayer. If you see them, all is ok.
6. Open a video file with BSPlayer. Load the subtitle with BSPlayer. Go to font options and select a true type font (that support your language) and select the script suitable for your country.

So, after doing all that you can't see the subtitle correct ?

ajnakata 30th June 2005 10:03 AM

After following to your suggestion, i still cant load it...

giddybird 30th June 2005 02:51 PM

Quote:

Originally Posted by adicoto
So, let's see if we talk the same language.
1. You open notepad (text based editor)
2. Change keyboard layout to your mother-tongue
3. Type the subtitle using the new layout (not combinations of alt+ )
4. Save the subtitle as a text file, using txt extension.
5. Open the file again. Do you see the special chars speciffic to your country ? If not, then you don't installed Windows with support for your language. But this is not fatal for BSPlayer. If you see them, all is ok.
6. Open a video file with BSPlayer. Load the subtitle with BSPlayer. Go to font options and select a true type font (that support your language) and select the script suitable for your country.

So, after doing all that you can't see the subtitle correct ?

Hi, adicoto, i saw someone posted the same question which i intend to ask u. I have problem viewing the traditional chinese character on my bsplayer. Can you guide me. Appreciate your help.

Tizio 30th June 2005 03:12 PM

Quote:

Originally Posted by ajnakata
After following to your suggestion, i still cant load it...

If you have WindowsXP, the notepad version is different from the Windows 9.x/ME one!!
With XP version you can save texts with Unicode charset, so if you want to try the adicoto suggestion, when saving your text file, save it throught the menu item File -> Save as..., and then at bottom of the Save as window select ANSI.

I hope that these instructions could help also giddybird :wink:

giddybird 30th June 2005 03:19 PM

Quote:

Originally Posted by Tizio
Quote:

Originally Posted by ajnakata
After following to your suggestion, i still cant load it...

If you have WindowsXP, the notepad version is different from the Windows 9.x/ME one!!
With XP version you can save texts with Unicode charset, so if you want to try the adicoto suggestion, when saving your text file, save it throught the menu item File -> Save as..., and then at bottom of the Save as window select ANSI.

I hope that these instructions could help also giddybird :wink:

Wow, it sounds a bit complicated for me. :roll: I'll try later. Anyway, thanks for instruction.

Tizio 30th June 2005 03:23 PM

Not so complicated :wink: you only have to save the file with "Save as" instead of only "Save", and in that dialog window select the ANSI code.

But if you have problems, just post a message and I (or other users) will try to help you :)

ajnakata 1st July 2005 03:05 AM

It cant work again. After changing the subtitle file into Ansi, Bsplayer even cant open the movie file!!!!!!

dankoi 14th May 2016 07:05 AM

Go to
Start - Control Panel - Change display language - Keyboard and.. - Change Keyboards and put you language as default and first into the list


All times are GMT +1. The time now is 01:20 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20