Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23rd March 2004
Junior Member
BS.Player Newbie
 
Join Date: Mar 2004
Posts: 2
Rep Power: 0
videotree is an unknown quantity at this point
Default Subtitle in Unicode

I edited a .srt file and saved it as Unicode (or rich-text) with a .srt extension but BSPlayer does not load it. Does anyone know how to display subtitle in language other than English. Please input. Thanks.
Reply With Quote
  #2 (permalink)  
Old 23rd March 2004
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Use text files for subtitles. In options->preferences->subtitles->font, select the script more suitable for your location (IE, i use central european for my language to be dislpayed correctly)
Reply With Quote
  #3 (permalink)  
Old 25th March 2004
Junior Member
BS.Player Newbie
 
Join Date: Mar 2004
Posts: 2
Rep Power: 0
videotree is an unknown quantity at this point
Default

Thank you Adicoto. If I saved the text file using encoding ANSI, I lost the Unicode characters. If I saved using encoding UNICODE, BSplayer does not recognize it. Any other hints, please!
Reply With Quote
  #4 (permalink)  
Old 25th March 2004
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

So, let's see if we talk the same language.
1. You open notepad (text based editor)
2. Change keyboard layout to your mother-tongue
3. Type the subtitle using the new layout (not combinations of alt+ )
4. Save the subtitle as a text file, using txt extension.
5. Open the file again. Do you see the special chars speciffic to your country ? If not, then you don't installed Windows with support for your language. But this is not fatal for BSPlayer. If you see them, all is ok.
6. Open a video file with BSPlayer. Load the subtitle with BSPlayer. Go to font options and select a true type font (that support your language) and select the script suitable for your country.

So, after doing all that you can't see the subtitle correct ?
Reply With Quote
  #5 (permalink)  
Old 30th June 2005
Junior Member
BS.Player Newbie
 
Join Date: Jun 2005
Posts: 4
Rep Power: 0
ajnakata is an unknown quantity at this point
Default

After following to your suggestion, i still cant load it...
Reply With Quote
  #6 (permalink)  
Old 30th June 2005
Junior Member
BS.Player Newbie
 
Join Date: Jun 2005
Location: Malaysia
Posts: 2
Rep Power: 0
giddybird is an unknown quantity at this point
Default

Quote:
Originally Posted by adicoto
So, let's see if we talk the same language.
1. You open notepad (text based editor)
2. Change keyboard layout to your mother-tongue
3. Type the subtitle using the new layout (not combinations of alt+ )
4. Save the subtitle as a text file, using txt extension.
5. Open the file again. Do you see the special chars speciffic to your country ? If not, then you don't installed Windows with support for your language. But this is not fatal for BSPlayer. If you see them, all is ok.
6. Open a video file with BSPlayer. Load the subtitle with BSPlayer. Go to font options and select a true type font (that support your language) and select the script suitable for your country.

So, after doing all that you can't see the subtitle correct ?
Hi, adicoto, i saw someone posted the same question which i intend to ask u. I have problem viewing the traditional chinese character on my bsplayer. Can you guide me. Appreciate your help.
Reply With Quote
  #7 (permalink)  
Old 30th June 2005
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 20
Tizio will become famous soon enough
Default

Quote:
Originally Posted by ajnakata
After following to your suggestion, i still cant load it...
If you have WindowsXP, the notepad version is different from the Windows 9.x/ME one!!
With XP version you can save texts with Unicode charset, so if you want to try the adicoto suggestion, when saving your text file, save it throught the menu item File -> Save as..., and then at bottom of the Save as window select ANSI.

I hope that these instructions could help also giddybird
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #8 (permalink)  
Old 30th June 2005
Junior Member
BS.Player Newbie
 
Join Date: Jun 2005
Location: Malaysia
Posts: 2
Rep Power: 0
giddybird is an unknown quantity at this point
Default

Quote:
Originally Posted by Tizio
Quote:
Originally Posted by ajnakata
After following to your suggestion, i still cant load it...
If you have WindowsXP, the notepad version is different from the Windows 9.x/ME one!!
With XP version you can save texts with Unicode charset, so if you want to try the adicoto suggestion, when saving your text file, save it throught the menu item File -> Save as..., and then at bottom of the Save as window select ANSI.

I hope that these instructions could help also giddybird
Wow, it sounds a bit complicated for me. :roll: I'll try later. Anyway, thanks for instruction.
Reply With Quote
  #9 (permalink)  
Old 30th June 2005
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 20
Tizio will become famous soon enough
Default

Not so complicated you only have to save the file with "Save as" instead of only "Save", and in that dialog window select the ANSI code.

But if you have problems, just post a message and I (or other users) will try to help you :)
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #10 (permalink)  
Old 1st July 2005
Junior Member
BS.Player Newbie
 
Join Date: Jun 2005
Posts: 4
Rep Power: 0
ajnakata is an unknown quantity at this point
Default

It cant work again. After changing the subtitle file into Ansi, Bsplayer even cant open the movie file!!!!!!
Reply With Quote
  #11 (permalink)  
Old 14th May 2016
Junior Member
BS.Player Newbie
 
Join Date: May 2016
Posts: 1
Rep Power: 0
dankoi is on a distinguished road
Default

Go to
Start - Control Panel - Change display language - Keyboard and.. - Change Keyboards and put you language as default and first into the list
Reply With Quote
Reply

Tags
subtitle, unicode

Thread Tools
Display Modes

Posting Rules


All times are GMT +1. The time now is 07:09 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19