Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 5th April 2004
Junior Member
BS.Player Newbie
 
Join Date: Dec 2003
Posts: 5
Rep Power: 0
Bempel is an unknown quantity at this point
Default Some Problems with bsi-files

Hello,

I have a 2CD movie and I have 2 problems with the bsi-file. (I use version 1.00 RC1 of BSPlayer).
First problem is that the player doesn't change the resolution (800x600) by double-clicking on the bsi-file. The second problem is that the player doesn't automatically switch to fullscreen mode when the second cd is started. But I have to say that the second cd is started automaically.

Are the errors in my bsi-file, or are these problems general bugs of the player?
Thanks in advance for your help!!

Here are the two bsi-files I use for CD1 and CD2:

[Main]
Version=1.00
NumberCDs=2
CD=1

[Movie]
Title=JFK
Directory=.
Fname=JFK CD1.avi
AudioName1=English
AudioName2=French

[Subtitles]
Directory=.
Sub1=English|english.txt
Sub2=French|french.txt


[Options]
PanScan=0
FullScreen=1
ExitAtEnd=1
RunHD=2

[Autorun]
Language=English
HideBanner=0
Resolution=800x600x16
CloseLauncher=1
OlderVersionWarning=0
ShutDownWindows=0
WithExtras=0
WithPrograms=0
____________________________
[Main]
Version=1.00
NumberCDs=2
CD=2

[Movie]
Title=JFK
Directory=.
Fname2=JFK CD2.avi
AudioName1=English
AudioName2=French

[Subtitles]
Directory=.
Sub1=English|english.txt
Sub2=French|french.txt


[Options]
PanScan=0
FullScreen=1
ExitAtEnd=1
RunHD=2

[Autorun]
Language=English
HideBanner=0
Resolution=800x600x32
CloseLauncher=1
OlderVersionWarning=0
ShutDownWindows=0
WithExtras=0
WithPrograms=0
Reply With Quote
  #2 (permalink)  
Old 7th April 2004
xlv600's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Location: France
Posts: 218
Rep Power: 0
xlv600 is an unknown quantity at this point
Default

I've found the same bug on Fullscreen=1, it acts merely as a toggle :(

About, r?©solution, if the option Resolution=XxYxZ-H exists, it's in section [Options]. The [Autorun] section is not documented, and I guess it's not used by BSPlayer but a launcher (maybe HW_BSPlayer ???).
Reply With Quote
  #3 (permalink)  
Old 8th April 2004
Junior Member
BS.Player Newbie
 
Join Date: Dec 2003
Posts: 5
Rep Power: 0
Bempel is an unknown quantity at this point
Default

I' ve solved the first problem! You have to put Fullscreen=1 in the the first bsi-file on CD1, but Fullscreen=0 on the second ini-file on CD2. Doing it that way the player doesn't switch from fullscreen to "window"screen while changing to CD2!!

For the autorun section, I have my own method, and I dont have to use HW_BSPlayer

But the resolution problem at startup remains!

Bien le bonjours ?• la France !!
Reply With Quote
  #4 (permalink)  
Old 8th April 2004
Junior Member
BS.Player Newbie
 
Join Date: Dec 2003
Posts: 5
Rep Power: 0
Bempel is an unknown quantity at this point
Default

OK, I've solved all the Problems by myself now. But there is a new one that remains:
The Subdelay command in an bsi-file only accepts the time in the HH:MM:SS format. Is it possible to use this command with frames instead??
Reply With Quote
  #5 (permalink)  
Old 11th April 2004
Junior Member
BS.Player Newbie
 
Join Date: Apr 2004
Posts: 3
Rep Power: 0
LaStLiFe is an unknown quantity at this point
Default

Hi Bempel,

The SubDelay command only uses frames and not the HH:MM:SS format as you state or, at least, that's what the documentataion for "ini" files says.

Good luck.
Reply With Quote
  #6 (permalink)  
Old 15th April 2004
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Location: Greece
Posts: 115
Rep Power: 0
HackerWerger is an unknown quantity at this point
Default

@Bempel:

I suppose you are using HW maker. :)

If you do, I suggest you download the latest available version (RC3) as the previous versions had some bugs.

Now, if you use HW maker but you don't use HW launcher (aka HW BSplayer Autorun), you can deselect the checkbox on the up-right in the autorun tab.
The following text of your bsi file isn't necessary if you do not use HW launcher (as BSplayer ignores it) :

[Autorun]
Language=English
HideBanner=0
Resolution=800x600x16 <---- This line should be in [options] to work!
CloseLauncher=1
OlderVersionWarning=0
ShutDownWindows=0
WithExtras=0
WithPrograms=0
Reply With Quote
Reply

Tags
bsifiles, problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20